• Which the release of FS2020 we see an explosition of activity on the forun and of course we are very happy to see this. But having all questions about FS2020 in one forum becomes a bit messy. So therefore we would like to ask you all to use the following guidelines when posting your questions:

    • Tag FS2020 specific questions with the MSFS2020 tag.
    • Questions about making 3D assets can be posted in the 3D asset design forum. Either post them in the subforum of the modelling tool you use or in the general forum if they are general.
    • Questions about aircraft design can be posted in the Aircraft design forum
    • Questions about airport design can be posted in the FS2020 airport design forum. Once airport development tools have been updated for FS2020 you can post tool speciifc questions in the subforums of those tools as well of course.
    • Questions about terrain design can be posted in the FS2020 terrain design forum.
    • Questions about SimConnect can be posted in the SimConnect forum.

    Any other question that is not specific to an aspect of development or tool can be posted in the General chat forum.

    By following these guidelines we make sure that the forums remain easy to read for everybody and also that the right people can find your post to answer it.

MSFS Building into ground

Messages
462
Country
us-northcarolina
is this a Blender issue if the object is partly below the "cube" axis.. I am a total noob....lol...but a nice guy.

Greets
BobM.
 

Attachments

  • 25.JPG
    25.JPG
    25.9 KB · Views: 52

Pyscen

Resource contributor
Messages
2,526
Country
us-texas
No, not a Blender issue...

Look at the vertices at the bottom of the model. What are the z-axis values of the model?.
 
Messages
462
Country
us-northcarolina
I hate to ask but where is that (vertices) . Also..when I add this as a model and save and compile..Its pink and says user model...but if I go back "next time"..the model has disappeared from the list and it shows up in yellow as Library Object and if I build from that..the model will not be in ADE and I have to delete Library and re-add model everytime? Could it be that the guid for the model is the same as the library object (old fsx bgl) but its not in the library now?
 
Messages
193
Country
italy
Can you share a bigger screenshot?
Looks like the model Is tilted or the ground Is not flat
Can you also share a screen of the Blender file?

Also, you are talking about old fsx, Is this model an import? Maybe from modelconverterx? I've seen some strange result where scale and rotation can be not has expected and Need some work in Blender

Inviato dal mio Mi 9 Lite utilizzando Tapatalk
 
Messages
462
Country
us-northcarolina
Here's a larger pic of terminal.. The left end is in the ground as you can see.. This is an fsx landmark bgl96. I used model x to convert it and it had 4-5 files i guess. so I combined the gltf into one with Blender. I am not sure if that is where the problem is because being a Noob....lol..I didn't know how to get the model (not cube) above the axis so I exported it with the msfs toolkit etc and @rhumbaflappy was nice enough to get the textures right so I could see it.

Greets and salutations @mamu
 

Attachments

  • 26.JPG
    26.JPG
    329.2 KB · Views: 19
  • UNC1RLM-kint-smith-reynolds-modelLib.zip
    560.8 KB · Views: 11
  • getting model above axis  is that required to be out of ground.PNG
    getting model above axis is that required to be out of ground.PNG
    255.8 KB · Views: 23
Messages
193
Country
italy
ok got it
The blender file /gtlf is ok, althought the origin of your object is slighly above ground

You can, in the scenery editor:
toggle the snap to ground in the object properties window, once you have done that you can move your object up and down as you want
OR
lower it in blender,
in object mode, press A to select all object, than press G to move, press Z to move along Z axes, move your mouse to move the object, confirm with enter,
than, prior to export, make sure to press CTRL+A to make sure to apply all transformation

Anyway, your real problem in this case is the terrain/mesh, it is not flat
You can easily solve that by adding a polygon with terraforming option (falloff 1), or a terraforming rectangle, lot of choices here, screen attached is polygon+snap to ground off


2 question for you:
- i had hard time looking for that specific point in the aiport, that i realized you have photogrammetry off, I not a fan of that but hey, in this area it adds a lot to the airport and surrodings
- was that terminal demolished? no sign of it in bing/google sat imagery or google street maps either? Anyway, free to put everything you like in your scene!
 

Attachments

  • Screenshot (120).png
    Screenshot (120).png
    3 MB · Views: 22
Messages
462
Country
us-northcarolina
No this is an addon...the KINT Winston-Salem airport is almost dead. I am trying to liven up the joint...lol.. I worked for Piedmont Airlines (this was there home base) 50 years ago. They were bought out by USAir and then American and are a fraction of what they were. There are American flights out of Charlotte (KCLT) that are operated by Piedmont pilots mostly EMB 145's or Emb 170's....I even have a McDonalds Fly-thru to go in...lmao... I issue I have right now is adding objects thru ADE and have them show up in the models list. You can add them but then they seem to disappear (if you restart ADE)...they are no longer in the list and whats left is an object "black" showing as a library object..so you keep having to re-add back in and recompile for them to show up. Maybe since ADE offers 2-way..once I get object installed via the sim..maybe the model will stick in ADE....not your problem anyway. Thank you so much and I eagerly await Chapter 2....

Greets and the Best!!
 
Top