• Which the release of FS2020 we see an explosition of activity on the forun and of course we are very happy to see this. But having all questions about FS2020 in one forum becomes a bit messy. So therefore we would like to ask you all to use the following guidelines when posting your questions:

    • Tag FS2020 specific questions with the MSFS2020 tag.
    • Questions about making 3D assets can be posted in the 3D asset design forum. Either post them in the subforum of the modelling tool you use or in the general forum if they are general.
    • Questions about aircraft design can be posted in the Aircraft design forum
    • Questions about airport design can be posted in the FS2020 airport design forum. Once airport development tools have been updated for FS2020 you can post tool speciifc questions in the subforums of those tools as well of course.
    • Questions about terrain design can be posted in the FS2020 terrain design forum.
    • Questions about SimConnect can be posted in the SimConnect forum.

    Any other question that is not specific to an aspect of development or tool can be posted in the General chat forum.

    By following these guidelines we make sure that the forums remain easy to read for everybody and also that the right people can find your post to answer it.

P3D v5 Can’t click on anything AIFP

gadgets

Resource contributor
Messages
9,120
Country
ca-britishcolumbia
Thank you. I can report that your files do not cause any difficulty on my system. But, I don't have most of your add-ons.

I do not think the issue is related to scenery.cfg. Your scenery.cfg contains only stock scenery. More likely add-ons.cfg is at fault. It contains many add-ons - one or more of which I suspect is interacting problematically with something else on your system. That AIFP doesn't respond to a mouse click suggests AIFP may no longer be the active foreground application.

I suggest the following. Suffix the name of add-ons.cfg with ".xxx". This will disable the file and prevent its loading - by AIFP and everything else. Restart AIFP to see if the problem recurs. If it doesn't then re-enable add-ons.cfg, set all the ACTIVE items to "false" and repeat the exercise. (If it does, please let me know and I'll take another look.) Assuming the problem does not occur, close AIFP and reset one ACTIVE item to "true", then Restart AIFP. Repeat, setting another item to "true" each time, until the issue recurs. At that time , you will have identified at least one involved add-on. Reset that add-on's ACTIVE flag to "false", reset all ACTIVE items to true and test again. If all is OK, then your done. But, there may be more than one involved add-on, you may have to continue this exercise until you've examines every add-on.

I did note one possible anomaly in your add-ons.cfg. Discovery Path 14 contains "PATH=Q:\Prepar3D v5 Addons\Addon Scenery". Several other Discovery Paths point to sub-folders in that folder. Perhaps that causing you system to go into some sort of loop.
 
Messages
14
Country
france
@gadgets
Sorry for the late reply! I have good news.
I have been doing some testing all day and now I do understand how I get this bug!

I am going to try to explain as best as I can, this actually happened to me when I uninstalled an addon incorrectly (addon installed outside of p3d main folder, I got a warning message from p3d saying that it could not locate the scenery and that it would unload it. From that moment AIFP would not be clickable.

I would run the addon organizer from lorby and the same message would appear about a faulty xml installed. I checked the scenery.cfg removed the lines that were not supposed to be there and AIFP became clickable again.


I guess this was all about xml files and scenery.cfg.

any thoughts ?
 

gadgets

Resource contributor
Messages
9,120
Country
ca-britishcolumbia
This appears to confirm my assessment of nthabti's files. ie, that one or more add-ons are interactively negatively with some other element of your systems.
 
Messages
14
Country
france
That’s right! The xml was removed, the scenery was not in p3d greyed out section anymore, but still, AIFP was unclickable. Deleting these 2 faulty lines in my scenery.cfg made the trick.
 
Messages
14
Country
france
I can’t seem to reproduce the bug now. It was just 2 lines the layer and an entry location below.
I will send it here if I reproduce it in the next few days. I will probably do cause I install and uninstall stuff in my sim all the time.
 

gadgets

Resource contributor
Messages
9,120
Country
ca-britishcolumbia
nthabti. have you managed to isolate the culprit? If so, I'd be very interested in learning which add-on was at fault and what were the contents of it's entry in add-ons.cfg
 
Messages
3
Country
unitedkingdom
I'm also having the same issue.
I've only just come back to FS and creating AI flights.

I get as far as selecting the aircraft folder then from there I can't do anything else. As it's been mentioned the only way to get out of the program is via task manger.

I have just emailed you with the 2 cfg files you requested...

Okay, I must have your email address wrong as my email to you has come straight back!
 
Messages
3
Country
unitedkingdom
nthabti. have you managed to isolate the culprit? If so, I'd be very interested in learning which add-on was at fault and what were the contents of it's entry in add-ons.cfg
I was trying to email these files to you but the email keeps coming back.

Anyway, here are the 2 files you requested...
 

gadgets

Resource contributor
Messages
9,120
Country
ca-britishcolumbia
No files attached. The e-mail "bounce" message will tell you what's wrong. If the e-mail address, then you can e-mail to don at stuff4fs dot com.

That being said, unless these files illustrate the results of your testing as I have suggested here, they are unlikely to tell me anything immediately useful. If you have not already done so, I suggest you review this thread in detail to see the extent to which the experience of others applies to you
 
Top