• Which the release of FS2020 we see an explosition of activity on the forun and of course we are very happy to see this. But having all questions about FS2020 in one forum becomes a bit messy. So therefore we would like to ask you all to use the following guidelines when posting your questions:

    • Tag FS2020 specific questions with the MSFS2020 tag.
    • Questions about making 3D assets can be posted in the 3D asset design forum. Either post them in the subforum of the modelling tool you use or in the general forum if they are general.
    • Questions about aircraft design can be posted in the Aircraft design forum
    • Questions about airport design can be posted in the FS2020 airport design forum. Once airport development tools have been updated for FS2020 you can post tool speciifc questions in the subforums of those tools as well of course.
    • Questions about terrain design can be posted in the FS2020 terrain design forum.
    • Questions about SimConnect can be posted in the SimConnect forum.

    Any other question that is not specific to an aspect of development or tool can be posted in the General chat forum.

    By following these guidelines we make sure that the forums remain easy to read for everybody and also that the right people can find your post to answer it.

Can change in water level be fixed?

Messages
293
Country
italy
Love your answer Dick, i thought about the qgis way too, but suggesting It to John would have been really overwhelming
(Btw did you noticed the attributes table contains only changed atrributes?)

Anyways, It Is still strange John Is not be able to click the properties Window!

Inviato dal mio Mi 9 Lite utilizzando Tapatalk
 

rhumbaflappy

Administrator
Staff member
Resource contributor
Messages
4,819
Country
us-wisconsin
Here's easier:

I drew the polygon in the DevMode (hits the carpal tunnel pretty good), and then used the Gizmo to set the exact elevation of the poly:

Untitled.png
 
Messages
931
Country
australia
Thanks HEAPS Thalixte, mamu (more great tutorials but you have your real name there ;)) and Dick for your detailed help.

I was wondering (Dick) if I needed to draw a polygon around all the foreshores of the lake (as I did years ago when developing scenery for Sechelt for FSX as the stock shoreline was very 'rough' and inaccurate) but was hoping not to have to. And a zipped scenery ready to go the the community folder - truly amazing. I will try and work out how to load that into SDK to see what it contains.

Thalixte I read with interest that you used a 'rectangle with a ramp'. I had noticed that when taxiing around the lake the change in elevation of the water was greater at one 'end' than the other and so wondered if that was the reason (or maybe I misinterpreted 'ramp').

In my attempts to get this worked out TWICE after clicking on one of the 'windows' on the screen everything seemed to freeze and the screen lost contrast and the only thing I could do was to 'kill' the whole process. Not sure what caused that if it was recoverable or not by clicking on something else - hey I think I remember seeing one window with correct contrast (as if highlighted) which I clicked and everything came good again but not sure as so many things were going through my head at the time as I was getting frustrated.

I will work through them all a bit later after I get some jobs around the house done. I certainly have come a long way with SDK thanks to your assistance. My only other SDK 'project' was to 'place' satellite imagery from Google maps which worked out very well after a lot of 'learning'.
 

rhumbaflappy

Administrator
Staff member
Resource contributor
Messages
4,819
Country
us-wisconsin
In this case, you are only flattening with the polygon, and you can have a generous falloff (I used 30 meters). So the poly can be fairly rough.
 
Messages
931
Country
australia
I have now tried a flatten polygon (over the area where the line for change of surface altitude shows using ADE) which works nearly ok as it seems that the altitude of the water varies from one side of the lake to the other along that 'line'. What I am trying to describe is that the polygon needs to have a slight slope on it such as what would be achieved setting the altitudes of some of the vertices in the polygon like I did back in the 'good old days' (were they?) of FSX and the pathetic scenery at Sechelt on the land where I corrected it using polygons with different altitudes on different vertices to get the correct slope of the land.

Anyway at least the area used for takeoff and landing is now relatively flat.

[added later] I opened Dick's scenery with SDK to see what he did and I'm impressed with the amount of work he did 'tracing' out the shores of the lake to create a polygon with so many vertices. Maybe I should in all fairness use his scenery. At least it should overcome (I am assuming) the fact that the change of surface is higher on one side of the lake than the other. If I do that I am wondering what would happen if I remove 'myairport' (bgl) which contains the runway (as my scenery already has a runway), and leave the 'myshapes' (bgl) which contains the terraform polygon, would it still work.

And YES mamu I have no idea what you guys are talking about when you mention QGIS although I 'googled' it and found that (perhaps) it means Quantum GIS and it is about geospatial information and that too I have no idea. There is a web site OsGeo.

PROBLEM -
I tried TWICE to replicate what I see in two of mamu's video tutorial and for me it does NOT do what I see in the tutorial. Here is the work flow as I see it -
Tools > Project Editor > Project > New Project
A window opens to allow me to 'navigate' to my empty (Windows) folder
I enter the project name in lower case eg greenlake-water and press the ENTER key
Click on Create New Project

Now what happens here is that the 'wizard' opens (where you select Airport, Custom etc) yet in 2 of the tutorials (I only checked 2 including the latest mamu suggested above) a window opens with a heading ADD PACKAGE with places to enter TITLE, CREATOR and COMPANY NAME. This window does not open for me. I cannot see that I have done something wrong. Could someone please explain.
 
Last edited:
Messages
931
Country
australia
I decided that I should push on and try and create scenery using SDK for the experience and education if nothing else BUT...

This window does NOT open/display after I select CREATE NEW PROJECT (where the empty folder is selected to write the files to and the Project Name is entered) as it does in mamu's video tutorials.
I have watched the video many times and also ensured the folder selected is empty many times. Cannot understand this.
add_package.jpg
<<<<<< this does not appear after I Create New Project

Not sure if this matters but I continued on and added a polygon when after a few retries was able to select Terraforming in the Properties window without the window going blank as it did the other day - the method was to double mouse click on second line showing 'polygon' in the Scenery Editor which then also sets the camera into top down view and enabled selection of the terraforming 'parameter'. This is diffeernt from how mamu achieved the same thing.
Anyway something else I have learned and achieved.


Well I now need to know what Rhumbaflappy (Dick) did to the 'elevation' (Y axis) when he created his terraforming polygon. Did he leave the altitude alone or drag it higher or lower? Does it matter in this case (ensuring there is no abrupt level in the water)?

And there's something else. When the elevation is changed (Y axis) it displays the change which then becomes 0 if the user goes back to make changes and so he needs to remember how far he dragged on the Y axis if he wants to revert to the original height. Surely there is a way to reverse the action more easily?
 
Last edited:
Messages
293
Country
italy
I decided that I should push on and try and create scenery using SDK for the experience and education if nothing else BUT...

This window does NOT open/display after I select CREATE NEW PROJECT (where the empty folder is selected to write the files to and the Project Name is entered) as it does in mamu's video tutorials.
I have watched the video many times and also ensured the folder selected is empty many times. Cannot understand this.
View attachment 78666 <<<<<< this does not appear after I Create New Project

Not sure if this matters but I continued on and added a polygon when after a few retries was able to select Terraforming in the Properties window without the window going blank as it did the other day - the method was to double mouse click on second line showing 'polygon' in the Scenery Editor which then also sets the camera into top down view and enabled selection of the terraforming 'parameter'. This is diffeernt from how mamu achieved the same thing.
Anyway something else I have learned and achieved.


Well I now need to know what Rhumbaflappy (Dick) did to the 'elevation' (Y axis) when he created his terraforming polygon. Did he leave the altitude alone or drag it higher or lower? Does it matter in this case (ensuring there is no abrupt level in the water)?

And there's something else. When the elevation is changed (Y axis) it displays the change which then becomes 0 if the user goes back to make changes and so he needs to remember how far he dragged on the Y axis if he wants to revert to the original height. Surely there is a way to reverse the action more easily?


Hi John, the videos where made with SU6, in SU7 they changed some minor things in the wizards (as they alway do....). The package in SU7 is created automatically, so that additional window is skipped

About your issue with the inability to click on the windows, i suggest to reset the developer mode user interface by deleting the files DevMode.xml and imgui.ini , they are located in
C:\Users\YOURUSERNAME\AppData\Local\Packages\Microsoft.FlightSimulator_8wekyb3d8bbwe\LocalState
they are safe to be deleted as the sim will re create them for you

then

- use render scale 100%, fullscreen, monitor resolution = sim resolution
- don't dock any window, avoid moving them to the monitor edges, so they will be alway "semi-transparent" (in your screenshot the properties window is opaque/black background, this is the reason why you can't click on it (infact, if you ALT+TAB,
when a window is docked is like you have another task in your computer open :D )




And about the last question ...if you keep the gizmo window open it will show you the values of your object, including the Z value (altitude) (translate / lat / long / alt), so as soon as you create a new polygon, before moving it up and down
you could note down its value, and manually type it in the gizmo window to reset

(since with polygons you are dealing with geo-shapes, longitude is the X value, latitude is the Y value and altitude is the Z value)
 
Messages
931
Country
australia
Thanks mamu for your detailed instructions. I had asked earlier if the work flow had changed and you advised that it has not and that is why I was (almost) tearing my hair out (and have a look how much I have left:eek: - unlike yours :D) trying to duplicate what I saw in the video especially when I found I could not select any parameters/elements in the properties window for the polygon (without everything going blank), but then later from trial and error found that I needed to double click on "Polygon ( )*" in the scenery editor (after selecting ADD). I see now that add package happens automatically and I was wondering about that as Creator and Company display as 'defaults' is the Project Editor. I guess the package name prompt appears later - I didn't notice.
It seems (from what I think I remember seeing) that the 'axis' for a polygon are different from the 'gizmo' displayed where you can drag the polygon up and down (altitude) I see Y not Z

Also I have found that the changing of properties for the polygon is VERY problematical. Just now I went in to 'play around' with it and found once again that attempting to select a parameter/element causes it to go blank again. I double clicked on the Polygon ( )* which made no improvement. I did this and that and all of a sudden selecting a parameter/element in the properties did not make it go blank. Quite annoying. Unless of course there is a 'trick' to enable 'editing' of the properties parameters/elements?

add_polygon_object.jpg


polygon_gyzmo.jpg
 
Last edited:
Messages
931
Country
australia
Update

I deleted those files and now have big problems. Firstly I cannot open my last 'project' (error cannot open) but that could be for a number of reasons as I can still open Dicks 'project' which is attached somewhere here.

BUT more importantly I cannot control the 'camera' as I could before. Pressing the W, A, S and D keys do nothing and the only 'control' I have is using the ALT key and dragging with the left mouse button pressed.
I cannot change the altitude of the camera nor can I scroll left, right, forward, backwards.
Thankfully I still have those deleted files and will restore them.
Any ideas what could cause this?
 
Messages
293
Country
italy
Update

I deleted those files and now have big problems. Firstly I cannot open my last 'project' (error cannot open) but that could be for a number of reasons as I can still open Dicks 'project' which is attached somewhere here.

BUT more importantly I cannot control the 'camera' as I could before. Pressing the W, A, S and D keys do nothing and the only 'control' I have is using the ALT key and dragging with the left mouse button pressed.
I cannot change the altitude of the camera nor can I scroll left, right, forward, backwards.
Thankfully I still have those deleted files and will restore them.
Any ideas what could cause this?

yep, last opened project are store in the .xml one

I'm sorry about the WASD, it is an easy fix, they are still there, open the Developer Camera Settings and adjust the traslation speed to a right value (obviously the default -100% is wrong!)
 
Messages
931
Country
australia
Thanks mamu

YES I could understand that last opened project would be lost when the files were deleted. I was trying to open the 'top' xml file instead of the one where the packagedefinitions etc folder is.

I found the the developer camera was set to -85% and changed it to (+) 85% which fixed everything.
 
Last edited:
Messages
931
Country
australia
Could someone please advise what caused the change in water level as I want to note that in my readme (for list of what I did in initial version eg 'flattened part of Green Lake caused by...') for possible upload of my airport as freeware.
I believe it is Bing Maps tiles?
 
Last edited:
Top