• Which the release of FS2020 we see an explosition of activity on the forun and of course we are very happy to see this. But having all questions about FS2020 in one forum becomes a bit messy. So therefore we would like to ask you all to use the following guidelines when posting your questions:

    • Tag FS2020 specific questions with the MSFS2020 tag.
    • Questions about making 3D assets can be posted in the 3D asset design forum. Either post them in the subforum of the modelling tool you use or in the general forum if they are general.
    • Questions about aircraft design can be posted in the Aircraft design forum
    • Questions about airport design can be posted in the FS2020 airport design forum. Once airport development tools have been updated for FS2020 you can post tool speciifc questions in the subforums of those tools as well of course.
    • Questions about terrain design can be posted in the FS2020 terrain design forum.
    • Questions about SimConnect can be posted in the SimConnect forum.

    Any other question that is not specific to an aspect of development or tool can be posted in the General chat forum.

    By following these guidelines we make sure that the forums remain easy to read for everybody and also that the right people can find your post to answer it.

P3D v5 can not add an object in the library

Messages
23
Country
spain
Hi

im facing this issue when I try to add an object in the library.

any idea how to solve this problem?

Please see the attached pic.


thanks
 

Attachments

  • Screenshot (516).png
    Screenshot (516).png
    375.9 KB · Views: 18

scruffyduck

Administrator
Staff member
FSDevConf team
Resource contributor
Messages
34,595
Country
unitedkingdom
This is a known issue with very large objects in a library. What version of ADE are you using and have you applied the 64bit fix?
 
Messages
23
Country
spain
thanks for ur reply

im using:
Application 01.79.7475.29407
Engine 04.75.7475.29405

and yes i have applied the 64bit fix.

do u know how to confirm that the fix has been successfully applied?
 

scruffyduck

Administrator
Staff member
FSDevConf team
Resource contributor
Messages
34,595
Country
unitedkingdom
do u know how to confirm that the fix has been successfully applied?

Open your task manager. look for airport design editor.exe

1655216352629.png


If it has (32bit) at the end of the entry then the fix is not applied correctly. If 32bit is not then you can assume it is 64bit and will be able to handle bigger objects without running out of memory. This is coming from MCX code embedded in ADE and even with the fix you may still get OOM errors.

The OOM errors come from trying to generate detailed footprints. It is not a fatal error but does mean that some objects may display as rectangles in ADE.
 
Messages
23
Country
spain
well its 64bit.

iv spent hours modelling terminal building :D
please do not tell me I have wasted my time lol

so is there a way to pass this issue or to place the object in the desired place without ade?
 

scruffyduck

Administrator
Staff member
FSDevConf team
Resource contributor
Messages
34,595
Country
unitedkingdom
Well this error should not stop you placing the object in ADE but may need some trial and error due to there not being a detailed footprint
 
Top