Can not convert xml to spb file with simpropcompiler

#1
Hi all

just trying to convert my mission xml to a spb, going around in cyrcles taken up my time:mad: tried following rightnumberones advice on fsx mission but no Joy. Heres Advice followed (also tried many diffrent things with no joy)

Setup
1) Place a copy of the file simpropcomiler.exe into your mission folder. You can find this file in the SDK\Core Utilities Kit\Simprop folder

2) Open a cmd prompt and change directories to your mission folder.

3) Here is the command. If you make the slightest error in path, filenames, etc., it will just fail. Ignore all error messages as they are, as usual, LAME, and will provide no useful information. You made a typo, simple as that, or your files aren't in the right place. MAKE SURE you put quotes around the propdefs argument. Microsoft always forgets to mention this in the SDK, because only 3 guys left in the world remember freakin MS-DOS version 1.0. ... OK /rantoff ... here is the command placed all on one line:

simpropcompiler 2spb -symbols "C:\Program Files\Microsoft Games
\Microsoft Flight Simulator X\propdefs\*.xml" yourmissionname.xml newmissionname.spb

Cheers

Redeye

http://uk.geocities.com/redmond.lines@btinternet.com/index.html
 
Last edited:

Horst18519

Moderator
Staff member
Resource contributor
#2
I'm not sure why the way described in the SDK shouldn't work.

Creating an SPB file

Mission files can either be in XML or SPB (Sim-Prop Binary) format. The binary format is faster to load that its XML equivalent. To create an SPB file, run the simpropcompiler.exe tool, which is in the SDK\Core Utiliites Kit\SimProp folder. This is a command-line tool, so open a command window, navigate to the SDK\Core Utiliites Kit\SimProp folder, then enter the following command:

Simpropcompiler 2spb –symbols C:\Program Files\Microsoft Games\Microsoft Flight Simulator X\propdefs\*.xml yourMission.xml yourMission.spb
I did it just the way the SDK describes - and it works perfectly well. No need to use "" by the way.
Of course you have to change "C:\Program Files\Microsoft Games\Microsoft Flight Simulator X" to your individual fsx-folder-path.
 
#3
still no joy

still no joy any ideas, do not do a lot with command line.

Could you post exactly what you type in, i have tried both cmd and promt, i am using scenery shortcut for xml to bgl because i had no joy with that either,

Cheers

Redeye
 

Horst18519

Moderator
Staff member
Resource contributor
#4
Sorry to ask, but are you really from Britain? I don't understand a word... :eek: :D

I guess you have Microsoft Windows XP.

Ok:

First you have to put the file simpropcompiler.exe into the same folder as your mission-xml.

Then:

start -> run (what's it called in english?)

that brings up the command window

there you go to your missions-directory, for example:

cd\mymissions
As you can see I suggest you create an easy to navigate-to directory in which you place all your mission-files you're working on. That saves you a lot of work, especially when compiling the mission- or the reward-file.

Now, if you are now in the folder where the exe and your xml are, you type this (and exactly this!):

Simpropcompiler 2spb –symbols c:\Program Files\Microsoft Games\Microsoft Flight Simulator X\propdefs\*.xml yourMission.xml yourMission.spb
Be sure to type the correct location of your fsx-folder and the correct name of your mission.

That should bring back the joy. :)
 
#5
Still No joy must be getting close

Still no joy must be getting close this is whats displayed in cmd:


Microsoft Windows XP [Version 5.1.2600]
(C) Copyright 1985-2001 Microsoft Corp.

C:\Documents and Settings\Redeye>d:

D:\>cd\Redbull Air Race Longleat

D:\Redbull Air Race Longleat>Simpropcompiler 2spb -symbols c:\Program Files\Micr
osoft Games\Microsoft Flight Simulator X\propdefs\*.xml longleat.xml longleat1.s
pb
Microsoft Corp. SimProp data file compiler and converter 10.0.61206.1
Copyright ⌐ 1995-2006 Microsoft Corp. Copyright ⌐ 1995-2006 Microsoft Corp.
Error parsing param Files\Microsoft.
Syntax:
simpropcompiler.exe command (options)

commands:
makeheader (options) symbolfile
options:
-i searchpath -- semicolon delimited list of filenames (wildca
rds supported)
-h c_headerfile -- C/C++ header file to output.
-cs cs_headerfile -- C# header file to output.

2spb (options) infile outfile
validate (options) infiles(wildcards supported)
options:
-symbols symbolfiles -- semicolon delimited list of filenames
(wildcards supported)
-excludesymbols excludedsymbolfiles -- semicolon delimited lis
t of filenames (wildcards supported)
-i symbolsearchpath
-encoding (ansi|utf8|unicode)

D:\Redbull Air Race Longleat>
 
#6
D:\Redbull Air Race Longleat>Simpropcompiler 2spb -symbols c:\Program Files\Microsoft Games\Microsoft Flight Simulator X\propdefs\*.xml longleat.xml longleat1.spb
You should use quote marks if path or command contains spaces:

Code:
D:\Redbull Air Race Longleat>Simpropcompiler 2spb -symbols [COLOR="Red"][B]"[/B][/COLOR]c:\Program Files\Microsoft Games\Microsoft Flight Simulator X\propdefs\*.xml[COLOR="Red"][B]"[/B][/COLOR] longleat.xml longleat1.spb
 

Horst18519

Moderator
Staff member
Resource contributor
#8
Good news.

As my mission folder name is quite short (e:\missions :D) I didn't stumble over the problem with spaces. Good to know. :)
 
#10
Compiling with text in chinese characters...

One of the users that has been posting on FSXmissions is from China and wants the Tutorial01 to show Chinese Characters in the dialog window. He sent me the file and my computer reads the chinese characters in my .xml editor fine. Now when i run the program all I get is a bunch of ?????? in place of the chinese characters.

Does anyone know what is required for the OS to read exactly what is in the dialog file ? Or is it just FSX that can not understand it ? Do the dialogs need "quotes" around the chinese characters ?

Guessing someone might know....

Regards
Jib01/02
:confused: :confused: :confused:
 
#12
Add the -i switch for non C: Drive FSX installs

I had an extra problem in that I had my FSX directory on my D: drive and I found I had to add the i switch as well. -i tells simpropcompiler to search in other paths for symbols. I guess the simpropcompiler tool is a little fussy!

simpropcompiler 2spb -symbols "D:\Program Files\Microsoft Games\Microsoft Flight Simulator X\propdefs\*.xml" -i "D:\Program Files\Microsoft Games\Microsoft Flight Simulator X\propdefs" mymission.xml mymission.spb

I needed the quotation marks around the path.

I made a batch file up that does the compilation so I didn't have to copy simpropcompiler into my mission directory and keep on typing in the loooong command line. The batch file has to run in the same directory as the missions xml file. As I said the simpropcompiler tool is a little fussy.


Regards

sireland
 

Attachments

Last edited:
#13
Thanks for the explanation!

Just been banging my head against the command window and Simpropcompiler to convert a mission.xml to mission.spb. Your comments above are very much appreciated as I finally - after a lot of typo problems, missing quotes, spaces, etc - yes, finally got it to work. Sheesh!

Also noted that Windows 7 has a neat mechanism for opening the command window in whatever folder you need it. Just press SHIFT as you right-click in the required folder and, Hey Presto!, the requisite file structure appears.

Anyway, back to it - Thanks Again.

Cheers - Dai.:cool:
 
Top