• Which the release of FS2020 we see an explosition of activity on the forun and of course we are very happy to see this. But having all questions about FS2020 in one forum becomes a bit messy. So therefore we would like to ask you all to use the following guidelines when posting your questions:

    • Tag FS2020 specific questions with the MSFS2020 tag.
    • Questions about making 3D assets can be posted in the 3D asset design forum. Either post them in the subforum of the modelling tool you use or in the general forum if they are general.
    • Questions about aircraft design can be posted in the Aircraft design forum
    • Questions about airport design can be posted in the FS2020 airport design forum. Once airport development tools have been updated for FS2020 you can post tool speciifc questions in the subforums of those tools as well of course.
    • Questions about terrain design can be posted in the FS2020 terrain design forum.
    • Questions about SimConnect can be posted in the SimConnect forum.

    Any other question that is not specific to an aspect of development or tool can be posted in the General chat forum.

    By following these guidelines we make sure that the forums remain easy to read for everybody and also that the right people can find your post to answer it.

Can't Create New Airport using ADE for FS9

Hi everyone,
After several attempts to modify a stock airport in FS9 and it not showing up correctly, I attempted to create a new airport for the same area. I used AirNav to get all the relevant airport data and followed all the suggested steps for creation in ADE 1.78. (I used ADE in the past on an XP machine with no issues). Now however, when I put in the information for KPIA (Peoria,IL) it will create the initial airport location, but when I try to add the runways using the GPS coordinates, it does not place them in the correct location. Could someone please tell me if this is a Windows 10 issue or am I missing something? I am not using FSX because I could not get FSX accelerator to load on my AMD system. Please help and thanks
 

scruffyduck

Administrator
Staff member
FSDevConf team
Resource contributor
Which problem do you want us to look at - the failure of the modified stock airport or the failure of your new user defined airport. It seems likely we need to sort out the modified stock airport issues first

Please attach your ADE project file for the modified stock airport

When you say it doesn't show up correctly what exactly do you mean? I don't think it has anything to do with your computer or Windows version.
 
Hi Jon,
I am including the bgl file and the ade file. You will see that the ade file looks fine and that it compiles correctly. However, when it loads in FS9, at least on my system, all of the changes do not show up correctly. For example, the new taxiways I created or the ones in the original file that I moved since they were in the wrong place do not work correctly. With ADE connected to FS9 on my system, you will see where if you are on the taxiway in FS9, you are not on it in ADE. Also, even though I changed all the Taxiway Signs, and moved them to there correct location in ade, some do not show up in FS9, or show up in the middle of the Taxiway or Runway. I am also including a screen shot of the library listing in FS9 so you can that I have the scenery at the top of the addon list. Thanks again for all you efforts to help me get a handle on what is going on.
Jeff
 

Attachments

tgibson

Resource contributor
I placed your BGL file into FS9, and I see differences, and no obviously misplaced signs.

Default is on the left, your ADE file on the right:

kpia_ade.jpg
 
Hi Tom,
Thanks for taking a look. It is really weird that you get it to show up for you. It definitely does not work on my system. I have been having issues since I changed my system to AMD and Windows 10 for FS. FSX won't load, and I get the errors described above in my sim. Any ideas what might be going on?
 

tgibson

Resource contributor
That tells me you probably have another version of this airport in the Addon Scenery/scenery folder? Search for it.
 

scruffyduck

Administrator
Staff member
FSDevConf team
Resource contributor
With your project loaded go to Tools > File Priority Analyzer Set the checkboxes as shown here

1586253728024.png


and click Scan. Wait for it to finish

1586253758271.png


Look for the bgl file you created. If it is not at the top of the list then anything above it will have the potential to defeat your changes. Stock files should be at the bottom. If any file is listed above yours then you need to disable them one at a time and check the sim until you find the culprit
 

Attachments

Thanks for all the help everyone. Jon, I ran the test and included the screenshot. It is at the top of the list so not sure what is going on.
Screenshot (6).png
 

tgibson

Resource contributor
Those are both airport BGL files in the same folder - you can't have that. Move the F1UT_KPIA.bgl file to the parent folder (i.e. outside the scenery subfolder.)
 
Would the same thing be achieved by moving the ADE file? The other file is ultimate traffic which I use and would like to keep working.
 
Just a follow up. I tried what you suggested and it didn't make a difference. I also tried my previous post and that didn't fix the issue either. I am not sure what else to try, but thanks for everyone's help.
 
Top