FSXA Can't seem to get my conditions right

#1
Large swing gate should open about 46 meters in front of the gate. Nothing happening. somehow I got it to open once with a previous condition (been trying many times) but I had to get very close.

I assume CAT uses meters. I chose -46 meters for the front of the gate... about 138 feet or so.

Used to do all this very fast and easy but have forgotten.

Also- I corrected the alpha so the gate texture is correct. I hope this did not kill the animation.... i.e. can have one or the other but not both.

Attached asm files and pics. Can anyone correct this for me and tell me where I went wrong? Bob
 

Attachments

arno

Administrator
Staff member
FSDevConf team
Resource contributor
#2
Hi,

What settings did you use for the animation trigger exactly? I can't see that for the files you attached.
 
#3
IN CAT after title page .... 1st page enable animation conditioon is checked, and b
bounding box is checked.

jpgs are attached.

I - for now- change the gate over to just horizontal bars which need no trans correction. (This is for FSX btw) It now animates but not until the nose of my plane is right on top of the gate itself. - ergo bounding box is wrong? In MCX the bounding box shows up very tightly drawn around the gate.

Bob
 

Attachments

arno

Administrator
Staff member
FSDevConf team
Resource contributor
#4
Hi Bob,

I would remove the checkbox for the animation condition. It is never a good idea to use the same condition as animation condition and as animation trigger.

The difference is that the trigger is what actually starts the animation. The condition is just a condition determines if the animation (and the trigger) will work at all. I think you should be fine with just a trigger.

Also be sure to enter a rotation, if your MDL object is placed with a heading different from zero. Because the bounding box does not rotate with the object when you rotate it during placement.
 
#5
rotation? I was wondering about that. Should I place the object and check its heading then in CAT use that heading in the rotation box?

Are my parameters ok? right now I have to actually nose the gate to get it moving. Also- when I go through or back away the gate snaps shut instead of gently closing.

right now I have animation to open the gate only. Should I continue and add frames to show closing the gate? Bob
 
#6
Arno- Just made the changes. It works fine now. Thank you for the help. Now- about the default trans.

is it possible to have this animation AND fix the default transparency? And which do I do first? the ani THEN the trans? Bob
 

arno

Administrator
Staff member
FSDevConf team
Resource contributor
#7
Hi,

The transparency is in the texture, so that should have nothing to do with the animation. So does your texture have an alpha channel?

Given that it is a fs2004 object in fsx, you will always keep some issues with the drawing order of objects behind your fence. That can't be solved.
 
#8
Well I tried like crazy. 2:40 AM here. I have been trying since about 11:30 PM. My gate was performing beautifully, but the z-write (drawing order?) was bad. I'd correct it in ModelconX, which would solved this but I would lose the animation. Of course the reverse is true as well. So I gather that I can have one or the other but not both.

I assume to have both would be quite difficult or impossible to fix due to differences between Xtomdl and makemdl.

Could confirm these assumptions I just made? .... and thanx for the help.... most appreciated. Bob
 

arno

Administrator
Staff member
FSDevConf team
Resource contributor
#9
Hi,

You can have transparency displayed, but the drawing order will always be wrong. That can't be fixed with using a FS2004 MDL in FSX. For that you would need to use a FSX material, but then you can't have the conditional animation. So that's the choice you need to make (unfortunately).
 
Top