Compiled mit v5 SDK will not be recognized by v4

Hello,
I used ADE v1.79.7417.
I opened my old YSSY ADE with it.
Compiled it with the v5 SDK (including an xml)
also saved the Airport as an new file

Prepar3dv4 didn't recognized the ADE (the default one was loaded)

I opened the ProjectFile wit ADE v1.76 (v4 SDK)
compiled it
Prepar3dv4 recognized it

I opened the v5compiled XML File with ADE v1.76
compiled it
Prepar3dv4 recognized it

Any idea? Is an v5 compiled BGL not compatible with v4?

Regards
Urmel
 

scruffyduck

Administrator
Staff member
FSDevConf team
Resource contributor
You got it in one. Generally compiled bgl files are not reverse compatible. So I would not expect v5 to work with v4 since there are changes in the bgl contents and structure between the two. v4 may work fine in v5
 
Ok, Thanks. That means I should use the new ADE v1.79.7417 with the v4 SDK? And only when I want to compile an sloped Airport or an only v5 compatible Airport with the v5 SDK?
 

scruffyduck

Administrator
Staff member
FSDevConf team
Resource contributor
You must use the v4 SDK if you have ADE set to run for v4 and the v5 SDK if set for v5. Sloped airports are a small part of v5. If you want to create stuff for v5 use the v5 SDK irrespective of whether you are working on a sloped airport or not
 
Ok, FlyTampa Sydney is an quite old airport with no v5 features. Does it benefit from an special v5 compile or is an v4 compile enough?
 

scruffyduck

Administrator
Staff member
FSDevConf team
Resource contributor
I have no idea - you need to try try things on a case by case basis.
 
Top