Compiler Error FS9

#1
I am wondering if anybody can help with an issue I'm currently having, I am unable to compile a saved airport, the error message i am getting is as follows

.Compiler Errors Found. These were not identified by the Issue Manager. Please let us know
what the compiler error is so that we can improve the Issue Manager.

The compiler message is shown below

ScruffyDuck Scenery Design Engine Compiling
Using BglComp....

INTERNAL COMPILER ERROR C1003: Failed to create MSXML object! (0x80040154)

Parsing document: C:\MSFS\FS Design Tools\Airport Design Editor 175\!AdeTempWorkOnly\EGHL_ADE9_JMS.xml

ERROR C2470: Unrecoverable error parsing XML!
ERROR C2006: Parse failed (0x80004005)
ERROR C2003: Failed to process file: C:\MSFS\FS Design Tools\Airport Design Editor 175\!AdeTempWorkOnly\EGHL_ADE9_JMS.xmljon

I have been on the help pages of the sruffyduck website, and following a quick email conversation regarding this it was suggested it might be msmxl4 missing so I installed that, but it when I did it asked did I want to repair it, so I did that, ADE is still not compiling and windows 10 is up to date, what am I missing thats stopping this working as it worked so well on a previous laptop, as anybody had a similar issue, and when it comes to MSMXL4 is there anything else I can do, because at the moment I am stumped, thanks
 
#3
You may need to uninstall and reinstall MSXML. Try not repairing it this time.

https://www.fsdeveloper.com/forum/t...r-c1003-failed-to-create-msxml-object.429868/

Hope this helps,

Thanks for replying, unfortunately I had already tried this or at least updating it, subsequently and after posting on here I uninstalled the version of mxmsl I had on my computer and tried a fresh install of msxml and that won't install either now, having googled that, it appears to be a common problem as well, so this is turning into a bit of a nightmare, now trying to find a way that works to install it, don't suppose anybody can help with that, or failing that have the home address of the head of customer service at Microsoft
 

Pyscen

Resource contributor
#4
Hello...

You might need to install MSXML4 as well as 6. Especially for some of the newer applications or tools.
 
#5
Yeah its MSXML 4 SP3 that won't actually install with my version of windows 10, it gets to product something or other then gives an error message then rolls back and doesn't install, googled it and it seems to be a known problem, but finding a solution seems to be elusive, so unless somebody knows how to get past MSMXL4 SP3 not installing that would be great, or its off to my local techie and letting him have a laugh at me or buying an old charger for an old laptop and seeing if the gerbils in that still are alive, but again thanks for responding
 
Top