• Which the release of FS2020 we see an explosition of activity on the forun and of course we are very happy to see this. But having all questions about FS2020 in one forum becomes a bit messy. So therefore we would like to ask you all to use the following guidelines when posting your questions:

    • Tag FS2020 specific questions with the MSFS2020 tag.
    • Questions about making 3D assets can be posted in the 3D asset design forum. Either post them in the subforum of the modelling tool you use or in the general forum if they are general.
    • Questions about aircraft design can be posted in the Aircraft design forum
    • Questions about airport design can be posted in the FS2020 airport design forum. Once airport development tools have been updated for FS2020 you can post tool speciifc questions in the subforums of those tools as well of course.
    • Questions about terrain design can be posted in the FS2020 terrain design forum.
    • Questions about SimConnect can be posted in the SimConnect forum.

    Any other question that is not specific to an aspect of development or tool can be posted in the General chat forum.

    By following these guidelines we make sure that the forums remain easy to read for everybody and also that the right people can find your post to answer it.

FS2004 Compiler Error

Messages
141
Country
germany
In trouble again. After a WIN10 crash I had to reinstall the WIN10 OS. As a result I lost most of my data and am now in the process of reinstalling and activating many of my missing files etc. I have used the tool fs92fsx before in creating airbirt FS9,bgl`s for use in Euroscope however I am now faced with the following message:-

ScruffyDuck Scenery Design Engine Compiling
Using FS9 BglComp....
INTERNAL COMPILER ERROR C1003: Failed to create MSXML object! (0x80040154)

I have tried using old and present ADE`s but all with the same result. Can anyone please help.
 
Did what you said and it now works to some extent. Provides a xml file but no bgl. No great problem as I can use the bglcomp to create one. Many thanks from a very frustrated PC user.
 
I have the same problem after a computer change, still WIN 10. Have updated MSXML and still get the following

Compiler Errors Found. These were not identified by the Issue Manager. Please let us know
what the compiler error is so that we can improve the Issue Manager.

The compiler message is shown below

ScruffyDuck Scenery Design Engine Compiling
Using BglComp....

INTERNAL COMPILER ERROR C1003: Failed to create MSXML object! (0x80040154)

Parsing document: C:\MSFS\FS Design Tools\Airport Design Editor 175\!AdeTempWorkOnly\GAKS_ADE9_LPH.xml

ERROR C2470: Unrecoverable error parsing XML!
ERROR C2006: Parse failed (0x80004005)
ERROR C2003: Failed to process file: C:\MSFS\FS Design Tools\Airport Design Editor 175\!AdeTempWorkOnly\GAKS_ADE9_LPH.xml

What haven't I set up!
 
I had already updated MSXML4 using the msi This cleared an error in MCX
Do I need to install it anywhere else? As you will have guessed - non-tech user.
 
I'm not a great expert on this either. It has arisen a number of times here in the past so perhaps do a search of the forums using the error C2003 and see what turns up
 
My apologies for misleading you. Installing MSXML4 got rid of a red warning in MCX but a closer look tells me that it is still
giving the error C1003
P will search around
 
If it is of any use to fellow sufferers, the Microsoft 'Answer' is at

I hope it works for you!
 
I also have the same issue. Trying to fix an airport with a bituminous runway saving it as asphalt. It only compiles into a ad4 thing, whatever that is.
Also I get the same error trying to compile it into a bgl.
I've noticed the MSXML 4 link shows its not Windows 10 compatible. Is that an issue if I install it?
 
No issues for me installing msxml4.dll in Windows 10.

I had the same errors as post #4 and could not work out why I was suddenly unable to compile scenery BGL using ModelconverterX anymore.

Installing MSXML 4.0 SP3 fixed my issues.

I hadn't used it for a while and it seems there was an update to msxml6.dll so my system did not have the correct version of msxml.

AFAIK BglComp needs msxml4.dll to run correctly. You can check on your system by opening a Run Command (Windows+R) and typing %windir%\System32 and then search for 'msxml' to see if you have msxml4.

1658847132142.png


I just spent a few hours trying to figure out the problem. Thanks to the forums here and the post from Rhumbaflappy. https://www.fsdeveloper.com/forum/threads/download-for-msxml-4-0-sp3-installer.452814/
I hope this helps someone!
 
Back
Top