• Which the release of FS2020 we see an explosition of activity on the forun and of course we are very happy to see this. But having all questions about FS2020 in one forum becomes a bit messy. So therefore we would like to ask you all to use the following guidelines when posting your questions:

    • Tag FS2020 specific questions with the MSFS2020 tag.
    • Questions about making 3D assets can be posted in the 3D asset design forum. Either post them in the subforum of the modelling tool you use or in the general forum if they are general.
    • Questions about aircraft design can be posted in the Aircraft design forum
    • Questions about airport design can be posted in the FS2020 airport design forum. Once airport development tools have been updated for FS2020 you can post tool speciifc questions in the subforums of those tools as well of course.
    • Questions about terrain design can be posted in the FS2020 terrain design forum.
    • Questions about SimConnect can be posted in the SimConnect forum.

    Any other question that is not specific to an aspect of development or tool can be posted in the General chat forum.

    By following these guidelines we make sure that the forums remain easy to read for everybody and also that the right people can find your post to answer it.

Constant CTD in Dev Mode

Messages
8
Country
unitedkingdom
I’m just starting work on a new airport, which I’d previously attempted and made some decent progress with in an older version of the SDK/Dev Mode. After updating to SU7, Dev Mode is constantly CTD, no matter what I’m trying to do. Just switching the camera or zooming will CTD, as will trying to add any items from the object list. Any ideas about this?

Cheers,
Malcolm
 
Messages
111
Country
france
I had a CTD yesterday trying the new car park feature in the scenery editor.
Most annoying to me is that MSFS freezes most of the time when trying to load my airport project. Couldn't make any progress since yesterday.
 
Messages
228
Country
unitedkingdom
I've had about 6 or 7 times since SU7. I haven't had one in months before that.

Sometimes it's opening the project, other times it's attempting to adjust the weather. No idea how to stop it of course.
 
Last edited:
Messages
228
Country
unitedkingdom
Now 3 times in a row on opening the project. As soon as I move the camera or close a window it's toast.

Nice one.

I can create a new project and transfer the old info over without crashing. As soon as I reopen it the next time it dies in the exact same way.
 
Last edited:
Messages
228
Country
unitedkingdom
I have managed stop CTDs on opening the project by starting at another location, opening the project, and then clicking on the airport object to go there.

It still crashes sometimes when working but not too often. It's now 100% guaranteed if I open at the location I want to edit.
 
Messages
14
Country
unitedstates
Yes, was happening to me too.
I think I have found my issue. When I added a new asset to the modellib I used to run the exe, create and load the package with the new asset. Start FS, open the project, load the scenery, and then try to do something, result: CTD.
Now I don’t run the exe after I add the asset to the modellib. Instead, Start FS, load the project and then add the new asset to the scene. Now Rebuild All and everything is fine.
Hope this helps. YMMD.
 
Top