Continued: colour issues in preview

arno

Administrator
Staff member
FSDevConf team
Resource contributor
Hi Paul, Rob,

This is a continuation of the colour issues discussed before. I have optimized the rendering code a bit, hopefully that helps. But since I can't reproduce the issue here it is hard for me to tell. It is available in the current development build.
 

arno

Administrator
Staff member
FSDevConf team
Resource contributor
Hehe, yes, it is a lot colder here. But for the rest it is nice to be home again.
 
Morning Arno,

Proviisional testing with latest development release gives me following findings:
- dimensions indicated are still completely off (both in MCX and in the ADE library Object data, although once converted into a library object and scaled to 0.10 gives the correct size visually in FSX;
- color preview in MCX gives a colored object when using certain colors only. For instance, 0,192,0 gives you green in the preview, 0,255,0 gives you the same green but 128,255,128 does not give you any color, neither in the preview nor in FSX.
- textures are OK and do not give me any problems.
I tried the reader on a more complex unfinished model and I get a lot of warnings upon export, but still it exports OK.
That's it for the time being. Will revert when I find out more.

Rob
 

arno

Administrator
Staff member
FSDevConf team
Resource contributor
Hi,

- dimensions indicated are still completely off (both in MCX and in the ADE library Object data, although once converted into a library object and scaled to 0.10 gives the correct size visually in FSX;
What's your reference of the good dimensions?

- color preview in MCX gives a colored object when using certain colors only. For instance, 0,192,0 gives you green in the preview, 0,255,0 gives you the same green but 128,255,128 does not give you any color, neither in the preview nor in FSX.
I have never been able to reproduce the problems with exporting to FSX, but when you try these different colours do you change them in MCX or in your source program (Sketchup?).
 
Hi again,

The last object was a house (30ft wide and 40ft long).
In MCX I get something like 1500ftx3000ft
IN ADE it is different still (something like 5053x7509ft at scale 1.0).
The house had a brick textured wall which shows up and a red tile roof texture, the latter of which, it now seems, I cannot change the name and format in MCX anymore.
When I export and reload, the old name is there again (texture1.jpg instead of tile.bmp).
It is possible that MCX cannot load two different textures, I still have to try that.
I changed the colors in MCX. But the same happens when I do it in Sketchup (example: yellow becomes red, pure green is green but light green is colorless).
It is really strange that you cannot reproduce it.
 

arno

Administrator
Staff member
FSDevConf team
Resource contributor
Hi,

Can you send me your COLLADA file you are using? Maybe I can see something if I try the same object.
 

arno

Administrator
Staff member
FSDevConf team
Resource contributor
Hi,

Got the file correctly. I can not reproduce the size problem here, the object is around 10 meters in size here (which seems like a normal size for a house).

I think I see what you mean with the materials, in Sketchup it looks different. I will check the material colours and see if they are read correctly.
 
Hi,

Correct, the size is some 10 meters in Sketchup.
In MCX it is approx 510x460x375 I don't know what.
I have English - US country settings i.e. 100,456.14 (as an example).
In ADE I get 513.72x460.86 meters which looks as if it agrees with the MCX data but not with the real size.
I continued working on this 'house' and two other things still do not look quite right:
- the colored surfaces (door and windowpanes)are still invisible (this time I used a named color=navy blue in sketchup);
- the textures are lit at night.
From Sketchup 7.1 I export with the DAE default options.
(I use Library Creator XML to convert MCX mdl's into Library Objects which I then put in the scenery using ADE).
 
When I said the textures are lit at night, I meant to say that although I tried to add night textures, MCX does not honor them. I do save the mdl with the night textures entry added, but when I load the mdl again, the night textures are gone from the materials entry.
Here is a screenshot of what it looks like in FSX and a preview of Sketchup.
The FSX object has been scaled down to 0.05.
 
Last edited:

arno

Administrator
Staff member
FSDevConf team
Resource contributor
Hi,

I will look at the materials in the COLLADA file, maybe I am not reading all parameters correctly.

For the night texture, let me try to reproduce that as well.
 

arno

Administrator
Staff member
FSDevConf team
Resource contributor
Btw, are you sure that you assigned your night texture correctly and did not assign the day texture again to the night slot?
 
I added it as a nightmap texture in MCX, I darkened the original texture and added the _LM extension to it. Then I export it again.
Upon decompiling the bgl or opening the mdl again, the night texture entry is gone again.
 
Last edited:
Solved but don't ask me why or how

Hi Arno,

Yesterday night my computer shut down and restarted windows after a MS windows update.
When I reloaded modelconverterX, I could not open the mdl in question anymore. I reloaded the dae file in modelconverterX and exported it, all in the same way as I did before.
Well, everything works fine now, including colors, night textures and dimensions.
There are two possible explanations:
Either the windows update did something or, as I recall, I installed your latest update again somewhere yesterday without rebooting the computer, and that may explain why some of your dll's were not working properly. I am just thinking out loud because those are the only things that changed.
Anyway, thanks for a very nice extra to your already extremely useful program.

Rob

PS Glad you found the glitch in the setting options as well as that would have puzzled some new users.
 
Last edited:
One more question:
Does MCX maybe support conversion of sketchup animations as well?
(Guess not but it is worth asking).

Rob
 

arno

Administrator
Staff member
FSDevConf team
Resource contributor
Hi Rob,

No, animations from COLLADA are not yet supported. That is still on the wishlist :).

Glad to hear most of your other issues seem solved now.
 
Top