FSX Convert FSX_KML file to SBuilderX ?

I am trying to rework an old project of mine that was made with FSX KML prior to when it got broken by some "breaking" change in a Google EArth update.

Since I am not using SBuilderX I would like to know if there is an easy way to convert the FSX KML file given that this utility was abandoned.
 
Hi Emilio:

Assuming you meant to type "I am (now) using SBuilderX", here's some info which may be of interest: :idea:


When FSX_KML 'compiles' a project, it writes a SHP file into one of the [FSX_KML install path]\sub-folders.

The intermediate KML file can be converted into a BLN file via rhumbaflappy's KML2BLN utility:

http://www.fsdeveloper.com/forum/threads/kml2bln.310230/


Either or both of these file formats may be "Appended" to SBuilderX.

However, the KML file may first require pre-processing via "PreFSXKML" to correct recent Google file format changes:

http://www.fsdeveloper.com/forum/resources/prefsxkml.82/


Hope this helps ! :)

GaryGB
 

rhumbaflappy

Moderator
Staff member
Resource contributor
Just get an older version of Google Earth and finish the project. Why change horses in the middle of the stream?

Dick
 
Hi Dick:

What 'numeric' version of Google Earth (aka "GE") would you recommend that can output a KML file which does not first require pre-processing via "PreFSXKML" to correct recent Google file format changes ?


The reason I ask is apparently Google reportedly does not "support" use of anything but the most immediately prior version:

https://productforums.google.com/forum/#!topic/earth/KTacBD6vsL4


Perhaps that does not matter if the "older" GE version is somehow still able to display the map background and can be used to output a KML file that works with FSX_KML and/or KML2BLN ? :scratchch


Thus far I have not found a "official" Google download page for anything but the most immediately prior GE version.


BTW
: I did find this page at "www.oldversion.com":

http://www.oldversion.com/windows/google-earth/


GaryGB
 
Last edited:

rhumbaflappy

Moderator
Staff member
Resource contributor
Hi Gary.

I posted a new thread and stuck it to the top of this forum:

http://www.fsdeveloper.com/forum/threads/getting-an-old-version-of-google-earth-for-use-with-fsx_kml.434997/

This is the 'official' means of getting an old version of Google Earth. I am not sure which version did not break the old KML format that FSX_KML uses. Perhaps an FSX_KML user could identify that version and post it to that pinned thread.

As far as support, Google has already announced it has discontinued development of Google Earth, and will eventually deprecate it's use entirely. (The Pro version has been free for some time now). I'm not a big fan of FSX_KML, but I'm a huge fan of Google Earth, just like millions of other users.

Edited++++++++++++++

According to this link:
http://www.fsdeveloper.com/forum/threads/invalid-tag-error-for-every-kml.433389/#post-704382

The poster states Google Earth Version 7.1.2.2041 works. I thought version 6.1 was the last one that worked with FSX_KML. Another old post indicates version 5.1 is the right version. We would need an FSX_KML user to track this down. (version 5.1 is the oldest version Google still has available).

Once we have the right version, the 7zip utility can open the EXE file and you can extract the 'Google Earth' folder to a safe spot ( I use C:\MyPrograms), and run it from there. (This is if you don't wish to uninstall the newer version and reinstall the older).

Dick
 
Last edited:
Many thanks, Dick ! :wizard:


One more question if I may:

Does your KML2BLN utility still work with KML / KMZ files output by versions of Google Earth NEWER than 7.1.2.2041 ? :scratchch


Thanks in advance for your clarification on this. :)

GaryGB
 

rhumbaflappy

Moderator
Staff member
Resource contributor
Hi Gary.

I just tried it with Google Earth Pro (now free), version 7.1.2.155 and it seems to work OK.

Dick
 
Hello Dick,
Just sent you a PM because I am trying to download the Google Tile Server for SBuilderX and Chrome blocks it as malicious...
 

rhumbaflappy

Moderator
Staff member
Resource contributor
I would block Chrome if I could...

Actually, I just used Chrome at work to download the version 172 dlls and it worked just fine. I'm guessing your computer has some issues with virus protection programs or permissions.

Dick
 
Last edited:
Top