FSX Cowl Flaps Gauge Help

#1
Hi all,

Sorry to be a pain yet again I just cant seem to grasp XML although I am getting better. Just trying to do a cowl flaps gauge
separate for each side. I modified and existing gauge but it is not showing up in FSX any help would be greatly appreciated.

Code


Back ground just black so should be invisible


First Gauge BMP 0% opened


Last Gauge BMP 100% opened


The other bmps are just different movements of switch but happy to post if needed

Thanks a million sorry I thought I was getting the hang of this apparently not grrrr

Cheers
Matt
 
#3
Sorry Chris code pasted below

XML:
<Gauge Name="Cowl Left" Version="1.0">
 <Image Name="cfl.bmp"/>
<Element>
 <Position Y="0" X="0"/>
  -
<Select>
 <Value Maximum="6" Minimum="0">(A:Recip eng1 cowl flap position, percent) 0.06 * near</Value>
<Case Value="6">
 <Image Name="0pl.bmp" ImageSizes="207,289"/>
 </Case>
<Case Value="5">
 <Image Name="16pl.bmp" ImageSizes="207,289"/>
 </Case>
<Case Value="4">
 <Image Name="31pl.bmp" ImageSizes="207,289"/>
 </Case>
<Case Value="3">
 <Image Name="47pl.bmp" ImageSizes="207,289"/>
 </Case>
<Case Value="2">
 <Image Name="78pl.bmp" ImageSizes="207,289"/>
 </Case>
<Case Value="1">
 <Image Name="94pl.bmp" ImageSizes="207,289"/>
 </Case>
<Case Value="0">
 <Image Name="100pl.bmp" ImageSizes="207,289"/>
 </Case>
 </Select>
 </Element>
<Mouse>
 <Help ID="HELPID_GAUGE_ENGINE_CONTROLS"/>
<Area Top="70" Left="20" Height="122" Width="169">
 <Tooltip ID="TOOLTIPTEXT_ENG1_COWL_FLAPS_PERCENT"/>
  -
<Area Bottom="200">
 <Cursor Type="DownArrow"/>
 <Click Event="DEC_COWL_FLAPS1" Repeat="Yes"/>
 </Area>
  -
<Area Top="46">
 <Cursor Type="UpArrow"/>
 <Click Event="INC_COWL_FLAPS1" Repeat="Yes"/>
 </Area>
 </Area>
 </Mouse>
 </Gauge>
 
Last edited:
#4
Couple of things to try;

1. Use
XML:
A:RECIP ENG COWL FLAP POSITION:1,Percent
2. Get rid of all those spurious minus signs.
 
Top