• Which the release of FS2020 we see an explosition of activity on the forun and of course we are very happy to see this. But having all questions about FS2020 in one forum becomes a bit messy. So therefore we would like to ask you all to use the following guidelines when posting your questions:

    • Tag FS2020 specific questions with the MSFS2020 tag.
    • Questions about making 3D assets can be posted in the 3D asset design forum. Either post them in the subforum of the modelling tool you use or in the general forum if they are general.
    • Questions about aircraft design can be posted in the Aircraft design forum
    • Questions about airport design can be posted in the FS2020 airport design forum. Once airport development tools have been updated for FS2020 you can post tool speciifc questions in the subforums of those tools as well of course.
    • Questions about terrain design can be posted in the FS2020 terrain design forum.
    • Questions about SimConnect can be posted in the SimConnect forum.

    Any other question that is not specific to an aspect of development or tool can be posted in the General chat forum.

    By following these guidelines we make sure that the forums remain easy to read for everybody and also that the right people can find your post to answer it.

MSFS Creation of a new airport with frequencies and ILS

Messages
110
Country
italy
Hi everyone, I created this new thread because I can't find the answer to my question:
With SDK of MSFS2020 I created a new LIKS inexistent airport in Sibari Italy. Previously done both with XP11 and FSX with ADE.
I can't find the way to enter the frequencies of the airport like: tower, ground, approach, arrival departure etc ...
I tried to insert an ILS but in BUIL stage gives me an error.
From what I saw on this forum I understand that you have to insert these instances by hand in the Objects.xml file or am I wrong?
Is there any kind soul who can help me in this project?
Maybe by posting a script to be included in the file, inserting another name as ICAO that I am going to modify and related LAT and LONG.
I thank you all
Paolo by Italy
 

Attachments

  • SimpleScenery.zip
    3.2 MB · Views: 76
Messages
702
Country
australia
Yes, it seems you need to enter them into your XML by hand into the <Airport> element. The format appears to be the same as used in FSX.

For example, this code goes inside <Airport> element. I place it just above the <DeleteAirport> element which is the last element in the airport.
Code:
        <Com frequency="120.3" type="CENTER" name="FIS Brisbane"/>
        <Com frequency="124.2" type="UNICOM" name="Multicom"/>
        <Com frequency="124.2" type="CTAF" name="CTAF"/>

For more information refer to this previous post which has an example for the ILD. One tip in the post is that you can export the FSX airport from ADE using the XML output option and you can then simply copy and paste the frequency information into the MSFS XML.

 
Messages
110
Country
italy
Yes, it seems you need to enter them into your XML by hand into the <Airport> element. The format appears to be the same as used in FSX.

For example, this code goes inside <Airport> element. I place it just above the <DeleteAirport> element which is the last element in the airport.
Code:
        <Com frequency="120.3" type="CENTER" name="FIS Brisbane"/>
        <Com frequency="124.2" type="UNICOM" name="Multicom"/>
        <Com frequency="124.2" type="CTAF" name="CTAF"/>

For more information refer to this previous post which has an example for the ILD. One tip in the post is that you can export the FSX airport from ADE using the XML output option and you can then simply copy and paste the frequency information into the MSFS XML.

thanks a lot for the confirmation, should I put them in my objects.xml file then? I don't see in my file <delete airport> also because my airport doesn't exist in the NAVDATA, is this right?
Thanks again
 
Messages
702
Country
australia
thanks a lot for the confirmation, should I put them in my objects.xml file then? I don't see in my file <delete airport> also because my airport doesn't exist in the NAVDATA, is this right?
Thanks again
Are you creating an airport? Because they need to go inside the Airport element in your xml file. You need to find the <Airport element.

Code:
    <Airport region="Evans Head" country="Australia" state="New South Wales" city="Evans Head" name="Evans Head" ident="YEVD" lat="-29.10181275421627" lon="153.42074837226909" alt="6.96933523807379" magvar="11.800000" trafficScalar="1.000000" airportTestRadius="2000.00000000000000" applyFlatten="FALSE" isOnTIN="FALSE" starAirport="TRUE">

a lot of airport elements data goes in here which I have deleted because it's not relevant for this example.

        <Com frequency="120.3" type="CENTER" name="FIS Brisbane"/>
        <Com frequency="124.2" type="UNICOM" name="Multicom"/>
        <Com frequency="124.2" type="CTAF" name="CTAF"/>
        <DeleteAirport deleteAllApproaches="FALSE" deleteAllApronLights="TRUE" deleteAllAprons="TRUE" deleteAllFrequencies="TRUE" deleteAllHelipads="FALSE" deleteAllRunways="TRUE" deleteAllStarts="TRUE" deleteAllTaxiways="TRUE" deleteAllBlastFences="TRUE" deleteAllBoundaryFences="TRUE" deleteAllJetways="TRUE" deleteAllControlTowers="TRUE" deleteAllDepartures="FALSE" deleteAllArrivals="FALSE" deleteAllPaintedElements="TRUE" deleteAllLightSupports="TRUE" deleteAllTaxiwaySigns="TRUE" deleteAllILSs="FALSE" deleteAllTerminalWaypoints="FALSE" deleteAllTerminalNDBs="FALSE"/>
    </Airport>
 
Messages
110
Country
italy
Are you creating an airport? Because they need to go inside the Airport element in your xml file. You need to find the <Airport element.

Code:
    <Airport region="Evans Head" country="Australia" state="New South Wales" city="Evans Head" name="Evans Head" ident="YEVD" lat="-29.10181275421627" lon="153.42074837226909" alt="6.96933523807379" magvar="11.800000" trafficScalar="1.000000" airportTestRadius="2000.00000000000000" applyFlatten="FALSE" isOnTIN="FALSE" starAirport="TRUE">

a lot of airport elements data goes in here which I have deleted because it's not relevant for this example.

        <Com frequency="120.3" type="CENTER" name="FIS Brisbane"/>
        <Com frequency="124.2" type="UNICOM" name="Multicom"/>
        <Com frequency="124.2" type="CTAF" name="CTAF"/>
        <DeleteAirport deleteAllApproaches="FALSE" deleteAllApronLights="TRUE" deleteAllAprons="TRUE" deleteAllFrequencies="TRUE" deleteAllHelipads="FALSE" deleteAllRunways="TRUE" deleteAllStarts="TRUE" deleteAllTaxiways="TRUE" deleteAllBlastFences="TRUE" deleteAllBoundaryFences="TRUE" deleteAllJetways="TRUE" deleteAllControlTowers="TRUE" deleteAllDepartures="FALSE" deleteAllArrivals="FALSE" deleteAllPaintedElements="TRUE" deleteAllLightSupports="TRUE" deleteAllTaxiwaySigns="TRUE" deleteAllILSs="FALSE" deleteAllTerminalWaypoints="FALSE" deleteAllTerminalNDBs="FALSE"/>
    </Airport>
OOhhhh yes yes dear Anthony, I put it at the bottom of the file before the </Airport> element.
Thanks to your advice I was able to get the frequencies to work.

<Com name="SIBARI" type="FSS" frequency="132.7500"/>
<Com name="SIBARI" type="FSS" frequency="121.7200"/>
<Com name="SIBARI" type="APPROACH" frequency="135.6700"/>
<Com name="SIBARI" type="APPROACH" frequency="119.0000"/>
<Com name="SIBARI" type="ATIS" frequency="125.6200"/>
<Com name="SIBARI" type="CENTER" frequency="132.6200"/>
<Com name="SIBARI" type="CLEARANCE" frequency="128.3250"/>
<Com name="SIBARI" type="CLEARANCE_PRE_TAXI" frequency="136.5200"/>
<Com name="SIBARI" type="CTAF" frequency="135.8000"/>
<Com name="SIBARI" type="DEPARTURE" frequency="125.3700"/>
<Com name="SIBARI" type="GROUND" frequency="118.2200"/>
<Com name="SIBARI" type="TOWER" frequency="122.4500"/>
<Com name="SIBARI" type="MULTICOM" frequency="125.3000"/>
</Airport>

My file is Objects.xml, and it works by trying the sim.
I don't have the <DeleteAirport .......... etc.
This delete line imagine both for airport already existing in MSFS that has radio frequencies, right?
Be patient but I'm at the beginning and this SDK seems a bit intricate to me, I should know more about how to set up with the various packages and files.
Now I have the VORs, some WAYPOINTS and ILS that I will copy from the same ADE - FSX file in XML. By adjusting the LAT and LONG geographic positions.
In case I will disturb you again for your valuable advice.
Thanks and Happy Holidays

P.S. sorry my english google translate
 
Messages
702
Country
australia
The <DeleteAirport> element was created by the tools within MSFS. I had to use it as the MSFS airport had 3 active runways but the real world airport only has 1 active runway.
 
Messages
110
Country
italy
Dear Anthony, Thank you very much, very kind, I wanted to ask you if there is a way to display the LAT and the LONG in the SDK? to position ILS and VOR? or download on LITTLENAVMAP airport and see the coordinates?
 
Messages
110
Country
italy
The <DeleteAirport> element was created by the tools within MSFS. I had to use it as the MSFS airport had 3 active runways but the real world airport only has 1 active runway.
Hello Anthony, in the new airport I have created the complete taxiways with 1 gate. when dominating the roaring, I am allowed near the runway without telling me the names of the taxis and he does not show me the blue arrows. I put a jetway into the gate and works, then when I insert other things like the pushback, the fuelcar gives me an error. if I insert them as scenery does not give the mistake but the landlord ignores them.
What should I implement?
I searched for tutorials in YT but in vain.
Do I need to create a Ground Service? how you do it?
Thank you and good evening
 
Messages
207
Country
germany
You'll find all these things in the properties of your taxiwayparking object. Right click the object name in the scenery object list and select Properties from the context menue.
Parking.jpg
 
Messages
110
Country
italy
You'll find all these things in the properties of your taxiwayparking object. Right click the object name in the scenery object list and select Properties from the context menue.
View attachment 66600
GuidoH thank you very much for your answer, I have set all the values in the properties, as in your image.
the only one that works for me is the jetway that in the project is linked with a dashed green line to the Parking. If I always insert in the Parcking SimObject as the pushback it does not give me an error but the SERVICE in the flight start phase tells me that it is not available.
If I always add a SimObject such as Marshaller in the design phase, it gives me a disaster of red errors.
the airport is a non-existent airport in MSFS and I think some script like service.xml is missing or am I wrong?
also I do not see the blue arrows that indicate the way of the taxy when the tower gives the consent for taxiing. during the design phase I named them all and also made the taxy of the runway.
For this I think I am missing some packages in my project.
I am attaching the project file if you want to view and suggest changes
Thanks again for your help
Merry Christmas
 

Attachments

  • SimpleScenery.zip
    3.2 MB · Views: 62
Messages
110
Country
italy
I have the problem of vehicle services putting a vehicle park, but the car fuel tells me that it is not available even if I see it parked in the vehicle park. what should i do?
Another problem is that the taxiing belt does not appear even if it is set ON in the ASSISTANCE menu. what could I do?
Thanks again for the vs. help
 
Messages
207
Country
germany
Hi, I checked your Scenery and after an initial error, I got at least the pushback working by using the Shift+CTRL+P key combination to be pushed back. The reason for the ATC not offering the pushback is possibly because of the frequency and procedure differences. You have defined 2 FSS 2 Approaches Clearance and Clearance_pre_taxi which might result into the ATC issues. But I'm not shure about that. So I tried with a more simple COM structure. it still doesn't work with ATC but with key strokes. Don't use frequencies bis more than 3 digits after the dot.
<!--
<Com name="SIBARI FSS" type="FSS" frequency="121.720"/>
<Com name="SIBARI APPROACH" type="APPROACH" frequency="135.670"/>
<Com name="SIBARI DEPARTURE" type="DEPARTURE" frequency="125.370"/>
-->
<Com name="SIBARI FSS" type="FSS" frequency="132.750"/>
...
Fuel should be available by using in Your xml file:
<Services>
<Fuel type="73" availability="YES"/>
<Fuel type="87" availability="YES"/>
<Fuel type="100" availability="YES"/>
<Fuel type="130" availability="YES"/>
<Fuel type="145" availability="YES"/>
<Fuel type="MOGAS" availability="YES"/>
<Fuel type="JET" availability="YES"/>
<Fuel type="JETA" availability="YES"/>
<Fuel type="JETA1" availability="YES"/>
<Fuel type="JETAP" availability="YES"/>
<Fuel type="JETB" availability="YES"/>
<Fuel type="JET4" availability="YES"/>
<Fuel type="JET5" availability="YES"/>
</Services>
Taxi lights left and right are not working all the times. Use edgelights instead. Looks like this in your xml and will create blue lights around Your apron (I used the same point out of your definition:
<ApronEdgeLights>
<EdgeLights>
<Vertex lat="39.73220009895310" lon="16.43798955071251"/>
<Vertex lat="39.72990375423527" lon="16.43913390153380"/>
<Vertex lat="39.72688493417081" lon="16.42687332591181"/>
<Vertex lat="39.72731492183593" lon="16.42610915147073"/>
<Vertex lat="39.72698176206724" lon="16.42362378500973"/>
<Vertex lat="39.72838134354493" lon="16.42290493620994"/>
</EdgeLights>
</ApronEdgeLights>
 

Attachments

  • objects.zip
    4.1 KB · Views: 56
Messages
110
Country
italy
Hi, I checked your Scenery and after an initial error, I got at least the pushback working by using the Shift+CTRL+P key combination to be pushed back. The reason for the ATC not offering the pushback is possibly because of the frequency and procedure differences. You have defined 2 FSS 2 Approaches Clearance and Clearance_pre_taxi which might result into the ATC issues. But I'm not shure about that. So I tried with a more simple COM structure. it still doesn't work with ATC but with key strokes. Don't use frequencies bis more than 3 digits after the dot.
<!--
<Com name="SIBARI FSS" type="FSS" frequency="121.720"/>
<Com name="SIBARI APPROACH" type="APPROACH" frequency="135.670"/>
<Com name="SIBARI DEPARTURE" type="DEPARTURE" frequency="125.370"/>
-->
<Com name="SIBARI FSS" type="FSS" frequency="132.750"/>
...
Fuel should be available by using in Your xml file:
<Services>
<Fuel type="73" availability="YES"/>
<Fuel type="87" availability="YES"/>
<Fuel type="100" availability="YES"/>
<Fuel type="130" availability="YES"/>
<Fuel type="145" availability="YES"/>
<Fuel type="MOGAS" availability="YES"/>
<Fuel type="JET" availability="YES"/>
<Fuel type="JETA" availability="YES"/>
<Fuel type="JETA1" availability="YES"/>
<Fuel type="JETAP" availability="YES"/>
<Fuel type="JETB" availability="YES"/>
<Fuel type="JET4" availability="YES"/>
<Fuel type="JET5" availability="YES"/>
</Services>
Taxi lights left and right are not working all the times. Use edgelights instead. Looks like this in your xml and will create blue lights around Your apron (I used the same point out of your definition:
<ApronEdgeLights>
<EdgeLights>
<Vertex lat="39.73220009895310" lon="16.43798955071251"/>
<Vertex lat="39.72990375423527" lon="16.43913390153380"/>
<Vertex lat="39.72688493417081" lon="16.42687332591181"/>
<Vertex lat="39.72731492183593" lon="16.42610915147073"/>
<Vertex lat="39.72698176206724" lon="16.42362378500973"/>
<Vertex lat="39.72838134354493" lon="16.42290493620994"/>
</EdgeLights>
</ApronEdgeLights>
GUIDO, How can I thank you? you have been a huge help, thank you for your time and availability, thanks again.
In the meantime, the pushback also works because I have entered a vehicle park.
Thanks again
 
Messages
110
Country
italy
Hi, I checked your Scenery and after an initial error, I got at least the pushback working by using the Shift+CTRL+P key combination to be pushed back. The reason for the ATC not offering the pushback is possibly because of the frequency and procedure differences. You have defined 2 FSS 2 Approaches Clearance and Clearance_pre_taxi which might result into the ATC issues. But I'm not shure about that. So I tried with a more simple COM structure. it still doesn't work with ATC but with key strokes. Don't use frequencies bis more than 3 digits after the dot.
<!--
<Com name="SIBARI FSS" type="FSS" frequency="121.720"/>
<Com name="SIBARI APPROACH" type="APPROACH" frequency="135.670"/>
<Com name="SIBARI DEPARTURE" type="DEPARTURE" frequency="125.370"/>
-->
<Com name="SIBARI FSS" type="FSS" frequency="132.750"/>
...
Fuel should be available by using in Your xml file:
<Services>
<Fuel type="73" availability="YES"/>
<Fuel type="87" availability="YES"/>
<Fuel type="100" availability="YES"/>
<Fuel type="130" availability="YES"/>
<Fuel type="145" availability="YES"/>
<Fuel type="MOGAS" availability="YES"/>
<Fuel type="JET" availability="YES"/>
<Fuel type="JETA" availability="YES"/>
<Fuel type="JETA1" availability="YES"/>
<Fuel type="JETAP" availability="YES"/>
<Fuel type="JETB" availability="YES"/>
<Fuel type="JET4" availability="YES"/>
<Fuel type="JET5" availability="YES"/>
</Services>
Taxi lights left and right are not working all the times. Use edgelights instead. Looks like this in your xml and will create blue lights around Your apron (I used the same point out of your definition:
<ApronEdgeLights>
<EdgeLights>
<Vertex lat="39.73220009895310" lon="16.43798955071251"/>
<Vertex lat="39.72990375423527" lon="16.43913390153380"/>
<Vertex lat="39.72688493417081" lon="16.42687332591181"/>
<Vertex lat="39.72731492183593" lon="16.42610915147073"/>
<Vertex lat="39.72698176206724" lon="16.42362378500973"/>
<Vertex lat="39.72838134354493" lon="16.42290493620994"/>
</EdgeLights>
</ApronEdgeLights>
Hi Guido
why do you think I don't see the blue arrows of the taxiway tape? on your pc with my project, did you see it when you get the taxi? I also read that taxies can have a direction, is that true? Can they be viewed with a tool from the SDK menu?
Thanks again very much
P.S. sorry for my translated Italian
 
Messages
207
Country
germany
As I mentioned, taxi lights are not working at all times. Please check my 17:09 message above for details.
 
Messages
110
Country
italy
As I mentioned, taxi lights are not working at all times. Please check my 17:09 message above for details.
Dear GUIDOH, in your answer I understood taxi lights, in fact my translate tells me lights (italiano: luci )
I was talking not about taxi lights (which are in the center of the taxi and are green) but about the "blue arrows" or "blue path tape)
as schematically here: -> -> -> -> -> -> blue which appears only when the taxi is accepted and takes you near the runway.
Thanks
 
Messages
207
Country
germany
I know what u r talking about - lights that u can select in the taxiway path properties. Forget about the left and right (blue) lights, they don't work at present. When You like to habe the blue lights left and right of your taxiway, use the code example that I have uploaded as a zip in my former message. Thx Guido
 
Messages
110
Country
italy
I know what u r talking about - lights that u can select in the taxiway path properties. Forget about the left and right (blue) lights, they don't work at present. When You like to habe the blue lights left and right of your taxiway, use the code example that I have uploaded as a zip in my former message. Thx Guido
Queste blu arrow non light
 

Attachments

  • C172Sottile.jpg
    C172Sottile.jpg
    314.7 KB · Views: 65
  • WnQPsjC.png
    WnQPsjC.png
    1.4 MB · Views: 56
Messages
207
Country
germany
Oh u mean the taxi help support...an area I've never been interrested in yet. So I cannot help you. The only thing I know is that it's only displayed when you have ATC clearance to parking, startup or any other permission relevant target of authorization. Regards Guido
 
Messages
110
Country
italy
[ICOD
Oh u mean the taxi help support...an area I've never been interrested in yet. So I cannot help you. The only thing I know is that it's only displayed when you have ATC clearance to parking, startup or any other permission relevant target of authorization. Regards Guido
Thanks a lot anyway, we misunderstood each other for blue arrow
 
Top