• Which the release of FS2020 we see an explosition of activity on the forun and of course we are very happy to see this. But having all questions about FS2020 in one forum becomes a bit messy. So therefore we would like to ask you all to use the following guidelines when posting your questions:

    • Tag FS2020 specific questions with the MSFS2020 tag.
    • Questions about making 3D assets can be posted in the 3D asset design forum. Either post them in the subforum of the modelling tool you use or in the general forum if they are general.
    • Questions about aircraft design can be posted in the Aircraft design forum
    • Questions about airport design can be posted in the FS2020 airport design forum. Once airport development tools have been updated for FS2020 you can post tool speciifc questions in the subforums of those tools as well of course.
    • Questions about terrain design can be posted in the FS2020 terrain design forum.
    • Questions about SimConnect can be posted in the SimConnect forum.

    Any other question that is not specific to an aspect of development or tool can be posted in the General chat forum.

    By following these guidelines we make sure that the forums remain easy to read for everybody and also that the right people can find your post to answer it.

MSFS CTD using ADE 2020 Alpha 21 HF5

Messages
20
Country
unitedkingdom
You probably better do it in Dev Mode. The method used for scenery polys is changed in recent updates and ADE is not yet modified for that
I apologise for troubling such a distinguished group, but I need your help.

I have successfully created airfields in FSX with the FSX version of ADE, and when I switched to flying in MSFS2020, I was able to import projects from the old version into the new ADE for 2020, build them, create them in the community folder, and fly to them with no problem. That was several months ago, I think using up to hot fix 3.

I have now tried to create a simple airfield using the hot fix 5 - I used the installer for HF4 then added HF5 as described previously in this thread. The airfield - just a runway - builds ok, the CMD box reports no errors, and the folder appears within the community folder. However, when I try to start a flight at this airfield, I get an immediate CTD - "The instruction at [memory location] referenced memory at [memory location]. The memory could not be read.". I have tried flying to this field in a helicopter, all is well until I touch down, when I get a CTD.

If I examine the folder in the community file, I have layout and manifest .json files, and scenery folder containing a world folder containing a scenery folder containing the airport BGL.

Any ideas as to what I should check please?
 

scruffyduck

Administrator
Staff member
FSDevConf team
Resource contributor
Messages
34,681
Country
unitedkingdom
Error like this?

1662906670220.png
 

rhumbaflappy

Administrator
Staff member
Resource contributor
Messages
5,351
Country
us-wisconsin
Hi Frank.
This is a new airport that isn't in the sim. Your runway is OK, but you do not have runway starts, and the sim needs those. Just try adding a runway start to each end of the runway, and see if that is the fix.
 
Messages
20
Country
unitedkingdom
Hi Frank.
This is a new airport that isn't in the sim. Your runway is OK, but you do not have runway starts, and the sim needs those. Just try adding a runway start to each end of the runway, and see if that is the fix.
That's cracked it, thank you. I guess it would be good if a warning got displayed if building a runway without starts, but I'll know now. Thanks again.
 

rhumbaflappy

Administrator
Staff member
Resource contributor
Messages
5,351
Country
us-wisconsin
I used ADE's fault finder to get the problem sorted. Lots of fun creating a new airport from scratch. Glad you got it started. :)
 
Top