FSXA custom buildings textures and their names.

Hi

I´m trying to customize the buildings texture in the autogen of my photoscenery. I´ve follow the SDK´s indications, setting my own texture in "Properties" Anotator´s menu. There, I selected my texture "test_autogen.dds" and then I copied it in fsx/textures main folder (as DTX1 + mipmaps). But, in the FS, the roofs were floating in the air, the buildings did not appear :confused:

So, I´ve tried:
- changing the texture extension to .bmp,
- changing the name (without "_" only "testautogen.dds")
- cloning the file to a "_LM" version ( I thought, maybe it is mandatory the night texture were created).
- and finally, downsampling from 1024x1024 to 512x512...
but everything without any success.

Then I started with the crazy tests and I found that if I rename my texture with any stock textures' names, it works! and it appears correctly.

Can someone point me what is the problem? Is there any name restriction? Did I do something wrong :banghead:? In the SDK I have not found anything about this.

Thanks in advance

Jose 'Bostar' Calero
 
Last edited:

arno

Administrator
Staff member
FSDevConf team
Resource contributor
Hi,

Try to enter the name without extension. That worked for me.
 
Hi Arno. Sadly it didn´t work either.

I´ve been testing more things (I´ve used the prefix BLDG,etc) but I think that the autogen only accepts default textures (you can modify them, but it´s mandatory to keep the name). The option in the annotator is to select one of those. It doesn´t accept new one with a custom name :(

To confirm this, I've checked how Orbx does it (via FTX central) and, apparently, they install their autogen textures overwriting the default ones.

Greetings
Jose 'Bostar' Calero
 

arno

Administrator
Staff member
FSDevConf team
Resource contributor
Hi,

No, I have been using a custom texture for my autogen here in tests.

Just remembered, your textures need to be in the main texture folder of FSX.
 
Please, can you confirm me if you see the autogen correctly in this test that I´ve just made? (1.9mb, it´s only a tile).

https://dl.dropbox.com/u/3054566/test_autogen.zip

It´s a zip with a replica of the folders structure of FS (addon scenery & texture). I´ve incluided the bgl with his agn. In the main texture folder only a test bmp (associated with the agn thru annotator).

A .flt too. It will put you over the tile with the autogen (near LEMT, in Spain).

thank you anyway :)
 
Last edited:
I see only roofs :(

I believe Arno had this when he first produced ScenProc but I can't remember the solution :eek:

 
Thank you for testing it, George.

As I said in the previous post, if you rename the texture as any default one (and setting it in the annotator), the buildings will appear correctly. For this reason I suspect that the autogen doesn´t like custom textures :(

Anyway, today I´m still going making some test. I hope to find any solution or, at least, an easy-non-intrusive alternative (without overwrite).

Greetings

Jose 'Bostar' Calero
 
Last edited:
Well, finally I think that I found a solution! :):)

In the main texture folder there is four building textures per each region with these names:

BLD+region+2.dds
BLD+region+2LM.dds

BLD+region+3.bmp
BLD+region+3LM.bmp

This gave me a clue.

As I said in the previous post, I copied my texture using the _LM suffix , but it didn´t work either. After try a lot of things, I renamed the night texture with the suffix LM (without "_") aaaand.... IT WORKS!!!



So, it seems it´s mandatory to create the night texture too using the suffix "LM". But It would be great if someone more confirms this "hypothesis" ;)

Greetings

Jose "Bostar" Calero
 
Last edited:

arno

Administrator
Staff member
FSDevConf team
Resource contributor
Hi,

Yes, last time I also bump my head into that night texture. I had forgotten about it already, but yes that night texture is required.
 
Top