CYDA Compilation Error

I just sent an error log of an unspecified error that failed to parse while working on this airport. Unfortunately I hit the <RETURN> key before completing an full explanation. Rather than resend the log I thought it better to explain here why you are seeing an incomplete error log explanation.

First, this is in regards to FSX, not P3D

A friend noticed that CYDA in the Yukon had renumbered the runway from 02/20 to 03/21. I opened up the stock airport in ADE and did a quick runway number change. Then I went to the Approach Page and repointed the stock approaches to the new runway numbers. I saved the file and then compiled and the compilation worked as expected.

Later I decided to add some taxiway signs and to build the correct and current approaches to the airport. After completing that work I got a compilation error that did not show in the....

Well, isn't that odd. I couldn't remember the specific wording of the compilation error so while I was typing this post I opened ADE and brought up my saved version of the renumbered/reapproached CYDA and hit compile again, expecting to get the parsing error. This time it compiled just fine. I double checked to make sure all my changes were present and they were. No idea why it wouldn't compile earlier and did compile after I had closed and reopened ADE to get the exact error code

Disregard my error log I guess... o_O

Randy
 

scruffyduck

Administrator
Staff member
FSDevConf team
Resource contributor
This was your error:

1547449873606.png


suggests that on line 1034 at position 18 of your xml source file you have, or had, a character which was not considered legal by the compiler
 
Thanks Jon,

I certainly appreciate the reply and apologize for the trouble, but in reading your explanation I had an "Ah Hah moment". I have had compile errors before, but in almost every case that I could recall, the offending problem was always identified like an unacceptable taxisign or forgetting to put a turn direction in an approach hold. This is the first time I recall getting a parse fail that didn't lead me to the problem, but I now see it did. I have never really read the compile fails carefully and that is my mistake and one I will correct.

This time I did use the "Show Source XML" (I think that's what it says) button in the lower left of the compile fail box, but didn't really understand how to use it. I expected to see the complete xml file, but now realize it was only giving me "snippets" at a time. I tried typing in different line numbers and never put together the fact that if I had just typed "1034" in there I would have been taken right to the line with the illegal character. I kept thinking as I was entering lines "How do I know what line to enter?" and it was right there in front of me the whole time. Every day I learn something and this is my learned "something" for the day. Thank you.

You probably hear this all the time, but, I just want to thank you for this amazing flight sim tool and the perseverance to continue to make it better and better. I would be lost without it. Thanks!

Randy
 
Top