effect bug in FSX ?

#1
Hi!

Trying to adopt my FS2004 airport flood effect, and get a strange error..

First of the codes :)

fx_engm_ground.fx: (controller fx)
Code:
[Library Effect]
Lifetime=5
Version=2.00
Radius=-1
Priority=0

[controller.0]
lifetime=0.0, 0.0
type=3
distance=2000.00, 2000.00
delay=7200.00, 7200.00
x offset=0.00, 0.00
y offset=0.00, 0.00
z offset=0.00, 0.00
effect.0=fx_engm_ground_e, 0.00, 0.00, 0.00, 0.00, 0.00, 0.00, 0.00, 0.00
Then the effedct itself:
fx_engm_ground_e.fx
Code:
[Library Effect]
Lifetime=5
Version=2.00
Display Name=Lightcone
Radius=250
Priority=0


[Properties]
Cockpit=1
VirtualCockpit=1
Spot=1
Tower=1
Map=1

[Emitter.0]
Lifetime=0.50, 0.50
Delay=0.00, 0.00
Bounce=0.00
Rate=1.00, 1.00
X Emitter Velocity=0.00, 0.00
Y Emitter Velocity=0.00, 0.00
Z Emitter Velocity=0.00, 0.00
Drag=0.00, 0.00
X Particle Velocity=0.00, 0.00
Y Particle Velocity=0.00, 0.00
Z Particle Velocity=0.00, 0.00
X Rotation=0.00, 0.00
Y Rotation=0.00, 0.00
Z Rotation=0.00, 0.00
X Offset=0.00, 0.00
Y Offset=0.00, 0.00
Z Offset=0.00, 0.00
Pitch=0.00, 0.00
Bank=0.00, 0.00
Heading=0.00, 0.00

[Particle.0]
Lifetime=0.00, 0.00
Type=19
X Scale=550.00, 550.00
Y Scale=580.00, 580.00
Z Scale=0.00, 0.00
X Scale Rate=0.00, 0.00
Y Scale Rate=0.00, 0.00
Z Scale Rate=0.00, 0.00
Drag=0.00, 0.00
Color Rate=0.00, 0.00
X Offset=0.00, 0.00
Y Offset=0.00, 0.00
Z Offset=0.00, 0.00
Fade In=0.00, 0.00
Fade Out=0.00, 0.00
Rotation=0.00, 0.00
Ground Normal=1
Static=1
Face=0, 0, 1

[ParticleAttributes.0]
Blend Mode=2
Texture=flood_terminal.bmp
Bounce=0.00
Color Start=194, 250, 240, 255
Color End=194, 250, 240, 255
Jitter Distance=0.00
Jitter Time=0.00
TempK=107.00
TempRate=0.00
uv1=0.00, 0.00
uv2=1.00, 1.00
X Scale Goal=0.5
Y Scale Goal=0.5
Z Scale Goal=0.5
Extrude Length=0.00
Extrude Pitch Max=0.00
Extrude Heading Max=0.00
Then my XML:
Code:
<?xml version="1.0" encoding="ISO-8859-1"?>
<!-- Created by Scenery Design Engine (SDE) on 06.09.2007 -->
<FSData version="9.0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:noNamespaceSchemaLocation="bglcomp.xsd">
	<SceneryObject lat="60.1923080887486" lon="11.0981575160242" alt="0.1M" altitudeIsAgl="TRUE" pitch="0" bank="0" heading="195" imageComplexity="NORMAL">
		<Effect effectName="fx_engm_ground.fx" effectParams="DAWN=1;DUSK=1;"/>
	</SceneryObject>
	<SceneryObject lat="60.1923080887486" lon="11.0981575160242" alt="0.1M" altitudeIsAgl="TRUE" pitch="0" bank="0" heading="195" imageComplexity="NORMAL">
		<Effect effectName="fx_engm_ground.fx" effectParams="DAY=0;NIGHT=1;"/>
	</SceneryObject>
</FSData>
As you see i call only the controller, to get the effect to work both during startup on actual airport, and arriving to it.

problem description: Effect is NOT visible when i am inside visible range, and visible when i get out of range ?

Any ideas ??

Freddy
 

HolgerSandmann

Resource contributor
#2
Hi Freddy,

a wild guess: none of the default controllers have Radius=-1; they all are set to a specific value >0 or =0. Perhaps something to fiddle with?

Cheers, Holger
 
#3
Hi again!

Tried to fiddle with the controller fx, and the -1 has makes no difference when set to 0 ore a positive number.. the effect comes visible in about 13500 feet when slewing direct up. (about 4000 meters). SO i was thinking the "Distance" parameters may do something strange here. When setting it to 5000,5000 the effect strangely came visible at much lower altitude. another strange thing using the controller, the effedct is not "stuck" to the ground, as i slew around above the airport, I see the effect moves on ground. This does not happen when using the effect with no controller file, but then, flying TO this airport does not trigger the effect. (effect only visible when starting from airport..)

Any other ideas ??

Freddy
 
#5
Hi Fog,

Just wanna say a big thanks for your light effects code. After battling the LIGHT_LANDING/LIGHT_TAXI method for months your way provides a better effect.

I haven't seen your issue yet as in your picture but I have seen on ocassion where the light cuts through a building at a certain angle. Maybe nothing as it goes away and it is usually at a distance.

Clutch
 
Top