Error: Index was out of range

arno

Administrator
Staff member
FSDevConf team
Resource contributor
#4
After you filed it, all the details are in my bug tracker. From there I try to fix them. But sometimes I focus on new features and don't always check new bugs immediately.

If I find some time tonight I'll check this bug.
 
#5
Thank you Arno! I've found that if i delete one truck from that scene, and reexport, then it works, its opening and compiling woth MCX. So maybe the problem is in model? But i can't imagine what that can be...
 

arno

Administrator
Staff member
FSDevConf team
Resource contributor
#7
Hi,

I can't reproduce the crash here on my machine. It seems you are using a build that is about 4 months old, so I would suggest you try the latest development release.
 
#9
Hi,

I can't reproduce the crash here on my machine. It seems you are using a build that is about 4 months old, so I would suggest you try the latest development release.
So. With latest version i can open it, but then i see all objects like this 1524597287612.png

They all are now floating in the air.

EDIT:
And again it's all because of one model from the scene. Whitout it all seems to work fine. 1524597755907.png :(
So what can cause this problem? This particular model was made like all the others. In sketchup, imported in max for texturizing and export. 1524598050725.png
 
Last edited:

arno

Administrator
Staff member
FSDevConf team
Resource contributor
#10
Yes, I see the same. But I don't know what content you expect of course. Which tool you used to make the X file?
 
#11
I'm using plugin from p3d v4 SDK for 3d's max 2017... till now i never had this type of issues...
Also, when i am trying to export, if i check BUILD MDL FILE, i get an error too 1524598409494.png
 
Top