• Which the release of FS2020 we see an explosition of activity on the forun and of course we are very happy to see this. But having all questions about FS2020 in one forum becomes a bit messy. So therefore we would like to ask you all to use the following guidelines when posting your questions:

    • Tag FS2020 specific questions with the MSFS2020 tag.
    • Questions about making 3D assets can be posted in the 3D asset design forum. Either post them in the subforum of the modelling tool you use or in the general forum if they are general.
    • Questions about aircraft design can be posted in the Aircraft design forum
    • Questions about airport design can be posted in the FS2020 airport design forum. Once airport development tools have been updated for FS2020 you can post tool speciifc questions in the subforums of those tools as well of course.
    • Questions about terrain design can be posted in the FS2020 terrain design forum.
    • Questions about SimConnect can be posted in the SimConnect forum.

    Any other question that is not specific to an aspect of development or tool can be posted in the General chat forum.

    By following these guidelines we make sure that the forums remain easy to read for everybody and also that the right people can find your post to answer it.


I have just updated CAT with the new version and gone through the process of putting in the animations for an updated windsock. As before I use the secondary animation and enter the parameters from 0 - 65535...press next and I get a run time error 13?

any ideas whya that would appear again, I am definately using the .asm files

Have you also installed the bugfix I released a little while ago? That fixes a crash when adding two conditions on the animation condition screen.

If you already have that, could you sent me the ASM files, so that I can debug your problem.
Cheers Arno,

First though which .asm files as there are 6 for each Windsock, low, medium or high, or do you mean the .asm that is produced albeit the error message comes up


Hi Paul,

I mean the ASM files that you are loading into CAT at the moment that it gives you the error.
CAT needs the _0.asm files as well. Without them I can not run your object through CAT and see if I can reproduce the error.
Hi Paul,

These files are enough for me to test it. I can reproduce your error.

I don't really understand where it comes from yet, but I did notice that part of your animation code is not correct. It looks like you forgot the tick18_ prefix for your animated parts. Could you check if the prefix is there first?
Hi Arno, yup I forgot to put tick18 in, so I have gone a step futher now and have produced a combined .asm called low, however the mdl will not create, do I need the mdl function present in the folder I am creating the windsock in, I suppose I do :confused:
Do you get any errors when you try to compile the MDL from CAT? If so, please post them here as they will tell what goes wrong.

PS. I have removed the ASM files you attached to your previous posts, so that you have some upload space again. As that problem is fixed we don't need the files anymore.
Hi Arno,

Right, I get through to the make mdl screen now, however all I am getting is a pop up box saying "File or Command not found", the main CAT box has a message saying "starting compilation"


OK, I have heard about that error a few times, but never found the reason of it. It is probably easiest to compile the ASM files CAT made manually with BGLC_9, this will give you your MDL file as well.

To do this, run the following command on the command prompt:

bglc_9 -mdl yourfile_cat.asm
Now thats odd :confused: I have just noticed that although I am getting a new .asm file it does not have the _cat.asm prefix, it is just normal, I name it Low Windsock and that is what I get, Is that correct?
Oh, yes of course. If you change the default output name that contains the _cat part, then you will get the name you specified :). That is fine.
Can I just drag the asm over the bglc_9 icon? I have tried that line in the command prompt and it will not reconise it
Yes, you can. BUT in that case you need to rename the output from BGL to MDL yourself (else you will crash FS).
The main ASM file, the other one is included in that file.

How about having a look at this tutorial btw, it shows you all basics of working with ASM files yourself.
In which case something is wrong as dragging the main .asm file doesn't produce anything at all :confused: I have even tried it using one of the .asm files from the root export from Gmax and it doesn't work..odd