ESP installation

#1
Hi all,
I just tried to install ESP on a test system with relative old components. It is a Dell dual CPU Xeon computer with a Geforce 7900 GS.
After the installation, when I start ESP, it claimed for the latest DirectX driver and crashes after a view seconds.

The measures I did were the following:
- installed the latest NVIDIA driver
- Installed the latest DirectX driver
- reinstalled ESP

no success...

On my main development system ESP runs fine.
Did anybody have similar troubles and found a solution?

regards
TOWSIM
 

arno

Administrator
Staff member
FSDevConf team
Resource contributor
#2
Hi,

What is the exact error message you get? That might help.

Also, when you say you installed the last DirectX, do you mean the last version of DirectX 9?
 
#3
Hi Arno,
the exact error message is:
ESP cannot run because the version of Microsoft DirectX(R) installed on your computer is incompatible. Please reinstall DirectX 9.0 by running ESP Setup, or download the current version from www.microsoft.com/directx.

I first installed a DirectX version 9.28? from the "Chip" Download site.
Then I tried the latest DirectX version 9.0c from the official Microsoft Site.
Both versions were published in February 2010. I even used the DirectX Test Tool to ensure that the installation is ok. The driver passed all the tests. Even the hardware acceleration test for version 9.0 worked fine.

I have FS2004 running on the same machine without any problem.

Thank you for you interest

TOWSIM
Friedhelm Michel
 
#4
Hi Arno,
I just found a solution for the problem by installing the DirectX SDK from August 2009. The DirectX version remained the same. It seems, that the DirectX runtime misses a component which is delivered with the SDK.
So finally I did not find exactly the reason but it works now.

Thank you
TOWSIM
Friedhelm Michel
 

arno

Administrator
Staff member
FSDevConf team
Resource contributor
#5
Glad to hear you solved it. It is indeed quite confusing since it seems there are many versions of DirectX 9.0.
 
Top