• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Export error

This is a new one on me:
"Warning: pruning animatimg scene graph nodes with no descendant" :eek:

This now comes up when exporting from Gmax to fsX
Possibly related to animations or custom animations, hard to tell as the parts listed in the error are not animated like the fuselage.

Can anyone point me towards deciphering it?

Mark Adams
Last edited:


Resource contributor
Mark, the only time I ever see that is if I am only exporting a select group of parts for testing.

The animated parts that are NOT exported still have their scenegraph data written to the intermediate file, so the compiler is simply letting you know that it's trimming the unused parts from the final model build.
Thanks for that Bill

Everything in the scene is being exported and everything arrives at the other end and displays so it isn't quite the same - but I am minus some animations.

Perhaps It is due to a modeldef.xml error and the warning report is from tidying up after the failed animations. That would kind of relate to what you describe.

More trial and error tedium, is there anything more enjoyable in the whole wide world?


Resource contributor
Well, on the up side, at least with the new compiler it only takes a few seconds to burn a new build, rather than the (sometime) very long and agonizing minutes that MakeMDL.exe requires! :eek:
Yeah, I don't get as many of those particular coffee breaks anymore!

The issue seems to be something to do with objects merged from other scenes. That seems to be the only thing they have in common. Each of the objects named in the warning:
1. had been made in another scene and brought in via the "merge" command
2.had a child part that had an animation, some were native animations and some were custom animations

Other merged items work fine, so I still have no idea what the cause might be.

Deleting the animation and creating it again in this scene cures the problem but is a pain.

If I find any more out I will post for anyone else with the same issue.


Resource contributor
Ah, that puts a different spin on things. When "Merged," although the keyframes are preserved, neither the stuff added by the Animation Manager nor anything added by the Attachpoint Tool are imported into the working scene... :censored:
Thanks Bill

If it is a known issue I will stop exploring it and get on with making things.

I was sure that other merged items were working correctly and crossed it off as a sole cause, maybe my memory is wrong about how I got those parts got into the scene (my memory is definately in need of SP2a so it is no surprise).


Resource contributor
Try setting up a new, empty scene.
"Merge" all your existing stuff to see if the problem persists.
Unfortunately I tried that early on and it didn't help

I also remade animations, broke heirarchy links and remade them.

My animations are working but it is always unpleasant to know that something is not perfect and is lurking in the shadows.
Hi there,

I ran into the same error today and want to give you a heads up what solved the issue for me.

I am using skinned mesh animations for some of my parts and this time I used dummies instead of bones to drive the animation. Although that works fine in Gmax the exporter seem to ignore dummies when used in that way.

So by changing the dummies to bones again, the animation works just fine in FSX.

Adding information to this thread based on my discoveries today. It's the first thread that pops up when you google the warning so hopefully if anyone else has this error they will read the solutions:

"Warning: pruning animating scene graph nodes with no descendant"

Had this warning today when exporting a model from FSDS. I use a custom program to inject texture definitions via a txt file into the x file before compiling with xtomdl. The error I made was typing in "Kohlsman" as the texture file name in the txt file rather than the "Kohlsmann" that I used in the model.

Seems the problem was the animated parts where textured but xtomdl was unable to find a matching texture definition in the x file (due to my typo). Once I fixed the typo all was good.

So check to make sure your texture definitions are correct for the parts.


Staff member
FSDevConf team
Resource contributor
Interesting thread this, I also have this problem in ModelCoverterX with some models. Let's see if this helps me to find the bug. On re-export of a model in MCX this warning appears, so I might have written something wrong in the X file.


Staff member
FSDevConf team
Resource contributor
After some debugging in MCX I found out that the pruning warnings are related to skin and bone animations which are not supported yet. So that's similar to the observations above.


Staff member
FSDevConf team
Resource contributor
Sorry to keep stirring the pot in this old thread, but I have done some more searching and in the model I'm debugging the warning goes away if I set the volume shadow material option to false. Has anybody seen something like that before and why would that be related? Are there requirements on animations when volume shadows are used?
I know, old thread, but I came across this today, and I can confirm, setting Volume Shadow off to every material has made this go away...