FSX Export problem. I cannot see the model in MCX.

jtanabodee

Resource contributor
#1
Hi,
I am making terminals of an airport. I could export one of the terminal before without problem. Once I came back to work on this terminal again, something weird happened. I cannot see the model when I load it up to MCX. There is a model since I can see the shadow and when I click on "Display normal", I can see the small red arrows around the model. But I cannot see the polygons, even when I direct MCX to the DDS texture, still nothing. I think the problem come from the exporter. But when I exported another terminal, it came out fine. It just only happen to this building. The polygons are not too many, 4832 polygons. There is no warning during exporting at all.
How can I solve this problem?
ExportProblem.jpg
 
Last edited:

jtanabodee

Resource contributor
#2
I thought I was wasting my time to solve this problem So I got my bgl back and converted it to 3ds file then imported to Gmax and work further.
Then I exported this building and look in MCX. Oh NO...ooooo, it gave me the same result.
 
Last edited:

arno

Administrator
Staff member
FSDevConf team
Resource contributor
#4
Hi,

I would check the material settings. Since you see the shadow and normals, maybe the material is fully transparent?

If you swtich from textured to coloured render mode, do you then see the polygons?
 

jtanabodee

Resource contributor
#5
Hi Arno,
I have switch to colored render mode, nothing I can see either. Like I said, I imported the successfully exported bgl file and converted it back to 3ds. Then import to Gmax and set up the new material to it. Nothing change, I still get the same result.
I also attached the MDL file. So you might want to check on.
 

Attachments

Last edited:

arno

Administrator
Staff member
FSDevConf team
Resource contributor
#6
That's weird. If you look in the material editor, what kind of colours do the materials have? Are they fully transparent?
 
#7
For interest's sake I dropped your file into MCX, and 'set default opaque' made it show up, so it does appear to be fully transparent.
 

jtanabodee

Resource contributor
#8
For interest's sake I dropped your file into MCX, and 'set default opaque' made it show up, so it does appear to be fully transparent.
Oh, thank you for testing that. But in Gmax it is still has z test alpha and other settings seem to be right.
I did that in my MCX and it is still the same.
 

tgibson

Resource contributor
#9
Interestingly, the material colors (Diffuse, etc.) are not set to be transparent. But if I turn off the Complex Shader the model becomes visible, so that suggests something in the settings displayed only by the Complex Shader view.
 

tgibson

Resource contributor
#10
1. Go to the Material Editor
2. Click on the material.
3. Choose Set Default Opaque in the drop down box.
4. Click the word Apply

Now reset your material settings as you like.

Hope this helps,
 

jtanabodee

Resource contributor
#11
1. Go to the Material Editor
2. Click on the material.
3. Choose Set Default Opaque in the drop down box.
4. Click the word Apply

Now reset your material settings as you like.

Hope this helps,
Thanks Tom, I got it back again!
I copied the material of another terminal and change the texture. So the material changed and the model becomes visible.
I don't know what happen but I did set up a new material from scratch and import the 3ds file which ported from the former bgl file of the terminal. Even that procedure, the terminal was still invisible. But when I copy the material from another terminal and applied to it, that works.
 

arno

Administrator
Staff member
FSDevConf team
Resource contributor
#12
I'll try to see which material attribute that is changed by the set default opaque template is causing the object to go transparent.
 

arno

Administrator
Staff member
FSDevConf team
Resource contributor
#13
It seems it's a combination of the z test and source/destination blend settings. But I don't understand why.
 

jtanabodee

Resource contributor
#14
It seems it's a combination of the z test and source/destination blend settings. But I don't understand why.
I don't know either. But in Gmax it seems to be something weird too. The terminal cause some how flickering. So I move some models out to the new file. It works right now. Gmax seems to work slowly in that file too.
 
Top