Failed initialization of Blender

I did not reinstall SDK and I tried opening it as admin. Here is the screenshot for the python code because I could not find where Blender says it thinks the modeldefpath is (I tried reloading Blender to see if it would read the changes then but I don't think it did).
shot157.png
shot156.png
 

Vitus

Resource contributor
I went through the code trying to figure out what could cause the issue. I found one major problem: the manual detection of the SDK doesn't work. At all. So until I fix that, we need to rely on the auto-detection of the SDK. But your problem doesn't seem to stem from that anyway, since the SDK path seems to be picked up correctly.

One thing I read on the web was that it might be an encoding issue. When you open the modeldef.xml file with notepad, does it state UTF-8 on the bottom right? Also, is the header of the modeldef file correct? It should be:
<?xml version="1.0" encoding="utf-8" ?>
 
I went through the code trying to figure out what could cause the issue. I found one major problem: the manual detection of the SDK doesn't work. At all. So until I fix that, we need to rely on the auto-detection of the SDK. But your problem doesn't seem to stem from that anyway, since the SDK path seems to be picked up correctly.

One thing I read on the web was that it might be an encoding issue. When you open the modeldef.xml file with notepad, does it state UTF-8 on the bottom right? Also, is the header of the modeldef file correct? It should be:
<?xml version="1.0" encoding="utf-8" ?>
I can confirm that the modeldef file has the xml and utf numbers correct.
 

Vitus

Resource contributor
Too bad, that would've been an easy fix. :)
Sorry, I'm out of ideas - for now. I'm working on a fix for the manual detect of the sdk though. maaaaaaybe it does something for you, but I'm skeptical.
 
Too bad, that would've been an easy fix. :)
Sorry, I'm out of ideas - for now. I'm working on a fix for the manual detect of the sdk though. maaaaaaybe it does something for you, but I'm skeptical.
Roger, thanks for trying though :)
 
Hi @Jason z,

Could you please make a video (via your phone also worth it) and upload it on your google drive and share the link for us to watch your steps? I think that will simply save sometime rather asking so many questions here.
 

Vitus

Resource contributor
Jason,
Check out the new update, this time with a working manual initialization of the SDK. Maybe it solves your issue as well?
 
Hi @Jason z,

Could you please make a video (via your phone also worth it) and upload it on your google drive and share the link for us to watch your steps? I think that will simply save sometime rather asking so many questions here.
Here's the video from before installing the SDK fix update:
(sorry about background music)
 

Vitus

Resource contributor
So, using the manual SDK-finder, does it work for you? I.e. after locating the SDK manually, do the animation list and attachpoint list fill up with values?
 
So, using the manual SDK-finder, does it work for you? I.e. after locating the SDK manually, do the animation list and attachpoint list fill up with values?
I double checked and it's giving me an error again for both selecting SDK and ModelDef. It's saying that the Modeldef.xml file is not in the right place so I created the folder there and copied the modeldef file there as well and it still gives me this error
shot158.png
shot159.png
 

Vitus

Resource contributor
Man, I'm really sorry you're having such a hard time getting this to work. And I am still clueless what could possibly cause this issue.
I attached a shortened modeldef.xml, that works on my machine. It's just the core and three animations to check whether or not it loads correclty. Could you do me a favor and try loading this file and see if that works?

If it does, there must be something fishy with your modeldef.xml file. If it doesn't it might be some system settings on your machine that wrongly interpret the file. I'm thinking of something along the lines of the region-code issue in GMax - Gmax wouldn't work properly if your windows settings for the decimal used the European , instead of the .
Maybe this is something similar?! Something specific to your machine that doesn't allow the parser to properly interpret the file...
 

Attachments

Man, I'm really sorry you're having such a hard time getting this to work. And I am still clueless what could possibly cause this issue.
I attached a shortened modeldef.xml, that works on my machine. It's just the core and three animations to check whether or not it loads correclty. Could you do me a favor and try loading this file and see if that works?

If it does, there must be something fishy with your modeldef.xml file. If it doesn't it might be some system settings on your machine that wrongly interpret the file. I'm thinking of something along the lines of the region-code issue in GMax - Gmax wouldn't work properly if your windows settings for the decimal used the European , instead of the .
Maybe this is something similar?! Something specific to your machine that doesn't allow the parser to properly interpret the file...
Good news, that modeldef you sent me solved the problem. I figured out that some SODE code in my modeldef file must have corrupted it and when I tried to restore the original as recommended earlier, I forgot to remove the last line of code from SODE. I removed that last line of SODE code and now everything is working. No wonder the problem seemed so obscure. It was nothing wrong on your guys' end but rather my end. Thanks so much for helping me figure this out! Now I've just gotta figure out how to reinsert the SODE code without corrupting it again.
 
Last edited:
Top