• Which the release of FS2020 we see an explosition of activity on the forun and of course we are very happy to see this. But having all questions about FS2020 in one forum becomes a bit messy. So therefore we would like to ask you all to use the following guidelines when posting your questions:

    • Tag FS2020 specific questions with the MSFS2020 tag.
    • Questions about making 3D assets can be posted in the 3D asset design forum. Either post them in the subforum of the modelling tool you use or in the general forum if they are general.
    • Questions about aircraft design can be posted in the Aircraft design forum
    • Questions about airport design can be posted in the FS2020 airport design forum. Once airport development tools have been updated for FS2020 you can post tool speciifc questions in the subforums of those tools as well of course.
    • Questions about terrain design can be posted in the FS2020 terrain design forum.
    • Questions about SimConnect can be posted in the SimConnect forum.

    Any other question that is not specific to an aspect of development or tool can be posted in the General chat forum.

    By following these guidelines we make sure that the forums remain easy to read for everybody and also that the right people can find your post to answer it.

FFG import issue in 3DS 2022 and 2024


I've been using the FFG tool to move models between 3DS 2022 and GMax for a few years now. I just upgraded to a new computer, and for the life of me I can't import anything but basic primitives into 3DS 2022 now. I run the script, the script runs, the list of objects is generated, it finishes and says it's done, and then absolutely nothing happens.

I can export a basic cube and it works fine, but that's it. I've even tried running existing scrips that worked fine on my old computer from previous projects, and I have the same problem - I know those scripts imported into 3DS 2022 fine because I previously imported them into 3DS 2022 with no issues. I have the same issue with 3DS 2024. After some experimentation, I found that I can create primitives and export them fine, but the moment they get converted to editable mesh or editable poly, they refuse to import. This seems to be some sort of fundamental object creation issue. Of note, the script seems to be running much faster than it usually does - although this could be due to the fact that my new machine is significantly more powerful than my old one.

Does anyone have any ideas? Is there an obscure "maxscript works ON/OFF" option in 3DS that I checked on my old computer but forgot to check on my new one? I'm at a loss. None of the software has changed. The only change is this is a new computer and I am running Windows 10 Pro instead of Windows 10 Home like my old computer.
Last edited: