• Which the release of FS2020 we see an explosition of activity on the forun and of course we are very happy to see this. But having all questions about FS2020 in one forum becomes a bit messy. So therefore we would like to ask you all to use the following guidelines when posting your questions:

    • Tag FS2020 specific questions with the MSFS2020 tag.
    • Questions about making 3D assets can be posted in the 3D asset design forum. Either post them in the subforum of the modelling tool you use or in the general forum if they are general.
    • Questions about aircraft design can be posted in the Aircraft design forum
    • Questions about airport design can be posted in the FS2020 airport design forum. Once airport development tools have been updated for FS2020 you can post tool speciifc questions in the subforums of those tools as well of course.
    • Questions about terrain design can be posted in the FS2020 terrain design forum.
    • Questions about SimConnect can be posted in the SimConnect forum.

    Any other question that is not specific to an aspect of development or tool can be posted in the General chat forum.

    By following these guidelines we make sure that the forums remain easy to read for everybody and also that the right people can find your post to answer it.

first try at library creator xml

Messages
1,484
Hi Arno....

Your tool is much appreciated. I am not yet successful, but that's common on first try...

check out the error message...seen it before? It happens each time I attempt to add a mdl file to a library file. Since it's happening always, the lib file is always empty at this point. Sometimes I save the empty file, or not...no matter.

Can't upload an image, so I'll transcribe: Error box is titled "gmaximum"

Message is: Run-time error '91'
Object variable or With block variable not set



I've tried several models, some with the rotate to user tweak from mdl tweaker, some without that tweak....no matter.

Best,

Bob Bernstein
 
Humm, let's think.

Have you made the new library first and selected the MDL file there? Or is it already there that you get the error message?
 
I put your exe in a folder. its a folder with bglcomp.exe and bglcomp.xsd.

no models in that folder

models are in a subfolder

execute the exe, make new library....appears ok.

add model, direct your tool to the subfolder...error message

start again, this time add folder ... browse to subfolder....error message
 
OK, I assume to error message appears after you have selected the MDL file or does it happen once you enter that folder?

The fact that you are using different folders is not the problem by the way, that should normally work. But there must be some little bug somewhere :D.
 
error message appears the instant I double click on a mdl file.

(I've clicked add mdl file and then found one, and clicked on it...bingo...error)
 
OK, thanks Bob. With this information I will try to search in the source where it could go wrong.

Can you try one other thing for me? If you open a XML file as made by GMax, can you then add a new object to it or do you get the same error then?
 
well, doesn't work "fine"....

After appearing to work, I find the app freezes on saving. I have an error notice in a screencapture. I'll send it to your email.

B
 
OK, so it only happens when you create a new library and are asked to enter the first MDL object. That gives me a very good starting point to look where it can go wrong.
 
Just for the information of other readers, the problem has been solved now by making a complete install for Library Creator XML. It seemed some DLL files were missing or outdated. If someone else has this problem, just drop me a note and I can send you the full install as well.
 
Back
Top