[FS9] problems with attached objects

hi folks,

I have a serious problem:

In GMAX (fs2004 gamepack) I defined small objects (e.g. struts for a canopy) to be visible in a certain distance to the reference point. these objects are spread over an area of let us say 300m x 150m. Altough not all of the objects are really located next to each other I used the attach command to keep the number of objects as small as possible. Wherever necessary I welded the vertices. Around these objects I defined a bounding box (an editable mesh with an asigned material with 0% opacity). This "combined" ojects of course have assigned "Multimaterials" (coming from the attach process).
Compiling these objects including the bounding box works fine.

When I load the mdl-file into MDL TWEAKER II (most recent version) during the loading process some message is popping up but it disappears so fast that I cannot read the entire text. The only part in the text I could investigate is somewhat with "error". But I am able to define the distance limitations for the mdl-file with MDL TWEAKER. Saving then is no problem.

After recompilation of the xml-file I receice a bgl file. But in Flight Simulator the objects are not visible. The bgl file is dramatically smaller than an "untweaked" version of the same objects. I tested whether or not the objects themselves are corrupted but this seems not to be the case: without any tweak the objects are visible.

My question(s):
- is there any known limitation for tweaks for "bundles" of objects which are a composition of attached smaller objects?
- can the fact that multimaterials are assigned to these objects be a reason for this problem?

Any help or information about a workaround is highly appreciated because I do not want to do the whole work again ;)

kind regards
 

arno

Administrator
Staff member
FSDevConf team
Resource contributor
Hi Gianni,

Could you send me the MDL file for debugging? Sounds like there is something in it that MDL Tweaker can not read.
 

arno

Administrator
Staff member
FSDevConf team
Resource contributor
Hi Gianni,

Here I can load the MDL file into MDL Tweaker II without any error and if I save it again the MDL file has the same size. Also when I add a condition to it, everything seems to work fine.
 
Top