FSX connect the easy way ....

#1
hello all

i know that there is a threat for connecting problems from FSX Planner to FSX and i read ALL of it !

after 4 hours of working around Pete s solution is really the easiest and worked on the first try.

so:

just delete simconnect.cfg and simconnect.xml in your FSX Planner folder

launch FSX

connect to FSX from FSX Planner

IP 127.0.0.1

and now the tricky part:

you need to find the established port for FSX

this tool finds it for you

http://www.freedownloadscenter.com/N..._Download.html

( Open port scanner )

just add the corresponding port and you are done


regards

awe

PS: you can read the full threat here :

http://www.fsdeveloper.com/forum/showpost.php?p=38901&postcount=35
 
Last edited:
#2
FSX - FSX Planner Connection Problem

Hi,
I have a problem connecting to FSX though FSX Planner so i thouht this might solve that problem, the downlaod link you provided is invalid and therefore, i canot find the FSX port.

Thanks for your help,

Steve
 
#4
You don't really need such an utility to configure simconnect applications.
Just specify a fixed port number in simconnect.xml. Remember it's %APPDATA%\Microsoft\FSX\SimConnect.XML
Don't use port numbers < 1024 or 8080

Eg:
<?xml version="1.0" encoding="Windows-1252"?>

<SimBase.Document Type="SimConnect" version="1,0">
<Descr>SimConnect</Descr>
<Filename>SimConnect.xml</Filename>
<Disabled>False</Disabled>
<SimConnect.Comm>
<Disabled>False</Disabled>
<Protocol>IPv4</Protocol>
<Scope>local</Scope>
<Port>48447</Port>
<MaxClients>64</MaxClients>
<MaxRecvSize>16384</MaxRecvSize>
<DisableNagle>False</DisableNagle>
</SimConnect.Comm>
</SimBase.Document>

If you specify a global scope instead of local, the port number would not be posted to the registry and thus some applications may stop working, like FSUIPC
There is a bug in Java with IPv6 sockets on WinXP (not Vista), so force protocol to be IPv4 (see http://bugs.sun.com/bugdatabase/view_bug.do?bug_id=6230761) if you want to be able to connect with FSXPlanner.
 
#5
You don't even need to download a tool to show you open ports. Just open a windows command prompt and type netstat -na. This will show you a list of all listening ports on your system. Look for the one in the list showing 127.0.0.1 as the ip and something in the 3000-4000 range for port number and that will probably be it.

Denny
 
#6
ty for your concerns and help BUT with a XML file it just doesn t connect !

(atleast not for me)

that s why i started this threat and the way decribed in my 1 post connects perfectly.

regards

awe
 
#7
ty for your concerns and help BUT with a XML file it just doesn t connect !

(atleast not for me)

that s why i started this threat and the way decribed in my 1 post connects perfectly.

regards

awe
I tested this on XP and it worked very well. I haven't tested it ono Vista though, so am not sure about that.

However, we are now going to look into seeing if we can have FSX Planner automatically discover the appropriate port. If this is successful, then we'll be able to do away with the SimConnect.xml file on local connections. We'll probably still leave it as an option though, if people prefer that.

-Russell
 
#8
ic0277

it works fine now with your SimConnect.XML in folder :

documentsandsettings/"USER"/%APPDATA%\Microsoft\FSX\SimConnect.XML

ty again

regards

awe
 
Top