FSX/P3D - Not able to create cone sound

#1
Hello!

Now I am creating sound for Tu-154B2 (not Tu-154M like previously).
This plane (video is from FS9 but I would like to create the sound also for FSX/P3D):

The problem that I have is that when for example the engine is on idle, when looking from the front of the plane outside, and then change the camera angle, it sounds the same with the same volume.
In that time I have the idle sound played and another sound of exhaust that has to be sound at the highest volume when looking from the back of the plane outside.
So it had to sound the idle from the front, and the more angle changes then the volume of it should be decreased and the volume of the exhaust should be increased but the problem is that isn't happen!

That's what I wrote in the sound.cfg for these two sounds of outside idle (AX1) and exhaust (AExhaust):
Code:
[COMBUSTION.1.07]
filename=AX1
flags=0
viewpoint=2
rparams=0.555285,0.936170,0.600813,1.297872
vparams=0.000000,12.078153,0.061789,12.255773,0.182927,12.078153,0.270732,12.078153,0.347154,12.078153,0.406504,12.078153,0.555285,12.255773,0.604065,0.000000
InsideConeAngle=90
OutsideConeAngle=270
ConePitch=0.000000
ConeHeading=0.000000 -----> Determines that the direction is to the front
OutsideConeVolume=9600
link=COMBUSTION.1.08
Code:
[WHINE.1.00]
filename=AExhaust
flags=0
viewpoint=2
rparams=0.000000,0.531915,1.000000,2.000000
vparams=0.001626,0.000000,0.122764,3.019538,0.210569,5.328597,0.300000,7.992895,0.446341,8.525755,0.571429,9.769094,0.714286,11.190053,0.998374,13.321492
InsideConeAngle=90
OutsideConeAngle=270
ConePitch=0.000000
ConeHeading=180.000000 -----> Determines that the direction is to the back
OutsideConeVolume=9600
link=WHINE.1.01
I even increased the volume of the file "AExhaust.wav" itself but it still not help.
I tested it only on the first one engine running.
The problem is that it sounds exactly the same outside from all the directions!
The files:
http://www.mediafire.com/listen/kzf9fwzjwxq9q5k/AX1.wav
http://www.mediafire.com/listen/yd6pn1694s32a6n/AExhaust.wav

What is wrong there?

Thanks!
 
Last edited:
#2
The strangest thing - I took another 2 sound files of idle and exhaust from the soundpack of Turbine Sound Studios for Tu-154M, just for checking, and it worked perfectly!
But of course the idle sound of B2 and M are different, and also the exhaust sound of B2 and M are different, so I can't use them.
I can't understand what is wrong with what I do.
Maybe the volume difference between the idle sound file and the exhaust sound file has to be specific?
 
Last edited:
Top