FSX:SE functional GMAX operation with FSX SE

#1
Hello All, I'm having trouble navigating the various info i can find regarding the installation and function of Gmax in relation to FSX SE.

I want to get a working version of gmax so that i can create scenery for FSX SE

Some background info:

I've had previous installs of gmax and FS over the years... in the past was able to create scenery and put into FS with no problem.. i still think i'm familiar with the process (maybe a little rusty)

I am aware of the FS SDK issues (being incomplete) and i think i have a fundamental understanding that the p3d 1.4 sdk will work as substitute.

So far: Here's what i've been able to do :

* I've got gmax installed and the program opens up - I even have the "fs tools" in the menu bar.

* i get an error box that appears at loading "no execute function for undefined"

* I click Ok and the box goes away - everything seems functional Until i try to export an object (simple box with no texture)

* i can create a box - save it and then go to export... It gives me the option to "save as an .mdl" - i name it and hit ok....

* i get a message box about "mixed materials" fsx yes fs9 no - i hit yes

*gmax pops up a dialog box " flight simulator model export options" - I hit OK

*gmax returns with 3 boxes 1st "no guid set" 2nd "no friendly name set" 3rd "export module failure"

After that, I'm right back where i started... no other errors or crash...


I know that i've got to be close to functionality - because it seems as tho - things are nearly there... however - a LOT of conflicting info (with regard to different versions etc) has got me totally confused...


If anyone out there could help or advise - it would be greatly appreciated.. Again - I know i've got to be close to getting this solved....

Thanks !

John Walker
 

tgibson

Resource contributor
#2
Hi,

1. You need to set a GUID value using FSTools/LODName Tool. Click the button "Create new GUID for this"
2. Enter a friendly name for this object (anything will do). Click Go.
3. Now try to Export.
 
#3
Tom Thanks for the reply - However that does not seem to be the problem...

I can get to the FS tools in the menu , but when i go to click on LODname tool - an error box pops up this time with the message "no + function for undefined" (maxscript macroscript error exception)

gmax 1.JPG
 

n4gix

Resource contributor
#6
How do you start your GMax? The FSX SDK has a shortcut for GMax cleverly named "FSX_GMax" that invoked GMax with a bunch of important start up data.

Try creating a new Shortcut with this in the Target box:
%GMAXLOC%gmax.exe -i gamepacks\FSX_GMaxGamepack\gmax.ini -p gamepacks\FSX_GMaxGamepack\plugin.ini

and this in the Start in box:
%GMAXLOC%
 
#8
I did just try your suggestion of making a new shortcut and it was exactly the same result as using the one in the gamepack folder. no luck..
 

n4gix

Resource contributor
#9
John, is that from the FSX SDK? As you said the FSX:SE SDK is incomplete. Make certain that you have all of these files in your FSX_GmaxGamePack folder:

 
Top