• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

P3D v4 Gauge not showing


I have developed EasyFMC as a C++ gauge some years ago. I recently ported it to 64 bits and made it compatible with P3Dv4. It works perfect on my system, but some people (not all) don't see it in P3Dv4, as shown on the attached image (the FMC should appear on the pedestal), it doesn't appear in 2D either, just showing a black rectangle.

I made all the possible tests on my system and it works perfect, I was unable to reproduce the bug. For the people who have this problem, the strange thing is that nothing appears, not only the gauge background... I don't understand what is wrong because this gauge was developed according to the gauge SDK, it is a very standard gauge that uses no specific code or "hack", it doesn't use SimConect because it was originally developed to be compatible with FS2004 as well.

Does anybody has any idea to explain this strange problem?
Any help is greatly welcome :)




Resource contributor
Do the config files of the users point to the correct gauge location?

Is the correct VC++ reistributable installed?
Yes, the config files are correct. In fact, the gauge is listed in the panel.cfg and the gauge file itself (the DLL) is in the "Gauges" folder, very standard installation...
Your quetion is good because P3D reacts as if the DLL gauge file wasn't there, but I confirm it IS there as expected.

I am not sure VC++ redistributable package is installed, but it shouldn't be required because I don't use SimConnect. I may be wrong, but I thought this package was installed with P3D v4 installation.
I must say this package is installed on my system because I have Visual Studio, also installed by FSX for other users, so maybe it fails for users who just have P3Dv4 and nothing else...


Resource contributor
Compile the gauge with the /MT option, rather than /MD.
This will remove the runtime library dependency altogether.
Thanks for the tip Doug.
I recompiled the gauge with the /MT option and sent it to someone who had the problem. I am still waiting for his feedback...
I'll let you know if it solved the problem, I hope it will.