• Which the release of FS2020 we see an explosition of activity on the forun and of course we are very happy to see this. But having all questions about FS2020 in one forum becomes a bit messy. So therefore we would like to ask you all to use the following guidelines when posting your questions:

    • Tag FS2020 specific questions with the MSFS2020 tag.
    • Questions about making 3D assets can be posted in the 3D asset design forum. Either post them in the subforum of the modelling tool you use or in the general forum if they are general.
    • Questions about aircraft design can be posted in the Aircraft design forum
    • Questions about airport design can be posted in the FS2020 airport design forum. Once airport development tools have been updated for FS2020 you can post tool speciifc questions in the subforums of those tools as well of course.
    • Questions about terrain design can be posted in the FS2020 terrain design forum.
    • Questions about SimConnect can be posted in the SimConnect forum.

    Any other question that is not specific to an aspect of development or tool can be posted in the General chat forum.

    By following these guidelines we make sure that the forums remain easy to read for everybody and also that the right people can find your post to answer it.

MSFS Global AI Ship Traffic FSX, P3D and MSFS2020

Messages
809
Country
denmark
Henrik,
Your annoying problem of textures seems to (IMO) be in relation with LODs/Texture management.
On this screenshot (https://forums.flightsimulator.com/...621712f38104f70ef0c82dc4774af932f5c55fcd.jpeg)
The size of the boat is very small and therefore the mechanism of LODs must be used. There was a discussion about whether or not to reduce the textures with the extra LODs and the person was complaining that the object was turning gray instead of keeping its original textures. One of the solutions was to use the notion of vertex colors for some LODs to gain in memory and rapidity
=> https://www.fsdeveloper.com/forum/threads/lod-looses-texture-when-zooming-out.449744.

If the management of LODs remains as it is today, I think it will be necessary to create at least 3 LODs for each ship

As RumbaFlappy suggests you should go and have a look at this type of discussions:
Hi Didier,
I think the issue is different - the sim engine simply picks textures from a completely different simobject at random. It can be inside the Global AI Ship Traffic or another folder with simobjects - e.g. aircrafts - at one test run everything okay - during the next the texture allocated is from another model... nothing systematic. So far I just observed it for the simobjects included as mdl files - the ones I have converted to gltf works properly... I think...
Henrik
 

rhumbaflappy

Administrator
Staff member
Resource contributor
Messages
4,777
Country
us-wisconsin
I think these problems are due to bugs in the compiler. The SU4 compiled objects seem fine. So it may be that the core of the sim is OK... just the BGL compilation is wacky.
 
Messages
809
Country
denmark
I would go here to get support from Asobo: https://devsupport.flightsimulator.com/index.html

This is the developer support site and FlyingRacoon is the Asobo representative. He is quite good with his job.
Will do... but their answers regards to AI so far have been short..... Not too high on the agenda I suppose, even if I guess for many it is important for the immersion factor
I think these problems are due to bugs in the compiler. The SU4 compiled objects seem fine. So it may be that the core of the sim is OK... just the BGL compilation is wacky.
Certainly somewhere it "forgets" where to look for the right texture...
 
Messages
242
Country
germany
Hi Henrik,

I think that both errors, the swapping textures as well as the "not showing ships" are due to the fact that the compatibility mode does not work 100% with the BGL files.

If I compare this with my "Hamburg harbor" for MSFS, where more than 20,000 native objects are placed in quite a small space, there are no problems at all.
On the other hand, with the AI ship traffic that I inserted using the FSX method, there are the same problems as with GAIST off Rio de Janeiro. Sometimes the ships are displayed and follow their route perfectly, the next time not a single ship is displayed (neither in the simulation, nor in LNM).

So I also think that your new version of GAIST, with the native models, will work fine.
 
Messages
809
Country
denmark
Hi Henrik,

I think that both errors, the swapping textures as well as the "not showing ships" are due to the fact that the compatibility mode does not work 100% with the BGL files.

If I compare this with my "Hamburg harbor" for MSFS, where more than 20,000 native objects are placed in quite a small space, there are no problems at all.
On the other hand, with the AI ship traffic that I inserted using the FSX method, there are the same problems as with GAIST off Rio de Janeiro. Sometimes the ships are displayed and follow their route perfectly, the next time not a single ship is displayed (neither in the simulation, nor in LNM).

So I also think that your new version of GAIST, with the native models, will work fine.
Hi Manfred,
I was just testing native ferries in New York last night and after getting the package right.... a missing point in the compilation took three hours.... but after that they showed up on time and place. I will pack another package tonight and then I will tell you have to pack and send you a couple of dummy files for you to introduce your ships into. Did you convert your ships to native format already or should that be part of the story...?

Henrik
 
Last edited:
Messages
242
Country
germany
Hello Henrik,

I have already prepared everything and converted all ships that should sail in the port and on river Elbe into gltf format.
 
Messages
809
Country
denmark
21080611273816112917520513.jpg

21080611273916112917520514.jpg
 
Messages
809
Country
denmark
These ferries are brilliant!
Just need the wake, but Didier (Lagaffe) is helping out so I guess we will get there in order to release the first native package by the end of next weekend. Still I hope the issues with texture mixing will be resolved so the carry over package will continue to work until we get to the end of the conversion... I guess we speak 3000 textures to convert though I didn't count and some are simple... But at least 400 new PBR templates needs to be created.

21080703485216112917521158.jpg


21080801042116112917521605.jpg
 
Messages
1
Country
slovakia
This is absolutelely great work! I cant wait for wake and smoke on this update. I have question. Can you create some light GUI app for easy creation of custom (ferry) routes? Show map, click from, click to, time frequency, numer of boats, type of boats. It will make custom routes over the world in flightsim.to.
 

rhumbaflappy

Administrator
Staff member
Resource contributor
Messages
4,777
Country
us-wisconsin
Still I hope the issues with texture mixing will be resolved so the carry over package will continue to work until we get to the end of the conversion... I guess we speak 3000 textures to convert though I didn't count and some are simple... But at least 400 new PBR templates needs to be created.
There is some indication that MSFS now only loads a texture once, so if a package uses a texture of the same name of one already loaded, the wrong texture may be used. If true, then the solution is to rename the textures to a unique name (like a prefix with the package or object name). This could be done with a text editor to edit the glTF files, and a file renaming editor for the textures such as 1-4a Rename
 
Messages
6,629
Country
us-illinois
Hi Dick:

If we use MCX > Material Editor > {Texture} tab [Prefix all with model name] button to re-name mapped texture Materials:

* Will we be at risk for having too long of a file name and thus having too long of a folder / file path in MSFS VFS sub-system ? :scratchch


Thanks in advance for any impressions you may offer here, on feasibility of using MCX to do the file re-naming. :)

GaryGB
 
Messages
809
Country
denmark
There is some indication that MSFS now only loads a texture once, so if a package uses a texture of the same name of one already loaded, the wrong texture may be used. If true, then the solution is to rename the textures to a unique name (like a prefix with the package or object name). This could be done with a text editor to edit the glTF files, and a file renaming editor for the textures such as 1-4a Rename
I will try to test this evening, but it still doesn't explain as the ship models actually have unique textures based on ship names - in worst case we would just see many of the same ship. But the loading of the first texture with that name was probably the case before SU5 where we always ended up in tests having too many of the same ship, and we resolved by always have pairs of model folder and texture folder, even if this logically meant repeating a lot of models. However that problem didn't give textures from other AI ship types mixing.
 
Messages
242
Country
germany
Hello Henrik,
I'm keeping my fingers crossed that everything will work in the beta test 🤞🤞🤞.
 
Last edited:
Messages
22
Country
ca-alberta
I'm am packing a beta test now... But that is just the first 70-80 ships to see if it works with larger numbers on different systems.
Fantastic, I definitely missed your stuff since I moved to XP, cant wait to have the marine alive again in MSFS. Your job is mindblowing.
 
Top