gmax - Aircraft appears black

System: i7 6700K, Graphics GeForce 970
FSX, but I am sure P3D will be the same

I have a very simple plane (Cessna 150) that I use specifically for AI around the airports where I used to fly, and now I "fly". The plane was made by a friend of mine using FSDS.

This plane appears fine in 5 different PCs, 3 with Windows 10, one Windows Vista and 1 with Windows XP. On this new PC (the i7 6700K with the GeForce 970), this Cessna 150 appears black. I, then, ported the plane to gmax using Arno's Model Converter and practically re-made the plane: still black on the PC, OK elsewhere. Then I tried dds textures, and even 8 bit textures: Black. The glass and the nose wheel strut are colored, not textured, and they appear fine.

Does anyone have any idea what could be wrong? All other planes appear fine, only this one has trouble.

Thanks

Fern
 

Heretic

Resource contributor
Have you tried other texture formats like 32bit or DXT1 or DXT3 bmp?

If the PC is new: Are the proper DirectX runtimes (that came with FSX) installed? Are the video drivers up to date?
 

hairyspin

Resource contributor
Other aircraft display just fine, so it's not video or driver problems. Does the model know where to look for textures? Is it possible the texture config is missing or mangled?
 
right. check the textures and his location. or you have the very same model duplicated flying somewhere. if it is the problem try to edit and change the guid. because maybe to find the other model could be difficult
 
You will find a blue and white checkered button on the Material panel. Make sure that is clicked (depressed) so that it is 'active'. Your maps should then show up in FSX.

Make sure they are in DDS-5 ARGB 8PB format. They must be 'exactly' 1024, 2048, 4096, 512, and or any mix of those, such as 512x4096, etc. They cannot be one pixel off or they will not work.
 
Guys, maybe I didn't emphasize enough: the plane appears FINE in 5 other PCs at my house, and in three other PCs at my friends. It only appears black in this new PC I just bought, an Acer Predator G6. ALL other aeroplanes appera fine on it, too, including the massive number os AI planes. It is just this little stinky plane giving me trouble, in one PC out of 9.
As I mentioned, I tried all formats of texture, including dds and 8-bit.
And I want a Cessna 150 for AI...
Thanks, guys

Fern
 

tgibson

Resource contributor
And if black only in FSX, can you remove the plane from the SimObjects/Airplanes folder and no longer find it in the Select Aircraft menu? Another version may be hiding on that machine.
 
Seeing that nothing else seems to work, Lets try something, First, Delete the airplane out of Your FSX folder on the Computer it Doesn't Like, Simobjects, and or the Aircrafts folder, Grab Your Handy Dandy USB Thumb Drive, (Everyone has at least One), and down load the file from one of You're other Computers, and plug it into the Acer, in the same folder that You Downloaded it from, in the other Computer ! I'm thinking that , maybe Something got bent in the process of converting it and re exporting it ect. this gives You a clean start, with a new file that You know works ! Just Try'in to Help ! Johnman :cool:
 
Hi, Guys. You have no idea how I appreciate your help. Oh, well, you might have a pretty good idea, ha ha ha ha ha. Johnman's idea gave me hope... for a while. I copied the plane from the system that shows it black and pasted it in one of the other PCs and... it worked fine. The thing is that the plane looks fine in gmax (to answer one of the questions) and appears fine in FSX in 8 different PCs with Windows 10, 7, Vista and XP, but this new PC with Windows 10 doesn't like it. I did everything I could think of, and some I couldn't (Johnman's suggestion), including going back to gmax and modifying things just to see if that might fix it. One of my friends is re-doing it, too, and we'll test it tomorrow. I made a new one, and it works, but all my planes look alike, so I'd like to use this one.

Remember: This plane only appears black in one PC, with an i7 6700K and an NVIDIA 970. I'd appreciate any more ideas you might have.

Thanks, Fellows

Fern
 
One day You eat the Bear, the next day the bear eats You, Some days You just have MORE Fun than others, Good Luck and keep us informed - Johnman :cool:
 
Hey Fern - Did You copy it from a "Good" PC to the "Naughty" PC, just to satisfy My curiosity ??? - Johnman :cool:
 

Heretic

Resource contributor
Remember: This plane only appears black in one PC, with an i7 6700K and an NVIDIA 970. I'd appreciate any more ideas you might have.
I've written in my previous reply here that you should look at your video card drivers and (re)install DirectX from the FSX disk.
 
Hi, Fellows

OK, plane continues black, and here are the answers to the last two replies:

1. I did copy the plane from a "good" PC to the Predator, where it appears black. THEN I copied the black plane from the Predator to another PC where it appears fine.

2. This is only affecting ONE "Mikey Mouse" plane that a friend made for my AI and I modified it a bit, so I am NOT going to mess with drivers and Direct X, as everything else is working tickity-boo, but thanks for the suggestion.

I'll continue looking for a solution and, if I find one, I'll report. And you fellows out there, if you figure this one out, let me know.

Thanks

Fern
 
This Predator setup, does it have dx10 preview mode set under FSX Settings, where the others maybe haven't?
 
Yes, FSX shows the DX10 Preview mode set, but I don't use it: previous experiments with it in other PCs didn't have good results.
 

tgibson

Resource contributor
I don't understand, you say that it shows that it is using DX10, then you say it isn't?
 
I think that is what he is saying, and I don't understand it either. If you tick the dx10 box then you are using dx10. If that happens in the rogue PC only then there is a good chance that there's where the error lies.
 
Hi, Fellows

The box IS NOT ticked in any of the PCs.
But it is OK, guys, I gave up on that one.
Thanks
Fern
 
Top