GMAX export problem (FSX SDK path not found)

#1
Hi, all.

1. I have recently purchased FSX SE and download a separetly bundle of SDK files from here:

http://www.fsdeveloper.com/wiki/index.php?title=SDK_Installation_(FSX)

- SP1: https://www.dropbox.com/s/qmda3pt27fdao9z/FS_X_SDK_SP1a.zip?dl=0

- I have been using this SDK without any problems for my sceneries (resample for phototerrains, Annotator for autogen etc)

2. I installed Gmax to a separeted folder: D:\Program Files\Gmax\

3. I have copied "FSX_GmaxGamePack" to "gamepacks" inside Gmax mainfolder.

4. I run the file "FSX_GMax" and checked the "FS Tools": all is there, all is OK.

5. By the moment of exporting any model, after selection MDL files, I get the message: "Failed to find FSX SDK installation path!"

6. As I did a manual installation, I added these lines to the registry:

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Microsoft Games\Flight Simulator X SDK]
"SetupPath"="C:\\Program Files (x86)\\Steam\\steamapps\\common\\FSX\\SDK"
"SdkRootdir"="C:\\Program Files (x86)\\Steam\\steamapps\\common\\FSX\\SDK"

7. I also checked these posts and did not find a solution for my problem:

- http://www.fsdeveloper.com/forum/threads/gmax-fsx-sdk-path-not-found.311550/
- http://www.fsdeveloper.com/forum/threads/failed-to-find-fsx-sdk-installation-path.3568/


Could please somebody help me? Is this issue linked to a key in the registry? Is there a way to use Gmax succesfully with plugins from FSX SDK SP1A? Do I need to test another plugin? In this case, I mean, "gmax_FSModelExp". Ideas? A migration for 3DS MAX? Free?

System:

- Windows 10
- FSX Steam Edition
- SDK SP1A


Thank you! (big post, but I tried to give as much as detail I could)
Matheus
 
#2
I did a similar install a few days ago and got it working for the standalone SP2 version.

Briefly I followed the Wiki, had to do the msxml 4 install, then executed fsx_sdk_sp1a.exe (downloaded from elsewhere), then ran sdk.msi (the SP2 follow-up setup). That got me a working gmax link.

In Win 10 I did the gmax fix for the Material editor problem, also listed here. As far as I can tell, export works fine.

Certainly looks as if there should be an easier way ...
 
#3
[Solved]

I added this line in the registry:

[HKEY_LOCAL_MACHINE\Software\Wow6432Node\Microsoft\Microsoft Games\Flight Simulator X SDK]
"SetupPath"="C:\\Program Files (x86)\\Steam\\steamapps\\common\\FSX\\"
"SdkRootdir"="C:\\Program Files (x86)\\Steam\\steamapps\\common\\FSX\\"
 

arno

Administrator
Staff member
FSDevConf team
Resource contributor
#4
I can confirm that the two registries entries above also helped me to get my old FSX gamepack working again with FSX SE. I still had the FSX SDK on my computer, just these two entries was enough to get it working again.
 
Top