FSX Gmax FSX SDK path not found

#1
Currently working on my first scenery which uses a sat image as the base for the ground and surrounding area. I've created my plane and applied each tile to it. I'm now trying to export it as a Flightsim model file (.mdl) so that I can use modelconverterx to create my ground polygon and move on to the next step.

When I go to export it I get an error that says "Failed to find FSX SDK installation path!"

I tried to do some searching around to find a solution and did not.

I have my FSX SDK installed in the following location:

C:\Program Files (x86)\Microsoft Games\Microsoft Flight Simulator X SDK

I decided to run ConfigSDK.exe to try to solve the issue, but no burrito.

I tried uninstalling the SDK and reinstalling the SDK, no banana.

I tried putting the SDK on my second drive where I store my files for my scenery, ran ConfigSDK.exe, still no cigar.


Can anybody tell me what I am doing wrong here? Maybe I've missed something while searching.
 

scruffyduck

Administrator
Staff member
FSDevConf team
Resource contributor
#2
The general reason for this is that the registry entry for the SDK is missing or wrong. Uninstall/re-install may help. If not (and you don't mind looking at the registry) then you can check these:

Software\Wow6432Node\Microsoft\Microsoft Games\Flight Simulator X SDK"

Software\Microsoft\Microsoft Games\Flight Simulator X SDK

The key is SdkRootdir

As I recall the first above is for Vista and later and the second is for XP.
 
#3
I think it's the way you have installed the Gmax tool, have you followed the isntallation according the the Sdk instructions ?
you have to get the Gmax Gamepack and move them to the Gmax files and execute Gmax from there, afterward you have to set the path to fsx inside Gmax tools. At least it's the usual problem with Gmax, "not problem of Gmax, of users instead"
 
Last edited:
Top