FSX GMAX Material Editor not available after Windows 10 upgrade

#1
Hi folks,

I opted for the upgrade offer to Windows 10 a week ago. So far anything works (from today's view) but now I encounter a problem with GMAX.

When I want to open the material editor to assign an existing material to an object (or to define a new material) GMAX the editor is not opened. Looks for me like the system is searching for a path or something else.

Does anybody from you guys know this problem and a solution?

Thanks in advance.
 

Paul Domingue

Resource contributor
#2
I could not duplicate the problem on my Win 10 system. I had gMax installed prior to upgrading to Win 10, was this the same in your case or did you install gMax after the fact?
 

Paul Domingue

Resource contributor
#4
Did you work with a multi monitor setup before, but now you do not? Or might you have changed the monitor resolution so it is now offscreen? If so, this might help:

http://www.fsdeveloper.com/wiki/index.php?title=Changing_GMax_material_editor_startup_location

Hope this helps,
It's a coincidence that you should mention that because I lost my second monitor two weeks ago. I was expecting the problem of menus existing on the missing monitor, been there before, but it seems that Win 10 recognized the missing monitor and pulled the menus/windows back to the single monitor.
 
#5
Thanks for the replies! GMAX was already installed when I upgraded to Windows 10. And the software is operated with a single monitor setup. Very weird....
 

hairyspin

Resource contributor
#6
Hmm. I have Gmax on WinX, installed from new, and the material editor works fine. If neither the menu, toolbar button or shortcut key will open yours then a reinstall of Gmax might be needed.
 
#8
No good news. I reinstalled GMAX from scratch, checked all ini-files. But the problem still exists: the material editor does not open - the famous blue donut is turning and nothing happens: no message that something is not found - no nothing. This is really a mess....

Perharps I should mention that I have multiple gamepacks installed (fs2002, fs2004 and fsx). Tom: is this the same with you?
 
#9
Did you work with a multi monitor setup before, but now you do not? Or might you have changed the monitor resolution so it is now offscreen? If so, this might help:

http://www.fsdeveloper.com/wiki/index.php?title=Changing_GMax_material_editor_startup_location

Hope this helps,
No, it was installed in a single-monitor setup. It cannot be that the windows is opened somewhere outside the visible frame because in this case the opening sequence would have been successful (the sandwatch icon would disappear).
 

tgibson

Resource contributor
#10
This same problem surfaced with a friend of mine that brought his computer over to my place, and used my monitor. Since it was set for a different resolution, the Editor was opening off screen. A tweak of the ini file as in the link I posted fixed that. I assumed that if your OS upgrade also changed the screen resolution that could cause the same problem.

That said, if you have already edited the ini file and that didn't fix it then something else must be the problem. In fact since you are getting a blue circle cursor, it is certainly something else (there is no such symptom when it opens offscreen).

You did try pressing M to open it?
 

Paul Domingue

Resource contributor
#11
I would try another install but first I would completely uninstall gMax including any and all registry entries referring to gMax, completely shut down the computer not a reboot then reinstall. If that doesn't work, I don't have a clue.
 
#12
Eventually I had to do a reinstall from scratch. It was not only GMAX which did not work: other devices like my mobile modem were not recognized unter Windows 10 (no driver update available yet). The advantage is that now my system is clean again. Thank you guys for your hints anyway!
 
#13
Ah, ok, I had tested GMAX pretty well on the tablet before I put Windows 10 on the PC, and it worked fine, but I'm having the same issue. I'll need to schedule a reinstall when I can afford some downtime. In the meantime, I guess I'll find out how well I can work without the material navigator...
 
#16
This problem looks to be related to the FSX gamepack, as both the FS2002 and 2004 gamepacks display the material editor properly.
That explains why GMAX worked fine on the tablet, I didn't think to install the gamepack...
 
#17
Has anyone else got this, or a fix? I have just installed GMAX onto my system which is Win 10. GMAX was not installed before the win 10 upgrade. I have installed the gamepack correctly, but when I try to select the material editor, gmax just hangs, with the timer icon.
 

Heretic

Resource contributor
#20
Same problem here with the Material Navigator (the editor works) on Windows 10 x64.

- Works with the FS9 gamepack, but not with the FSX one
- GMax locks up when opening the material navigator from either the material editor or the material browser icon from the toolbar
- Reinstalling the FSX gamepack, for what it was worth, did not work
- None of the compatibility modes work
- File/folder permissions are not an issue

GMax will also lock up when using the dropdown list in the "File -> Open" menu, so I guess the two issues are connected.

Frustrating. I still have bodies in GMax' basement that I want to get rid of.


- Edit:

I've managed to isolate the nasty files. "gmax_MaxUtils.gup" and "gmax_MaxXML.gup". The presence of either will make the material navigator crash.
 
Last edited:
Top