gmax not responding after changing to OpenGL

Hi,

I just bought a new computer just for working with scenery (gmax, paint, PhotoShop, that sort of thingn). It is pretty fast, 3.9 GHz dual core.

I installed gmax, no problems. But when I change from HEIDI to OpenGL, close gmax, and re-open it, the viewports are white, the cursor has a few little "pages of paper" in it, and as soon as I click on anything gmax goes into a "Not Responding" state.

I can go back by editing gmax.ini, changing GFXType=OpenGL back to HEIDI and try again, and then it works.

If I try Direct3D it works, but with the same lack of definition as HEIDI, almost.

Important detail, this new PC has no separate graphics card. It has an on-board AMD Radeon HD8470D, and I installed the latest driver.

Any ideas?

Thanks

Fern
 
Hi, Tejal

It is Windows 8.1. Everything else works fine, including gmax in HEIDI and Direct3D modes. The only thing that doesn't work is OpenGL.

Fern
 

tgibson

Resource contributor
Various computers I've had would not work with OpenGL or Direct3D modes. I've been forced to use the other one.

Once you switched to Direct3D, did you maximize the texture sizes using the Configure Driver button?
 
Yes, I did, and I did the other little bits, too, copying from the other system that works fine.

NOW... I went to AMD and downloaded the latest driver for the APU and installed, and then it partially works now. It shows the texture in detail in the Perspective View, it doesn't stop working anymore. However, depending on what I do in one of the views, some or all of the other views go white until I click somewhere. All four views go white while I am holding the left button of the mouse down.

It has to be something related to the APU/on board graphics. It is not the driver, as I have now the latest and the greatest.

Only thing I can think of next is to install a video card...

Fern
 

hairyspin

Resource contributor
Depending on which driver is in use I get similar in Win7. Pressing 1 will refresh the display.
 
Hi, Tejal, Tom and Tom

Problem solved. All I had to do was to configure it as Direct3D and then re-configure the driver with different settings. The Perspective Viewport appears now with the texture as fine as it appears with OpenGL in my other PCs, and the blanking of the viewports doesn't happen anymore.

Attached is a picture of the two configurations that work, one for OpenGL and the other for Direct3D.

Thanks, guys for your input.

Fern
 

Attachments

Top