• Which the release of FS2020 we see an explosition of activity on the forun and of course we are very happy to see this. But having all questions about FS2020 in one forum becomes a bit messy. So therefore we would like to ask you all to use the following guidelines when posting your questions:

    • Tag FS2020 specific questions with the MSFS2020 tag.
    • Questions about making 3D assets can be posted in the 3D asset design forum. Either post them in the subforum of the modelling tool you use or in the general forum if they are general.
    • Questions about aircraft design can be posted in the Aircraft design forum
    • Questions about airport design can be posted in the FS2020 airport design forum. Once airport development tools have been updated for FS2020 you can post tool speciifc questions in the subforums of those tools as well of course.
    • Questions about terrain design can be posted in the FS2020 terrain design forum.
    • Questions about SimConnect can be posted in the SimConnect forum.

    Any other question that is not specific to an aspect of development or tool can be posted in the General chat forum.

    By following these guidelines we make sure that the forums remain easy to read for everybody and also that the right people can find your post to answer it.

GMax oddity

I have recently had to re-install Windows XP. When I did this I saved my GMAX setup on another drive and when XP was installed I moved the GMax program back to where it belonged. Everything opens fine and seems to work OK. BUT when I go to export a scenery object I get an error message:

"MSXML4.DLL could not be loaded. Config files won't be read." It still produces XML, MDL and ASM files. I have not tried to see if they are usable.

It appears that the MSXML4.DLL belongs in the FS9 root, at least that is where I found it. I copied a fresh one from the FS9 CD and put it in but that did not help.

Can anyone tell me what is causing this error and what I may do about it.

Thanks,

Al Gay
 
you may need to reregister it in windows !

click START , RUN and type regsvr32\windows\system32\msxml4.dll and press OK

make sure the file is in your System32 folder

Jeff
 
Hi Jeff,

There was not a copy of MSXML4.dll in the System 32 folder. I copied one from FS9 and placed it there. I then ran the RUN squence you listed. I get an error message "Windows cannot find 'regsvt32\windows\system32\msxml4.dll'. make sure you typed the name correctly, and try again. To search for a file, click the Start button, and then click Search."

Any further advise please?

Thanks

Al Gay
 

arno

Administrator
Staff member
FSDevConf team
Resource contributor
Try this:

regsvr32 c:\windows\system32\msxml4.dll
 
Thanks Arno but still not working.

1. I ran the sequence you suggested and received an error: LoadLibrary("c:\windows\system32\msxml4.dll") failed - A dynamic link Library (DLL) initialization routine failed.

2. I removed the MSXML4.dll from the Sys32 folder and ran the sequence again. This time it told me it could not find it, which makes sense.

3. I downloaded a free MSXML4.DLL from the internet, placed it in the SYS32 folder and ran the sequence again, I then got the same error as shown in #1 above.

Any other suggestions please?

Al Gay
 
Arno,

No I have not done that.... I am looking at it now and it tells me to UNINSTALL the old MSXML4.DLL. Does this mean I simply remove it from the SYS32 folder?

2.
To properly install or upgrade to the MSXML 4.0 SP2 SDK, uninstall the previous version of MSXML 4.0 and then install MSXML 4.0 SP2 with the custom option to install the SDK selected. -- Where do I find this SDK or is that what I am reading?

I may have to get someone to "talk me through" this. I now see to uninstall I need to go to a command line etc etc, most of which is quite confusing to me.

Any help most appreciated.

Al Gay
 

arno

Administrator
Staff member
FSDevConf team
Resource contributor
Hi Al,

Humm, strange, you should already have it when it asks you to uninstall it. So in that case there might not be a need to install it again :). But I have never seen this error myself, so I am not really sure what to do.

I don't think you need the SDK, that is only if you want to develop things using the DLL. You only need it to run another tool.
 
Arno,

Thanks so much. I installed that DLL using that installer and things appear to be working now. Your help is greatly appreciated.

Al Gay
 
Top