gmax Windows 8.1 - Shortcut doesn't work but Run command does

Hi, Everyone

This is NOT specific to FS2004, but that is what I am creating.

System is Windows 8.1

I installed gmax (new PC) and all was well. Had a little problem with OpenGL, but that was fixed.

However, with the gampacks installed properly, running gmax from the shortcut inside the gampacks/FS2004 folder starts gmax but it ignores the plugins, and it only wants to export plasma. Please keep reading before you decide it is the .ini files that have the trouble.

BUT, if I go Start > Run, and paste in there

C:\gmax\gmax.exe -i gamepacks\FS2004\gmax.ini -p gamepacks\FS2004\plugin.ini

, which is the target of the shortcut, it works fine, exports fine, and all is well.

THIS MEANS THAT THE .ini files are fine, Make MDL is fine, etc.

FOR SOME REASON WINDOWS 8.1 IS IGNORING THE QUALIFIERS in the shortcut.

So, I tried the Command Prompt (the black window), entered the same line, and IT DIDN'T WORK EITHER: It starts gmax without the qualifiers, and wants to export plasma.

Finally, I wrote a batch file with exactly the same content. It also DOESN"T WORK: It starts gmax without the qualifiers, and only wants to export plasma.

So, summarizing, I can start gmax from the Run command and it works just fine, but the shortcut, a batch file or the Command Prompt ignore the qualifiers and gmax only wants to export plasma.

Does anyone have an idea?

Thanks

Fern
 

Pyscen

Resource contributor
Hello,...

Have you tried running GMax under a different compatibility mode, (right click on GMax icon, "properties" and going to the compatibility tab)?
 
Hi, Dough. You name it, I tried.

Hi, Tom. No, gmax is in its default location, right in the root of drive C.

Running from the icon in Administrator Mode doesn't help either.

I found out in my other PCs in the house that the Run feature and the Command Prompt are different in XP, Vista and Windows 7 as well.

The catch is that XP, Vista and Windows 7 all run the Shortcuts as in the Run feature (paying attention to the qualifying paramaters), but Windows 8.1 seems to be running the Shortcut as if it was a command line in the Command Prompt.

Like I said, I can find work arounds, but someone should know a more elegant fix for this...

Thanks, Guys

Fern
 
PROBLEM SOLVED.

This may affect everyone migrating gmax to Windows 8.1.

The shortcuts/icons in the gamepack don't work the way the are. The command line has to be changed to include quotes in the main path portion:

"C:\gmax\gmax.exe" -i gamepacks\FS2004\gmax.ini -p gamepacks\FS2004\plugin.ini

That's it.

Thanks

Fern
 

n4gix

Resource contributor
That's unusual. Mine is simply
Code:
%GMAXLOC%gmax.exe -i gamepacks\FSX_GMaxGamepack\gmax.ini -p gamepacks\FSX_GMaxGamepack\plugin.ini
The %GMAXLOC% is a macro token that check's the Registry to find out where GMax was installed.
 
Top