Gmax zoom is acting strange

Recently I have been experiencing issues while zooming in and out in all view ports. Yesterday all was fine. Whereas I could click on a part, roll the mouse wheel, and the view would go large/small as needed.

Today I started Gmax doing the usual modeling. I'm finding that when I click in any view port (off the 3-view or model) that zooming with the mouse wheel works fine. The problem starts when I click on a part and want to zoom in/out.
The zooming feature appears to be on a different plane (exit, stage left, right, or whatever direction it decides to go) and not working.

Another symptom when trying to zoom in/out is when I click on a part and zoom, there is what appears to be a ghosting of the part (in wire form) that appears.

I have rechecked all settings with other frequent users to confirm my settings to theirs as a test bed in an attempt to rectify the issue, with negative results. I have also went to the extent of reinstalling, hoping that an overwrite of the file structure would alleviate the problem. Doing this did not help.

I'm hoping someone has a possible solution.
I am new to Gmax. (v1.2)

Currently I have the FSX Gamepack installed.

My operating system is Windows 7/64bit
GTX580 videocard


OleBoy
 

hairyspin

Resource contributor
To turn the wireframe 'ghosting' on or off hit O and the zooming problem may be related to where the mouse pointer is on screen - I find using mouse wheel the zoom is centred around the mouse pointer.
 
Hi Tom.

I tried the "O" key settings and it did not change things. It's real odd what's happening. The problem started right out of the blue. Like Gmax is possessed! :mad:
A Google search found nothing relevant to what I have going on. Nor the "Help" files, that I can find anyway.
 
One note, if you didnt know this. When you are in Perspective mode, your model will disappear in close zones when you zoom in really close. Only in Perspective mode though.

To get around this, get to a point close enough 'before' any parts disappear from view, and use the rectangle looking eye zoom icon, like a < symbol of the eye, and use that to zoom in farther and no parts will disappear or turn inside out.



Bill
 

hairyspin

Resource contributor
Another source of display problems like you describe - 'wireframe' style ghosting, actually bounding boxes appearing briefly - is concerned with which video driver you're using in Gmax.

I use Win7 64-bit with an nVidia 9800GT card and run Gmax with the Direct3D driver. In XP I used to use the OpenGL driver. The driver is selected from Customize/Preferences in Gmax and selecting the Viewports tab. Try either option and see which suits your rig best.

There's also the HEIDI software driver, but I'm not running an ancient rig with integrated graphics... :p
 
One note, if you didnt know this. When you are in Perspective mode, your model will disappear in close zones when you zoom in really close. Only in Perspective mode though.

To get around this, get to a point close enough 'before' any parts disappear from view, and use the rectangle looking eye zoom icon, like a < symbol of the eye, and use that to zoom in farther and no parts will disappear or turn inside out.
Bill
Hi Bill.
I'm not seeing any rectangle looking eye that you refer too. Is this symbol in the lower right corner by the "rotate" icon, or above in the toolbar?

Make a screenshoot - that will maybe help us.
I've since deleted the snapshots I had taken, and changed driver settings to OpenGL.
It's not great but it is better and not as noticeable.


Another source of display problems like you describe - 'wireframe' style ghosting, actually bounding boxes appearing briefly - is concerned with which video driver you're using in Gmax.

I use Win7 64-bit with an nVidia 9800GT card and run Gmax with the Direct3D driver. In XP I used to use the OpenGL driver. The driver is selected from Customize/Preferences in Gmax and selecting the Viewports tab. Try either option and see which suits your rig best.

There's also the HEIDI software driver, but I'm not running an ancient rig with integrated graphics... :p
I'm running nVidia drivers version 3.06.97. It seems to do good with Prepar3D. I know that what works with Prepar3D is not relevant, and I will/can update to a newer driver if need be. I would think due to the fact that Gmax is an older program that it's already outdated on it's own. As I mentioned, I'm giving the OpenGL options a try now. I'm keeping my fingers crossed that's the remedy.

Thanks everyone for your replies :)
 

hairyspin

Resource contributor
I'm not seeing any rectangle looking eye that you refer too. Is this symbol in the lower right corner by the "rotate" icon, or above in the toolbar?
It's in the lower right corner, but usually only when Perspective view is active. In other views the button is a magnifying glass in a shaded area and activates Region Zoom.

Quite frankly, Perspective (key P) view is something I rarely use since User view (key U) doesn't suffer from image clipping. In User view I can zoom in to individual vertices without losing any surrounding details.
 
Thank you.

I've been trying to avoid perspective view, and since have it set as "user"

I have a lot to learn in this program, and it does feed my frustrations. Hopefully my time in the drivers seat will lead me to modeling something worthwhile before the gray nodules start forming. :p
 
Its awesome. Very addictive. What it can do, when you learn where the tools are and how to use them, is just amazing and its fast.


The bad thing is when you accidentally turn something off or on and you have no idea where or what you have done. I was the poster child of doing that. arrgh....

X I think is the Gizmo key, and Y turns the brackets on and off around an object. I would miss hitting the Alt key or something hitting key selection shortcuts and suddenly I was offline for a day trying to figure out how to get something back.


A good way to figure out what you did is to go into your Customize section and go through all the buttons, looking for the one that you may have turned off, (such as Gizmo.. that was like 3 days trying to get that back. Nightmares.... ).
 
Its awesome. Very addictive. What it can do, when you learn where the tools are and how to use them, is just amazing and its fast.


The bad thing is when you accidentally turn something off or on and you have no idea where or what you have done. I was the poster child of doing that. arrgh....

X I think is the Gizmo key, and Y turns the brackets on and off around an object. I would miss hitting the Alt key or something hitting key selection shortcuts and suddenly I was offline for a day trying to figure out how to get something back.


A good way to figure out what you did is to go into your Customize section and go through all the buttons, looking for the one that you may have turned off, (such as Gizmo.. that was like 3 days trying to get that back. Nightmares.... ).
Modelers like yourself are assets to anyone wanting learn. For instance, I have worked with modelers in the past. Mainly beta testing and working with them compiling repaint templates. Frustration as a team!

Since my wandering into Google Sketchup, and finding that is easy (er), then with all the steps combined after that to get it into FSX, I decided to eliminate several steps. My journey into Gmax (for me) has been overwhelming. One of the hardest parts related is not knowing the terminology so I can look things up in the help files, or online. Or explain to an actual person as/to any issues I am having at the time.

I always (in most cases) try to figure things out for myself first before I fall back on others knowledge. To me it's the best way to learn. Although it DOES try my patience. LOL! Grrr :p

Since my short time with Gmax, I've also gained very much respect for accomplished modelers and those who create models for flight simulator. The modeling portion is relatively easy. Learning where the tools are and what they do in their combinations, is an experience I can't put in words. I'll admit. I've been PI-double dollar sign-ED many times. My remedy: Click save, hit the "X" and go do something else. I'm in no hurry :rolleyes:

Thanks for the help, Bill. All the little tidbits will help me along.
To anyone that helps me out at one point or another, thank you.



Out of curiosity, is there a way to add this and other tutorials into the Gmax UI so they can be pulled up via options contained or added in? An .HTM to .CHM conversion tool? Free is preferred.
Thanks for the TUT links.
 
Last edited:
Yo !
I'm not alone !! ;-))
-
This append for me since I work on a specific model.
And just on one view.
The top/bottom one.
Who know why ??
-
If I try to use the "common" zoom in/out" with the mouse wheel :
The view goes left or right but without any "zoom"...
-
This a little "ennuyous" (don't know in english .. ).
Bad ? Sad ? Horripilent ? Extremly desageable ... ;-)
-
I look everywhere in GMax and didn't found anything reporting to this ...
-
To be clear: I'm working on the AC-520 from Mr Shuppe.
He has the kindness to give her to us.
But ...
Haaarrrrg !
-
It will be a little step for you.
But a great one for all the human kind beginners...
If you have a answer !
-
Thank's to all.
-
A novice worker .
-
Daniel
 
Hey!

Sorry for bumping up this thread, but the problem is still here and no solution yet...

Have the same problem like Daniel or OleBoy...all of the sudden...just in user viewport.

When you unselect an object, the pan/zooming center of the camera is screwed up (seems to be far far behind the scene).

Does anyone know of a shortcut that accidently changes this behaviour??? How to set the camera center to the grid center?

Thanks in advance,

Steven
 
If you press & hold the zoom extents button in the lower right hand corner it will give you an option for "zoom extents selected" which is where I leave mine set permanently. In sub-object vertex mode for example you can select a group of four or five vertices then hit the zoom extents selected button and it will center the view orbit around those vertices - probably zoomed in closer than you want - so you have to roll the mousewheel to zoom out a bit and then use the little eyeball "Field of view" icon to position the view closer to the selected vertices. The field of view setting is the same as right clicking a viewport label and choosing "configure"; then on the lower right of the configure dialog you'll see the FOV setting, 45° is the default, if you're working on very small parts a setting of 3° or so works well.

EDIT: I avoid "User" views like the plague :)

Jim
 
Last edited:

tgibson

Resource contributor
LOL! Funny how people can use programs so differently. I much prefer the User view to Perspective - I can use the mouse wheel to zoom into exactly the location of the mouse cursor, and parts don't disappear when I get very close to them. So much more convenient. I avoid the Perspective view like the plague. :)
 

hairyspin

Resource contributor
I use Zoom Extents quite a lot, but also use the keyboard for zooming in or out, ([ and ] keys) just as much with zooming centred on the mouse pointer. I also use a single viewport view mostly and will switch view to left, right, top etc as necessary or Alt-middle mouse button drag to pan around. I like plenty of workspace to view the work.
 
Daniel: My guess is you have some rogue vertices on one or more parts. To check this, create a scene copy. Select all objects, slap on an Edit Mesh modifier, go to vertex submode and Select All. Click display extents and look out for far-out and possibly isolated vertices, I bet there are some. Kill them and see if it cures your problem.
 
Top