Ground flood light 3D ?

#1
Hi all!

I have been trying to create a new floodlight effect for ENGM.

OLD:


NEW:


This is still beta, and I am now trying to tweak my effect to get the correct size and color. BUT. is there any way to get the effect 3D, so it lights up the aircrafts parked on the gates ?.

Like this:


Here is my EFFECT code (its controlled by a controller FX file..)

Code:
[Library Effect]
Lifetime=5
Version=2.00
Display Name=Lightcone
Radius=250
Priority=0


[Properties]
Cockpit=1
VirtualCockpit=1
Spot=1
Tower=1
Map=1

[Emitter.0]
Lifetime=0.50, 0.50
Delay=0.00, 0.00
Bounce=0.00
Rate=1.00, 1.00
X Emitter Velocity=0.00, 0.00
Y Emitter Velocity=0.00, 0.00
Z Emitter Velocity=0.00, 0.00
Drag=0.00, 0.00
X Particle Velocity=0.00, 0.00
Y Particle Velocity=0.00, 0.00
Z Particle Velocity=0.00, 0.00
X Rotation=0.00, 0.00
Y Rotation=0.00, 0.00
Z Rotation=0.00, 0.00
X Offset=0.00, 0.00
Y Offset=0.00, 0.00
Z Offset=0.00, 0.00
Pitch=0.00, 0.00
Bank=0.00, 0.00
Heading=0.00, 0.00

[Particle.0]
Lifetime=0.00, 0.00
Type=19
X Scale=550.00, 550.00
Y Scale=185.00, 185.00
Z Scale=00.00, 00.00
X Scale Rate=0.00, 0.00
Y Scale Rate=0.00, 0.00
Z Scale Rate=0.00, 0.00
Drag=0.00, 0.00
Color Rate=0.00, 0.00
X Offset=0.00, 0.00
Y Offset=0.00, 0.00
Z Offset=0.00, 0.00
Fade In=0.00, 0.00
Fade Out=0.00, 0.00
Rotation=0.00, 0.00
Ground Normal=1
Static=1
Face=0, 0, 1

[ParticleAttributes.0]
Blend Mode=2
Texture=flood.bmp
Bounce=0.00
Color Start=152, 184, 184, 255
Color End=152, 184, 184, 255
Jitter Distance=0.00
Jitter Time=0.00
TempK=107.00
TempRate=0.00
uv1=0.00, 0.00
uv2=1.00, 1.00
X Scale Goal=0.5
Y Scale Goal=0.5
Z Scale Goal=0.5
Extrude Length=0.00
Extrude Pitch Max=0.00
Extrude Heading Max=0.00

Thx in advance!

Freddy
 
#2
The effect looks great ... I will try it in my next scenery. :D

As far as I know, we can't illmuniate the aricrafts with effects ... also not the Objects, only the ground :(
 
#4
Georg Aubele said:
The effect looks great ... I will try it in my next scenery. :D

As far as I know, we can't illmuniate the aricrafts with effects ... also not the Objects, only the ground :(
Study the aircrafts on the far end on my NEW screenshot.. there you see the aircrafts beeing lit... this alters depending on my altitude, and direction.. is this a bug ?

Freddy
 
#6
yepps.. they are,, tried to disable my effect and al aircrafts are dark again..

Somthing is happening with the effect at certain distances and angles... (you can also see the effect is causing part of the gates to be lit...)

freddy
 

Horst18519

Moderator
Staff member
Resource contributor
#7
No, I'm pretty sure, they are just AI-aircraft, that don't switch off the logo-lights when parked. There seems to be no way of illuminating objects in FS (only aircraft from within the aircraft.cfg).
Let's hope for the FSX to chance this. :)
 
#8
wow im amazed! very very nice results! ill try to code my own fx and use it as a light! Definately worth looking into! Thanx for the idea :) ! BTW: how are the framerates affected, compared to using another FS2002 semi-transparent light ground layer?
 
#11
Actually the lightsources are there, but they dont show from above (only when on ground, looking up.. :).

But: I would like a beam effect from the sources,,, have downloaded your effect packet, and i will do some research rgd the "strahler.fx" :)

Freddy
 
#12
WOW! amazing!
do you use gmax to place the effects or individual xml? and how are FR affected? compared to using a ground layer for lighting (bmp)?
 
#13
Hi!

Placing the effects using ObPlacer (direct XML), I have not noticed any FPS loss using effects instead og standard BMP.

Freddy
 

Horst18519

Moderator
Staff member
Resource contributor
#14
Unfortunately you won't find a solution for the beam in my fx. As you I only did the 2D-beam on the ground and the actual light. I didn't find a realistic way to produce a 3D-beam.
 
#15
Conditions for light effect not working

Dear all,

After having seen the screenshots in this post I started to try this in my scenery as well. For a long time it looked as if I would not get it working, but finally I noticed that the light effect is actually showing beautifully as long as I do not add a condition to it. As soon as the condition is set the effect never fires up. Any idea what I am doing wrong?

I use the "Apron Light-fx from EDLM2005" effect from Horst18519 and place it with this code:

<SceneryObject lat="47.9014381549238" lon="7.59623547751289" alt="0" altitudeIsAgl="TRUE" pitch="0" bank="0" heading="323.45538337715" imageComplexity="NORMAL" >
<BiasXYZ biasX="0" biasY="0" biasZ="0" />
<Effect effectName="fx_Lichtkegel.fx" effectParams="DAWN=1;DAY=0;DUSK=1;NIGHT=1;" />
</SceneryObject>

Thank you.
Martin
 
#16
There is an article in the wiki to this problem, you should not use these parameters in one effect, you have to place two: One for night and one for dusk/dawn ...
 
#17
Thank you, Georg. I just do not find the article :banghead:

It is not in using_gmax_to_create_apron_lighting, and I made a search in wiki for effectParams without a hit. Can you point me to the article, please ?

Cheers,
Martin

Added:

I have got it working now, but still would like to read the article to see if I can fetch some "understanding" as well
 
Last edited:
#18
Hmmm ... you are right, there is no article about it :confused: I was pretty sure, there is. Nevertheless, there is a thread about it here:

http://www.scenerydesign.org/forum/showthread.php?t=581&highlight=night=1

But in short terms:
Place twice the same effect controller, one with the parameter "DUSK=1" and one with "NIGHT=1" and your effect will be visible in night, dusk and dawn.

!!!But be sure to use controllers as described here:
http://www.scenerydesign.org/wiki/d...hting&s=controller#placing_the_effect_methods
 
Top