• Which the release of FS2020 we see an explosition of activity on the forun and of course we are very happy to see this. But having all questions about FS2020 in one forum becomes a bit messy. So therefore we would like to ask you all to use the following guidelines when posting your questions:

    • Tag FS2020 specific questions with the MSFS2020 tag.
    • Questions about making 3D assets can be posted in the 3D asset design forum. Either post them in the subforum of the modelling tool you use or in the general forum if they are general.
    • Questions about aircraft design can be posted in the Aircraft design forum
    • Questions about airport design can be posted in the FS2020 airport design forum. Once airport development tools have been updated for FS2020 you can post tool speciifc questions in the subforums of those tools as well of course.
    • Questions about terrain design can be posted in the FS2020 terrain design forum.
    • Questions about SimConnect can be posted in the SimConnect forum.

    Any other question that is not specific to an aspect of development or tool can be posted in the General chat forum.

    By following these guidelines we make sure that the forums remain easy to read for everybody and also that the right people can find your post to answer it.

Ground Poly Flicker

Messages
1,269
Country
us-northcarolina
Working on night lighting again, and I have the day/night switch working properly, but the poly is flickering. I have the poly sliced every few hundred feet or so. When you're in the air, it looks fine. However, once you slew down to ground level, the whole poly disappears :eek:

Any suggestions?

J1OZu8D.png


N1JS0kv.png
 

Attachments

  • vuj-ground-l_0.asm
    18.1 KB · Views: 321
  • vuj-ground-l.asm
    1.9 KB · Views: 303

tgibson

Resource contributor
Messages
10,232
Country
us-california
Do you have the area flattened?

Are you compiling these as FS2002 ground polygons? (otherwise they flicker).
 

arno

Administrator
Staff member
FSDevConf team
Resource contributor
Messages
30,726
Country
netherlands
And the flatten altitude is the same as the airport altitude in the bgl?
 

tgibson

Resource contributor
Messages
10,232
Country
us-california
Are you using the setting that doesn't suppress autogen? That can induce flickering.
 
Messages
1,269
Country
us-northcarolina
And the flatten altitude is the same as the airport altitude in the bgl?

Yes. The thing that's confusing me is how the actual ground poly itself is not having any flicker issues. Because of the ASM editing required to make it turn off during the day, I can't run that through MCX like I would normally do.

@TGibson

Yes, but this is shocking because it has never happened to me before.
 

tgibson

Resource contributor
Messages
10,232
Country
us-california
We don't yet know why the autogen suppression setting causes flickering in some cases, and not in others. But it does...
 
Messages
1,269
Country
us-northcarolina
I removed the autogen line (the line between BGL_END and BGL_RETURN in the _0.asm) and it's still flickering.

:mad:
 

arno

Administrator
Staff member
FSDevConf team
Resource contributor
Messages
30,726
Country
netherlands
Hi,

Did you try a different layer number? I see you use 54 now and it is not so common to use such a high layer number.
 

arno

Administrator
Staff member
FSDevConf team
Resource contributor
Messages
30,726
Country
netherlands
And something much lower like 12 or 16?
 

arno

Administrator
Staff member
FSDevConf team
Resource contributor
Messages
30,726
Country
netherlands
I have run out if ideas now. Do you have some files we can test maybe?
 

tgibson

Resource contributor
Messages
10,232
Country
us-california
While testing ground polys in ADE, we have found certain areas at certain airports (default and addon) where GP objects disappear/flicker/etc. from certain angles. We don't know why.
 

jtanabodee

Resource contributor
Messages
3,886
Country
thailand
I'm not sure if it is the case like myself.

I put flatten in ADE but it did not give me the same height through out the airport. When I used TCalcX to check the height and I found later some area was higher than the rest. I needed to put a new flatten with the highest point that I found from TcalcX and the problem went away.
 
Top