Ground Poly will never show

#1
screenshot.jpg

using ADE textures and put them into texture folders.I've tried several airport and different textures none of them show in the airports.It must be someting wrong.
screenshot(1).jpg
 

gadgets

Resource contributor
#2
The usual cause of this issue is that the flatten is below the elevation as the ARP and the GPs are therefore underground.

Don
 

tgibson

Resource contributor
#3
And can you confirm that the _GP BGL file was placed into an active scenery folder, along with any relevant textures in the texture folder?
 

gadgets

Resource contributor
#5
If you don't already have a flatten, then make one at ARP elevation. If you do have a flatten already, ensure it is at ARP elevation and that it extends to the GPs.

Also, at Tom said. ensure the …._GP.bgl is copied into your scenery folder.

Don
 

gadgets

Resource contributor
#10
Humphrey, did you copy/confirm the texture "gp_asphalt_Light.dds" into the texture folder companion to the scenery folder in which the airport resides. For whatever reason, PV4 did not display the expected "black" gp when the texture was missing. But, as soon as I suppled the texture, the GP appeared.

I that's not the issue on your system, try compiling FS8-style GPs. There are a couple unusual situations, depending on the relative locations of the GPs and ARP, where GPs do not display properly otherwise.

Don
 

gadgets

Resource contributor
#12
If the texture is present and FS8-style GPs don't work either, then I suspect your problem is more complex than simply a GP-issue.

I use p3dv4.4 sdk and p3dv4.3 main program because I cannot find a v4.3 sdk.
Can't comment on whether or not this is a good idea. Perhaps others can advise.

is that gp_asphalt_Light.dds? I just found .bmp one.
Either one will work.

I also note that, in your initial post, the GP Editor shows as 2.2.16. That's 3 issues out of data, and suggests you are using an older version of ADE. The current version of ADE_GP includes a couple of fixes re non-display of GPs. I have no way of knowing whether or not those fixes include your problem, but the fact that your GP displays on my system suggests upgrading to the current ADE release might be helpful.

Don
 
#13
This time I try to compile with FSX SDK from my FSX.iso,somethig more weird happend: my GP has a white outline which can only be seen at night,and I think the invisible GP covered my taxingway lights(with “lluminate” checked).
suggests upgrading to the current ADE release might be helpful.
However my ADE told me "is up to date".

considering using other verison of p3d...

screenshot3.jpg
 

gadgets

Resource contributor
#17
a white outline which can only be seen at night
Is the Illumination checkbox on the ADE-GP Compile dialog checked? If so, that would account for both the suppression of the GPs during daytime and the white outline at night.

Don
 
#18
I uncheck illumination and try again
sc002.jpg
it still made illumination textures only which cannot be seen at daytime,however these problems just happened on my new airports(which mean no any data in FSX) ,other stock airports are right to show GPs.
The problem is since illumination was unchecked why can't those GPs show at daytime?
 

gadgets

Resource contributor
#19
The screenshot suggests the GPs are still being compiled for ground illumination. Perhaps there's some residual file in your scenery folder that's causing this or perhaps not all the new files are being copied into your scenery folder.

I'm out of ideas. All I can suggest is that you delete the contents of your scenery folder (to get rid of any residuals) and delete all the GPs from your AD4 file. Compile your airport normally and check that is displays properly - without any GPs. Then add the GPs back into the .ad4 file and try again - with Illumination unchecked.

One other point. You said you are using the P3V v3.4 SDK. I note in the GP manual that ground illumination is only available from P3D v3.5 onwards. I don't recall why, but the mention suggests there's a significant difference between 3.4 and 3.5 that affects ground polys. So, when compiling the newly-entered GPs, I suggest you check Generate FS8-style GPs.

Don
 
Top