Ground Poly wizard eats runway

I don't know why I get this problem...

Looks like two planes overlapping, even though they're different layers (looks fine in FSX) The problem is that right about halfway down the runway, I'm missing a poly :mad:

 

Attachments

arno

Administrator
Staff member
FSDevConf team
Resource contributor
Hi,

Is the polygon really missing? In the preview the different layers are sometimes not drawn in the right order, so you can get flickering polygons.
 
when he actually compiled the runway and put it in FSX, there was this one pesky polygon that was completely just gone.
 
As Jon said, I compiled and the poly is missing. I'm not on my development computer at the moment, but I have circled the problem poly. Once I can get to that one I'll post a picture from inside the sim.

 

arno

Administrator
Staff member
FSDevConf team
Resource contributor
Hi,

If the polygon is really gone, I think it is a bug. Can you send me the file for debugging?
 
Hi.. I have a similar problem (FS2004).

If I use the wizard, I get an area around the plane that follows me.
In this area the terrain below my ground polygon shows up:
(in this picture the ground textures are a little bit transparent. Don't pay attention to that)



However, if I tweak the asm file, everything is fine:



If I go up one metre or so, that area disappears... So it can only be seen with C182 and not with A320, for example.

Thanks.
 
Last edited:

arno

Administrator
Staff member
FSDevConf team
Resource contributor
Ok, will take a look tonight.
 

arno

Administrator
Staff member
FSDevConf team
Resource contributor
Luis,

FS2004 style output should be the same as manual tweaking. The only difference I can think of is that the wizard will make sure the elevation of all polygons is zero. But if you have a flatten that should be fine.
 
mmm... There must be something... because the results are different.
In my last three sceneries I coudn't use the wizard because of that effect.
It's a pity, because the wizard is extremely useful.
Thanks Arno.
 

jdberg

Resource contributor
I got a similar problem in my last projekt (FSX) and fought several days.
The problem disappeared, when I disabled the ADEX-files expecially the _cvx.bgl file which contains the altitude of the airport.
All altitudes (flatten, airport-alt etc.) where set the same but the only workaround was to set these altitude to the value of the stock airport.
The difference in my case was only 0.06m but this solved the problem.

Jörg
 

tgibson

Resource contributor
Hi,

Yes, I'm thinking that rounding errors in the various programs (ADE, MCX, GMAX) are causing some of these problems. I'm not sure that setting things to 0 feet is always the best course, especially if the FS2002 SDK doesn't do this automatically...
 

arno

Administrator
Staff member
FSDevConf team
Resource contributor
Of course the FS2002 gamepack doesn't set the height to zero automatically, because it can also export 3D objects.

It's something I implemented because ground polygons should be flat. And I had issues slicing them when some vertices have another height.

When I make ground polygons myself they always have height zero. Combined with a proper flatten I never had bleedthrough issues.

I didn't have time to look into the issues reported here yet, but soon I will see how the wizard can be improved.
 

arno

Administrator
Staff member
FSDevConf team
Resource contributor
Hi Michael,

I had a look at the missing polygon and I can reproduce the problem. The tricky thing is that in my debug tool it does not happen. So a little more searching to do.
 

arno

Administrator
Staff member
FSDevConf team
Resource contributor
Hi,

I have found it now. So from the next development release it should work fine.

I have also change the code so that the layer number you enter in the wizard influences the preview. So the flickering polygons should be gone as well.
 
Hi,

I have found it now. So from the next development release it should work fine.

I have also change the code so that the layer number you enter in the wizard influences the preview. So the flickering polygons should be gone as well.
You're the best Arno :) When will the development release be uploaded?
 

arno

Administrator
Staff member
FSDevConf team
Resource contributor
It is automatically made every night at 2:00 (central European time).
 
Top