• Which the release of FS2020 we see an explosition of activity on the forun and of course we are very happy to see this. But having all questions about FS2020 in one forum becomes a bit messy. So therefore we would like to ask you all to use the following guidelines when posting your questions:

    • Tag FS2020 specific questions with the MSFS2020 tag.
    • Questions about making 3D assets can be posted in the 3D asset design forum. Either post them in the subforum of the modelling tool you use or in the general forum if they are general.
    • Questions about aircraft design can be posted in the Aircraft design forum
    • Questions about airport design can be posted in the FS2020 airport design forum. Once airport development tools have been updated for FS2020 you can post tool speciifc questions in the subforums of those tools as well of course.
    • Questions about terrain design can be posted in the FS2020 terrain design forum.
    • Questions about SimConnect can be posted in the SimConnect forum.

    Any other question that is not specific to an aspect of development or tool can be posted in the General chat forum.

    By following these guidelines we make sure that the forums remain easy to read for everybody and also that the right people can find your post to answer it.

MSFS Help needed - I am going crazy

Well I thought that I had ADE 19 sorted out and working correctly but it seems not as when I build my project the update the library for changes I made to my scenery object I only see the footprint for the old scenery object, the additions do not display in the footprint (and they are extensive covering an addition area of at least 50% of the original).
Now here is what I am doing.
ADE 19 installed
My projects are now stored at H:/internet/downloads - MSFS 2020/ADEprojects/ eg CAX3-F20-SDS-v2
I copy the folder containing the newly created .bin .xml and .bin files to -
H:/internet/downloads - MSFS 2020/ADEprojects/CAX3-F20-SDS-v2/PackageSources/JGA-cax3-sechelt water aerodrome-modelLib
In ADE 19 I have Settings > Options > Project set to H:\Internet\Downloads - MSFS 2020\ADEprojects

Could it be that I have spaces in the folder name - downloads - MSFS 2020 and if so where is the compiler finding the previous scenery object as I searched all drives on my PC for the scenery object (vancouver harbour docks.gltf ) and there is only one, the one in - H:/internet/downloads - MSFS 2020/ADEprojects/CAX3-F20-SDS-v2/PackageSources/JGA-cax3-sechelt water aerodrome-modelLib? It nuts!
Last edited:
John there’s a discussion somewhere about the merits (or not) of using spaces in folder names. It looks like you’ve used some. Replace with underscore or just join the words up. Then repair the ADE paths and delete the _PackageInt and Packages folder and try again.
Worth a try right now to get you going

LOL just read the rest of your post…

The other thing I do when compiling or working on a project is remove everything from your Community folder except the current package. This way when you compile the only things you should see are the items in your package and hence your ModelLib folder.
Items that get wrapped up from another package will then appear in the XML as Unknown
Last edited:
Thanks Philip,
I was starting to think along the lines you mentioned but then I remembered that when it was all working correctly my project was in the same sub directory with spaces in its name so surely that can be eliminated as a possibility. A also double checked everything and looks for other copies of my scenery object elsewhere (in case I had links to other versions of the scenery object) on my PC and found NONE.

Anyway I am happy to advise that it is now working (correct footprint).
After trying so many different 'variants' including deleting .packageint etc and removing every scenery object except the 'problem child' from the modellib folder and rebuilding and deleting the .bgl from the LOM and then 'adding' the .bgl (which then only have ONE scenery object) the footprint was still not displaying the additions to be scenery model/object.

In DESPERATION I deleted the entire ADE 19 folder (my scenery objects are in a completely different location), reinstalled ADE 19 and applied the HF1 update, ran ADE 19 and entered all the relevant data indluding where my projects files are located, did a BUILD, added my library with LOM (which of course did not exist now with a fresh installation) and the footprint is now correct! Once again ALL I DID was to remove ADE 19 and reinstall and set 'pointers' to where my project files are.
I also IMPORTED the .gltf for my project into Blender and proved that I had exported correctly and then exported it for ADE.

Well after that happened I then made more changes to my object, exported them and replaced the scenery objects files in H:/ADEprojects, run ADE 19 again, did a build, updated the LOM and guess what. YES the foot print for the previous object was displayed. I GIVE UP. Do I have to remove and reinstall ADE 19 everytime I change a scenery object6 for the footprint to be correct (remember regardless of the incorrect footprint the changes get through to MSFS.

ADE 19 must be retaining certain things as a fresh installation fixed my problem.

Does anyone have any ideas what or why?

[added later]
Should the compiled/built .bgl file be deleted before (re)building? I have never done so before but just wondered particularly since I noticed that when ADE 19 is (re)installed and LOM is used to add a library (the .bgl built) there is a noticable time lag (before ADE advises how many objects were added) which isn't nearly as long as when I delete a scenery library (previously added) and then add the library. It's as if ADE doesn't 'do' as much work when adding back a library that previously existed.
Now there is another question.
After making changes to scenery objects (say in Blender) and I want to incorporate those changes is it necessary to DELETE an existing library and then ADD it back or simply select (lmb) ADD and ADE be smart enough to only update changes?
Last edited:
I have it solved at last after many hours. [added later] NO I thought that I solved it but the problem continued and appears to be a fault with ADE - see my later post I have proved that ADE 19 is not updating footprints for changes to scenery objects.]

At first I had all my projects stored in a subdirectory on my H: drive (about 4 levels down from root location). On suggestion I copied (NOT MOVED) the folder to a root folder on H: eg H:/ADEPojects and that is the location what I also had ADE19 set up to use. I had a 'pointer' somewhere still pointing to the OLD folder which still exists. I should have zipped up that folder and then removed it to save any confusion which I didn't think was possible.
OR should have left my projects in the original location instead of copying them to the new root directory. I still live by the saying "if it ain't broke don't fix it"!

Now I have to find if there is a method to remove or exclude parking locations for MSFS stock airports as the ones they have for Vancouver Harbour Airport are NOT in correct locations and my some of my docks, which are based EXACTLY in the correct locations according to satellite imagery have some of those parking locations on top of some docks.

Any ideas if it is possible to create an airport and exclude an existing stock MSFS airport?
Last edited: