• Which the release of FS2020 we see an explosition of activity on the forun and of course we are very happy to see this. But having all questions about FS2020 in one forum becomes a bit messy. So therefore we would like to ask you all to use the following guidelines when posting your questions:

    • Tag FS2020 specific questions with the MSFS2020 tag.
    • Questions about making 3D assets can be posted in the 3D asset design forum. Either post them in the subforum of the modelling tool you use or in the general forum if they are general.
    • Questions about aircraft design can be posted in the Aircraft design forum
    • Questions about airport design can be posted in the FS2020 airport design forum. Once airport development tools have been updated for FS2020 you can post tool speciifc questions in the subforums of those tools as well of course.
    • Questions about terrain design can be posted in the FS2020 terrain design forum.
    • Questions about SimConnect can be posted in the SimConnect forum.

    Any other question that is not specific to an aspect of development or tool can be posted in the General chat forum.

    By following these guidelines we make sure that the forums remain easy to read for everybody and also that the right people can find your post to answer it.

Help with services.xml

Christian Bahr

Resource contributor
Messages
848
Country
germany
Thank you both for the answers. Now I had changed the value "frequency=0.0" to "frequency=0", but it didn't work.

I tried this file for another test, but it didn't help either:

Code:
<SimBase.Document Type="ServiceFile">
<Service.ParkingSpaceServices>
<ParkingSpace name ="RAMP GA" MinParkingSpaces=0>
<ParkingTypes>
<ParkingEntry ParkingType="RAMP_GA"/>
<ParkingEntry ParkingType="RAMP_GA_SMALL"/>
<ParkingEntry ParkingType="RAMP_GA_MEDIUM"/>
<ParkingEntry ParkingType="RAMP_GA_LARGE"/>
<ParkingEntry ParkingType="RAMP_MIL_COMBAT"/>
<ParkingEntry ParkingType="RAMP_MIL_CARGO"/>
<ParkingEntry ParkingType="GATE_SMALL"/>
<ParkingEntry ParkingType="GATE_MEDIUM"/>
<ParkingEntry ParkingType="GATE_HEAVY"/>
<ParkingEntry ParkingType="VEHICLE"/>
</ParkingTypes>

<IdleWorkers>
</IdleWorkers>

<Services>
<Service name ="SmallPushBack" Filename="Shared\Asobo_PushBack\SmallPushBack" AIType="SmallPushback" Frequency="0"
SpawnDistanceParkingRadiusFactor="1.0" SpawnDistanceAdditionalOffset="2.0" SpawnAngleFromParking="-10" HeadingFromParkingHeading="150"/>
</Services>

<SleepingActivities>
<SleepingAirlinerServices Probability ="1.0" Timer ="30"/>
<SleepingSmallPlaneRefueling Probability ="1.0" Timer ="30"/>
</SleepingActivities>

</ParkingSpace>

</Service.ParkingSpaceServices>

<Service.AirportServices>
<Services>
<Service name ="Fuel" Filename="Shared\Asobo_Fuel\Fuel" ParkingType="VEHICLE" Frequency="0"/>
</Services>
</Service.AirportServices>
</SimBase.Document>

With the above file, it looks like this in EDLE in MSFS:
msfs_edle_airport_services.jpg

The path to the Service.xml under PackageSource is this:

msfs_services_package_source_path.jpg

The path in the finished package is this, the entry in the layout.json file is also correct:

msfs_services_package_path.jpg

Entry layout.json:

msfs_edle_layyout_json.jpg


Maybe it has less to do with the Service.xml and more to do with the configuration of LivingWorldTraffic?! I probably have to try something else :-(
 

Christian Bahr

Resource contributor
Messages
848
Country
germany
Hi, feedback from me.

It finally worked, the little pushbackers and the airport workers are gone:

msfs_edle_services.jpg


It was due to an undefined type of medium parking spot (RAMP_GA_MEDIUM). The XML file looks like this, maybe it will help one or the other:

Code:
<SimBase.Document Type="ServiceFile">
<Service.ParkingSpaceServices>
<ParkingSpace name ="RAMP SMALL">
<ParkingTypes>
<ParkingEntry ParkingType="RAMP_GA_MEDIUM"/>
<ParkingEntry ParkingType="RAMP_GA_SMALL"/>
<ParkingEntry ParkingType="RAMP_GA"/>
</ParkingTypes>
<IdleWorkers>
</IdleWorkers>
<Services>
</Services>
<SleepingActivities>
</SleepingActivities>
</ParkingSpace>
</Service.ParkingSpaceServices>
<Service.AirportServices>
<Services>
</Services>
</Service.AirportServices>
</SimBase.Document>

Thanks for the great support! :)

PS: A completely different question is how to get the vehicles away
 
Top