Here we go again....

hairyspin

Resource contributor
Hmmm. Perhaps a software update might be an idea. Any particular reason to stick with XP? I’m only curious.
 

Vitus

Resource contributor
Just experienced the same issue.
Fatal error: Uncaught XF\Db\Exception: Connection refused in /var/www/vhosts/fsdeveloper.com/httpdocs/forum/src/XF/Db/Mysqli/Adapter.php:165 Stack trace: #0 /var/www/vhosts/fsdeveloper.com/httpdocs/forum/src/XF/Db/Mysqli/Adapter.php(28): XF\Db\Mysqli\Adapter->makeConnection(Array) #1 /var/www/vhosts/fsdeveloper.com/httpdocs/forum/src/XF/Db/AbstractAdapter.php(60): XF\Db\Mysqli\Adapter->getConnection() #2 /var/www/vhosts/fsdeveloper.com/httpdocs/forum/src/XF/Db/Mysqli/Adapter.php(113): XF\Db\AbstractAdapter->connect() #3 /var/www/vhosts/fsdeveloper.com/httpdocs/forum/src/XF/Db/AbstractAdapter.php(516): XF\Db\Mysqli\Adapter->escapeString('options') #4 /var/www/vhosts/fsdeveloper.com/httpdocs/forum/src/XF/Db/AbstractAdapter.php(494): XF\Db\AbstractAdapter->quote('options') #5 /var/www/vhosts/fsdeveloper.com/httpdocs/forum/src/XF/DataRegistry.php(138): XF\Db\AbstractAdapter->quote(Array) #6 /var/www/vhosts/fsdeveloper.com/httpdocs/forum/src/XF/DataRegistry.php(83): XF\DataRegistry->readFromDb(Array, Array) #7 /var/www/vhosts/ in /var/www/vhosts/fsdeveloper.com/httpdocs/forum/src/XF/Db/Mysqli/Adapter.php on line 165
 

arno

Administrator
Staff member
FSDevConf team
Resource contributor
I just got an email about a short downtime as well.

But like I said before, this is something at the webhost, I do not have control or access to the MySQL server. If it happens very often I will file a support ticket for them.
 
While attempting to access FSDev initially, or navigating link to link (with lag) on the web site last night, I repeatedly saw this status message in Mozilla FireFox:

"connecting to fonts.lug.ustc.eu.cn..."


Thus far the only query result that seems remotely related was at this URL:

https://lug.ustc.edu.cn/wiki/intro_english


Anyone else seen this ? :scratchch


BTW: The FSDev web site is rather nicely responsive this morning. :cool:

GaryGB
 
Last edited:

arno

Administrator
Staff member
FSDevConf team
Resource contributor
Was that on a specific page? Might be some image or signature is hosted there.
 
IIRC, I saw that message when clicking on every link at FSDev.; every click and subsequent page render was lagging.

FYI: I began seeing it on a few other web sites last night as well.


It was seen in FireFox v75.0 (64-Bit).


BTW: I have not seen that message (anywhere) yet his morning, however. :scratchch

GaryGB
 
Yeah I have been getting

Fatal error: Uncaught XF\Db\Exception: Connection refused in /var/www/vhosts/fsdeveloper.com/httpdocs/forum/src/XF/Db/Mysqli/Adapter.php:165

on the login page every now and then for the past 2 afternoons/evening (peak time). I just figured it was a surge in member traffic. So I waited and eventually got on.

But I thought others had to been affected, because at one instance I saw that the who's on had 1 member and 105 guests. I was pretty certain that was not usual for FSD,

But happy to say, like Gary; I've had no issues Today.

~WEB~
 

Vitus

Resource contributor
FYI and to add to the record. This just happend at 2:42 GMT+1:
Fatal error: Uncaught XF\Db\Exception: Connection refused in /var/www/vhosts/fsdeveloper.com/httpdocs/forum/src/XF/Db/Mysqli/Adapter.php:165 Stack trace: #0 /var/www/vhosts/fsdeveloper.com/httpdocs/forum/src/XF/Db/Mysqli/Adapter.php(28): XF\Db\Mysqli\Adapter->makeConnection(Array) #1 /var/www/vhosts/fsdeveloper.com/httpdocs/forum/src/XF/Db/AbstractAdapter.php(60): XF\Db\Mysqli\Adapter->getConnection() #2 /var/www/vhosts/fsdeveloper.com/httpdocs/forum/src/XF/Db/Mysqli/Adapter.php(113): XF\Db\AbstractAdapter->connect() #3 /var/www/vhosts/fsdeveloper.com/httpdocs/forum/src/XF/Db/AbstractAdapter.php(516): XF\Db\Mysqli\Adapter->escapeString('options') #4 /var/www/vhosts/fsdeveloper.com/httpdocs/forum/src/XF/Db/AbstractAdapter.php(494): XF\Db\AbstractAdapter->quote('options') #5 /var/www/vhosts/fsdeveloper.com/httpdocs/forum/src/XF/DataRegistry.php(138): XF\Db\AbstractAdapter->quote(Array) #6 /var/www/vhosts/fsdeveloper.com/httpdocs/forum/src/XF/DataRegistry.php(83): XF\DataRegistry->readFromDb(Array, Array) #7 /var/www/vhosts/ in /var/www/vhosts/fsdeveloper.com/httpdocs/forum/src/XF/Db/Mysqli/Adapter.php on line 165
 
Chrome is working amazing here.
Chrome is all I use, and so far I have had the fatal error happen about 4-5 times in the past 3-4 days... Usually for me, a telltale sign is the extreme lag in loading the next page. I first thought it was just on the login page, but yesterday it happened while conversing with Pyscen, as he has been diligently trying to help me grasp an understanding of Blender. I thought I was causing the error at first, due to the enormous amount of screenshots I have been posting for Pyscen to see how things were going, or failing in my case.

~WEB~
 
I’m occasionally getting very long page loading times. That’s true in iOS13/Safari, MacOS Catalina/Firefox and Win10-1909/Firefox.
 
While attempting to access FSDev initially, or navigating link to link (with lag) on the web site last night, I repeatedly saw this status message in Mozilla FireFox:

"connecting to fonts.lug.ustc.eu.cn..."


Thus far the only query result that seems remotely related was at this URL:

https://lug.ustc.edu.cn/wiki/intro_english


Anyone else seen this ? :scratchch


BTW: The FSDev web site is rather nicely responsive this morning. :cool:

GaryGB
I started seeing the above described page load lag and "connecting to fonts.lug.ustc.eu.cn..." at 'other' web sites last night (but not at FSDev ...yet).

Anyone else seen this ? :scratchch

GaryGB
 
Hi again:

I found some new info on related to the ongoing issue cited immediately above:

"connecting to fonts.lug.ustc.eu.cn..."



"Since Google took the wind, the default Google fonts of WordPress have followed the wind, showing that some pages that use specific fonts need to "take a long time to open."


"ustc.edu.cn

HTTPS Everywhere currently rewrites requests to ustc.edu.cn (or its subdomains).


Embedded content loaded from third-party domains (for example, YouTube, Google Analytics, ad networks, or CDNs) may also be affected. You can test this by loading the web page in question in a browser with HTTPS Everywhere installed and pulling down the HTTPS Everywhere rules menu. This will show a list of HTTPS Everywhere rules that were applied as the page was loaded, including rules that might have affected embedded content from other domains."







More info to come as I chase this down.... :coffee:

GaryGB
 
Last edited:
This evening#:

Fatal error: Uncaught XF\Db\Exception: Connection refused in /var/www/vhosts/fsdeveloper.com/httpdocs/forum/src/XF/Db/Mysqli/Adapter.php:165 Stack trace: #0 /var/www/vhosts/fsdeveloper.com/httpdocs/forum/src/XF/Db/Mysqli/Adapter.php(28): XF\Db\Mysqli\Adapter->makeConnection(Array) #1 /var/www/vhosts/fsdeveloper.com/httpdocs/forum/src/XF/Db/AbstractAdapter.php(60): XF\Db\Mysqli\Adapter->getConnection() #2 /var/www/vhosts/fsdeveloper.com/httpdocs/forum/src/XF/Db/Mysqli/Adapter.php(113): XF\Db\AbstractAdapter->connect() #3 /var/www/vhosts/fsdeveloper.com/httpdocs/forum/src/XF/Db/AbstractAdapter.php(516): XF\Db\Mysqli\Adapter->escapeString('options') #4 /var/www/vhosts/fsdeveloper.com/httpdocs/forum/src/XF/Db/AbstractAdapter.php(494): XF\Db\AbstractAdapter->quote('options') #5 /var/www/vhosts/fsdeveloper.com/httpdocs/forum/src/XF/DataRegistry.php(138): XF\Db\AbstractAdapter->quote(Array) #6 /var/www/vhosts/fsdeveloper.com/httpdocs/forum/src/XF/DataRegistry.php(83): XF\DataRegistry->readFromDb(Array, Array) #7 /var/www/vhosts/ in /var/www/vhosts/fsdeveloper.com/httpdocs/forum/src/XF/Db/Mysqli/Adapter.php on line 165
 
Top