• Which the release of FS2020 we see an explosition of activity on the forun and of course we are very happy to see this. But having all questions about FS2020 in one forum becomes a bit messy. So therefore we would like to ask you all to use the following guidelines when posting your questions:

    • Tag FS2020 specific questions with the MSFS2020 tag.
    • Questions about making 3D assets can be posted in the 3D asset design forum. Either post them in the subforum of the modelling tool you use or in the general forum if they are general.
    • Questions about aircraft design can be posted in the Aircraft design forum
    • Questions about airport design can be posted in the FS2020 airport design forum. Once airport development tools have been updated for FS2020 you can post tool speciifc questions in the subforums of those tools as well of course.
    • Questions about terrain design can be posted in the FS2020 terrain design forum.
    • Questions about SimConnect can be posted in the SimConnect forum.

    Any other question that is not specific to an aspect of development or tool can be posted in the General chat forum.

    By following these guidelines we make sure that the forums remain easy to read for everybody and also that the right people can find your post to answer it.

Hierarchy Editor - model parts disappear

I have attached effects I need to move to a different model part in Hierarchy Editor.
I find that just by mouse clicking on a model part, the model will recompile in MCX and a part will disappear.
After export the the model will then be missing the part.

I've had this happen a number of times. Why should mouse clicking on a model part remove it if I do not touch the "Remove" button..?

MCX is the only app running, nothing open on my desktop.
 

arno

Administrator
Staff member
FSDevConf team
Resource contributor
Hi,

Clicking on nodes in the hierarchy editor will not remove parts of the model. Or are you dragging nodes to a different parent?
 
Hi,
Let me ask a different question. Can I move an Attached Effect using keystrokes..?
Dragging and dropping with the mouse is not really working for me.
See attached for what I am trying to do.
There are no-subsets of Model Part that only show JUST the light housings. I checked the entire tree.
 

Attachments

  • move.jpg
    move.jpg
    72.4 KB · Views: 12
  • move 2.jpg
    move 2.jpg
    65.1 KB · Views: 12

arno

Administrator
Staff member
FSDevConf team
Resource contributor
No, you can only move them to a different parent node by selecting them and then dragging them with the mouse over the new parent.

It might be that you have to reset the transformation after you dropped them on a new parent, as the old transformation might give them a big offset.
 

tgibson

Resource contributor
Change all the Translation transformations to 0, and then see if you can adjust it to where it should be?
 
Change all the Translation transformations to 0, and then see if you can adjust it to where it should be?
I changed to "0" and the attached effect went off to a different location.

I then moved it to the intended parent and at least it tracks with the intended animation...hope..!
 

Attachments

  • trans 1.jpg
    trans 1.jpg
    127.2 KB · Views: 6
  • trans 2.jpg
    trans 2.jpg
    135.3 KB · Views: 7
Last edited:
Hi,

Clicking on nodes in the hierarchy editor will not remove parts of the model. Or are you dragging nodes to a different parent?
Sorry to say I can use the left mouse button and while clicking nodes to check which is associated with what, watch the model recompile
in MCX and remove the model part. This has happened over a dozen times now.

I will try for singular movements followed by a recompile.
 

arno

Administrator
Staff member
FSDevConf team
Resource contributor
What do you mean with recompile? The model is only compiled when you use the export function.

Changing the selected node can affect the preview, for example which part is highlighted.
 
What do you mean with recompile? The model is only compiled when you use the export function.

Changing the selected node can affect the preview, for example which part is highlighted.
I meant to say the preview screen. I've seen the model disappear for a split second like its recompiling and then re-appear missing a part.
 
I have a pretty good handle on the process now but have run into a problem where I am stopped from dragging and dropping the attached effect.
I move the effect in slow steps which works OK but am now stopped as there are no model entries to move to.
There is a block of 60+ non model entries that will not allow the effect to be attached.
 

Attachments

  • he.jpg
    he.jpg
    91.7 KB · Views: 6

arno

Administrator
Staff member
FSDevConf team
Resource contributor
When you go with the mouse near the edge of the list it will scroll up or down, that way you can move a node over a bigger distance.
 
I wanted to make sure I wasn't fat fingering
Holding the left mouse key on the attached effect and moving to the top of the drop down list does not scroll the selection.
 

Attachments

  • he.jpg
    he.jpg
    129.6 KB · Views: 4

tgibson

Resource contributor
Tony's right, in the 1.4 Hierarchy Editor you cannot drag it anywhere outside the visible window.

A Cut/Paste capability would make this so much simpler...
 

arno

Administrator
Staff member
FSDevConf team
Resource contributor
But in the latest development release you can :)
 
After adding and editing 15 attachment points I found that after working in the hierarchy editor a part went missing. Is it possible to grab the part from an earlier mdl file and import it into the current mdl..?
OR can the current 15 attachment points be copied and imported into a new mdl file..?
 

arno

Administrator
Staff member
FSDevConf team
Resource contributor
Hi,

You can not drag nodes between different instances of MCX. Would you can do is isolate a part and export it to MDL. Then you can merge it into another object.

Do you have an idea in which situation you lost a part, because that sounds like a bug.
 
Hi,

You can not drag nodes between different instances of MCX. Would you can do is isolate a part and export it to MDL. Then you can merge it into another object.

Do you have an idea in which situation you lost a part, because that sounds like a bug.
It was while mouse clicking around in the HE looking for a specific attachment point.
 
When bringing in a new mdl object, is there a way to get exact offset information from the parent to enter on the Merged Objects window..?

Once merged with the parent is there a way to adjust the placement of the newly merged model part..?
 

arno

Administrator
Staff member
FSDevConf team
Resource contributor
When bringing in a new mdl object, is there a way to get exact offset information from the parent to enter on the Merged Objects window..?

That's a bit of trial and error normally. There is no way measure the offset between different parts.

Once merged with the parent is there a way to adjust the placement of the newly merged model part..?

That depends. If the part is animated or has an unique material you will find it in the hierarchy editor and you can tune the transformation.
 
Top