FSX How to prevent autogen and scenery interfering?

Horst18519

Moderator
Staff member
Resource contributor
#1
I've got a weird problem here. We all know that a scenery object excludes autogen, which might lead to ugly autogen spaces close to huge objects like airports.

I'm working on several islands at the moment, some of them consisting of just 1 huge MDL, that includes all buildings and custom vegetation. I place it on the photo scenery island, which also has autogen I placed with the annotator.
Now the big surprise: Even though the MDL covers the whole island, the autogen displays correctly, popping up all over the island between the houses and custom trees.
On some of the islands though this does not work: autogen is excluded beneath the MDLs.

Has anybode an explanation for this?

I guess I'd better show you what I'm talking about... see attached image.
You can see 6 different MDLs because I split the scenery into very_sparse to extremely_dense and placed all 6 files at the same location.
The dark green trees are autogen palms. This actually works!
 

Attachments

Last edited:

arno

Administrator
Staff member
FSDevConf team
Resource contributor
#2
Hi Thorsten,

Is this all in FSX, using FSX MDL files? And you did not use the option in the XML file to prevent autogen suppression on those objects as well?

I would be surprised to see autogen within the bounding boxes of your MDL files in other cases, but maybe you can found a little bug in the scenery engine (or should we call it is useful feature :)).
 

Horst18519

Moderator
Staff member
Resource contributor
#3
"Autogen suppression", that's the search term I should've used, then I would've found this topic.

Thanks Arno, you're my saviour! Erm... :D


Weird though, that I did not use this line in the XML and it still doesn't suppress autogen as you can see in the image above. I will have to figure why this happens, but it might indeed be some sort of bug, erm, I mean feature. :)
 

Horst18519

Moderator
Staff member
Resource contributor
#4
Oh, I found it already! It's the "altitudeIsAgl" option.

My islands are pretty flat (Maldives), so I didn't use a flatten command and still was able to use one big MDL placed at 0.0f MSL (!). So the line is:

... altitudeIsAgl="FALSE" ...

I guess the object is placed some inches below the terrain, because the island elevates for about 1 or 2 feet in its middle. Now, it looks like if an object is placed below ground level it won't affect autogen.

Could somebody test this? :)
 

arno

Administrator
Staff member
FSDevConf team
Resource contributor
#5
Hi Thorsten,

That is an interesting find. I did some tests and I would say that any objects with the altitudeIsAgl set to FALSE has no autogen suppression. To me it does not seem to matter if it is placed under the ground or just above it. So this might be a nice alternative to the NoAutogenSuppresion flag.
 

Horst18519

Moderator
Staff member
Resource contributor
#6
If the suppression tag didn't exist this would certainly be a trmendous find, but of course you can always use the tag.

But who knows how useful this can be someday. :)
 

arno

Administrator
Staff member
FSDevConf team
Resource contributor
#7
If the suppression tag didn't exist this would certainly be a trmendous find, but of course you can always use the tag.

But who knows how useful this can be someday. :)
Maybe it also works with FS2004, that would be a nice find :). But for FSX it is of less value indeed.
 
#8
FYI: New run time rendering issues have been reported with placement of scenery library objects with their RefPoints below local ground level:

http://www.simforums.com/Forums/topic51980_post324405.html#324405


Not only does disabling of Autogen suppression result, but apparently also, "square shadow display" in ex: FS default scenery library vegetation objects with certain Material setting in their MDLs. :alert:


Possibly this is also related to "different" / processing of Material 'texture display' attributes in MDLs ? :idea:

http:// www.fsdeveloper.com/forum/threads/x40-kinf-inverness-florida.429786/page-3


It would be interesting to learn more about this to see how it may be further used (in a predictable and controlled manner) ! :scratchch

GaryGB
 
Last edited:
#9
The shadow issue reported in the Inverness thread is pertinent to P3D2 only and has to do with the rendering engine detecting the alpha channel in the texture and displaying a shadow accordingly, FSX doesn't pay any attention to the texture and renders a shadow based solely on the geometry of the object itself which is why he's seeing square shadows. Vegetation shadows should always be suppressed in FSX. <noshadow/> in the placements would have been the correct approach, setting the trees below ground level merely buries the shadow.
 
#10
Indeed; I'd not seen those "square" shadows before, as I always suppress the shadow either in the MDL or in the BGLComp placement code.

[EDITED]

One might wonder whether placement of a scenery library object RefPoint at a negative elevation 'offset' below local ground surface level may affect the ability of FS to properly display objects at run time in other ways in addition to enabling shadow suppression / disabling autogen suppression. :scratchch

Perhaps processing of BGLComp XML placement parameters in BGLs may eliminate the "shadow anomaly" discussed above, as a result of how material attributes for textures in a MDL are processed for objects if RefPoints are "placed underground", but the greater visual portion of the object "protrudes above ground" ? :idea:

[END_EDIT]

It would be interesting to find a workaround for display of shadows in FSX which utilizes material texture attributes like in P3D. :wizard:

GaryGB
 
Last edited:
Top